Closed Bug 1653413 Opened 3 months ago Closed 3 months ago

URL status bar does not go away immediately, causing overlapping

Categories

(Core :: Graphics: WebRender, defect)

80 Branch
x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- verified

People

(Reporter: Fanolian+BMO, Assigned: lsalzman)

References

(Regression)

Details

(4 keywords)

Attachments

(5 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0
Build ID: 20200716094032

Steps to reproduce

  1. Open attached testcase.
  2. Hover over the first line.
  3. Move mouse away from first line and quickly hover over the second line.

Acutal result

First URL is not dismissed, overlapping under second URL.

Expected result

First URL is immediately dismissed and only the second URL is shown.

Note

  1. If I reduce the browser window height to very short, the issue cannot be reproduced.
  2. Looks like at most 2 URLs will be overlapping with each other.
Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1650984

Are you using Software WebRender?

Flags: needinfo?(Fanolian+BMO)
Attached file about:support
(In reply to Lee Salzman [:lsalzman] from comment #2)
> Are you using Software WebRender?

No. It's a brand new profile with WebRender enabled by default.

````

(reuploading the about:support page)

(In reply to Lee Salzman [:lsalzman] from comment #2)

Are you using Software WebRender?

No. It's a brand new profile with WebRender enabled by default.
I don't have the pref gfx.webrender.software in about:config as mentioned in bug 1653374.

It's on Win10 1909, Nvidia GTX 760 with driver v446.14.

Flags: needinfo?(Fanolian+BMO)
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Assignee: nobody → lsalzman
Attachment #9164197 - Attachment is obsolete: true
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/98279b68955c
update DCLayerTree surface rects at end of frame. r=gw
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Duplicate of this bug: 1653424
Duplicate of this bug: 1653420
Duplicate of this bug: 1653426

Thanks for the fix.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1653493
Duplicate of this bug: 1653503
Duplicate of this bug: 1653395
You need to log in before you can comment on or make changes to this bug.