Closed Bug 1663935 Opened 7 months ago Closed 7 months ago

Address book: Searching in displayed mailing list directory fails with display artifacts

Categories

(Thunderbird :: Address Book, defect, P2)

Tracking

(thunderbird_esr78+ fixed)

RESOLVED FIXED
82 Branch
Tracking Status
thunderbird_esr78 + fixed

People

(Reporter: joel.bazin, Assigned: darktrojan)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: [TM:78.3.x])

Attachments

(3 files)

Attached image After search

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

Select a List in the address book, and then type a existing string in the search box.

Actual results:

The email list is not filtered.
And if I drag the mouse over the email list, all fields become blank.

Expected results:

The email list must be filtered, as It does when we search on Address book root or at the root of Personal Adress

Attached image Before search

Confirming exactly as described for 82.0a1 (2020-09-07) (64-bit) and 78.2.1 (64-bit). Couldn't find a dupe.
Odd. Can we fix this fast?

Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Summary: Search in address book list failed → Address book: Searching in displayed mailing list directory fails with display artifacts

STR for bisecting:

  1. Create mailing list using 68esr with new profile and quit
  2. Start a comm-central build with the profile of step1
  3. Select a List in the address book, and then type a existing string in the search box

#1 Regression window: Search does not work. i.e nothing happens.
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=e7476e934b191ffac787208323191c9c034049ce&tochange=72b1cec1260e68511a8b99d0e72fd8b0cefd44dc
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3fa65bda1e506a314ea90d936f763c7e840ab98a&tochange=3fa65bda1e506a314ea90d936f763c7e840ab98a

#2 Regression window: Search does not work. i.e nothing happens. And list items(except icon) disappear when mouse over list.
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=ffa711650cb168714e3e6179267ab8656e8d47b5&tochange=a34c59e873c92c1d65c9dd3715d260698083d887
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a34695d9b99d1e9098e846b751c9adf1f52ee760&tochange=a34695d9b99d1e9098e846b751c9adf1f52ee760

Bug 1633620 is in the range so should be from that.

Regressed by: 1633620

I knew it was that bug the moment I saw it.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
See Also: 982887

This is the same as the implementation in AddrBookDirectory except without the mailing list pieces
(mailing lists don't have mailing lists).

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/b168d5981f41
Implement nsIAbDirectory.search in mailing lists. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Duplicate of this bug: 1665596

Comment on attachment 9174810 [details]
Bug 1663935 - Implement nsIAbDirectory.search in mailing lists. r?mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1633620
User impact if declined: can't search within mailing list

Should take this on 78 after some beta testing.

Attachment #9174810 - Flags: approval-comm-esr78?
Duplicate of this bug: 1666180
Whiteboard: [TM:78.3.x]
Duplicate of this bug: 1666728

Comment on attachment 9174810 [details]
Bug 1663935 - Implement nsIAbDirectory.search in mailing lists. r?mkmelin

[Triage Comment]
Approved for esr78

Attachment #9174810 - Flags: approval-comm-esr78? → approval-comm-esr78+

Does this need any more flags to land on ESR78?

Duplicate of this bug: 1668854

No.

You need to log in before you can comment on or make changes to this bug.