Closed Bug 1666497 Opened 1 year ago Closed 1 year ago

Fix a couple issues with anchored popups uncovered by bug 1665476.

Categories

(Thunderbird :: General, defect)

defect

Tracking

(thunderbird_esr78 wontfix, thunderbird82 wontfix)

RESOLVED FIXED
83 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird82 --- wontfix

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

No description provided.

The patch in bug 1666497 (which makes regular <window>-based XUL
documents with other the XHTML-based ones) uncovers an issue in the
anchored popup tests, which starts timing out.

The underlying issue is that it changes the reflow order from popups in
XUL-only documents with respect to their anchors. Note that Firefox
already uses the "broken" code, because we moved to xhtml and
browser.xhtml doesn't use a XUL <window> anymore.

Since we reflow now the popup after the anchor rather than before, we
don't need to rely on CheckForAnchorChange() to deal with changes. This
means that we need to notify on the positioning changes that happen
during reflow though.

We should be able to simplify a bit the CheckForAnchorChange() stuff
now, but it also takes care of hiding popups and such so I don't plan to
do it on this bug to minimize risk.

Status: NEW → ASSIGNED
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b76f477b19c
Fix various issues with anchored popups. r=NeilDeakin
Attachment #9177138 - Attachment description: Bug 1666497 - Fix various issues with anchored popups. r=neildeakin,tnikkel → Bug 1666497 - Fix various issues with anchored popups. r=NeilDeakin
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/368f054779b2
Fix various issues with anchored popups. r=NeilDeakin

Before my patch we were skipping some popuppositioned events, so it's
not unexpected that this count can go up as a result.

Attachment #9179619 - Attachment description: Bug - Increase the number of allowed reflows in browser_appmenu.js. r=mconley,gijs → Bug 1666497 - Increase the number of allowed reflows in browser_appmenu.js. r=mconley,gijs
Blocks: 1669243
Attachment #9179619 - Attachment description: Bug 1666497 - Increase the number of allowed reflows in browser_appmenu.js. r=mconley,gijs → Bug 1666497 - Don't flush layout from popuppositioned events. r=gijs,mconley
Duplicate of this bug: 1669243
Flags: needinfo?(emilio)
Duplicate of this bug: 1296442
Blocks: 1252224
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/741543bb9d41
Fix various issues with anchored popups. r=NeilDeakin
https://hg.mozilla.org/integration/autoland/rev/cdec58fb4132
Don't flush layout from popuppositioned events. r=mconley,Gijs,smaug
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
See Also: → 1669686
Regressions: 1670317
Regressions: 1670410
Regressions: 1670452
You need to log in before you can comment on or make changes to this bug.