Closed Bug 1668142 Opened 4 years ago Closed 4 years ago

Rotor doesn't return results when AXDirectionPrevious is used with no start element.

Categories

(Core :: Disability Access APIs, defect, P1)

All
macOS
defect

Tracking

()

RESOLVED FIXED
83 Branch
Tracking Status
firefox82 --- wontfix
firefox83 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [mac2020_2])

Attachments

(1 file, 1 obsolete file)

STR:

  1. Load data:text/html,<div><a href="a">one</a></div><div><a href="b">two</a></div><div><a href="c">three</a></div>
  2. Go to last item with VO next
  3. Press VO+Left

Result:
Cursor is unresponsive, after repeated presses it goes to the second link, and then it goes to the webarea

Expected:
VO cursor should go back to the second and first link respectively with each press of VO+left

It looks like a previous search that is done with no start element won't return any items.

Assignee: nobody → eitan
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/05c9cc6dd872
Support AXDirectionPrevious in rotor with no start element. r=morgan
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/80827b9f7918
Support AXDirectionPrevious in rotor with no start element. r=morgan
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

Comment on attachment 9180223 [details]
Bug 1668142 - Support AXDirectionPrevious in rotor with no start element. r=morgan!

Beta/Release Uplift Approval Request

  • User impact if declined: VoiceOver users will have difficulty moving the cursor backwards on some sites
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1668137, Bug 1668100
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): This isn't a small change, but it has tests and has been verified.
  • String changes made/needed:
Flags: needinfo?(eitan)
Attachment #9180223 - Flags: approval-mozilla-beta?
Attachment #9178636 - Flags: approval-mozilla-beta?
Attachment #9178636 - Flags: approval-mozilla-beta?

Is this a new issue? Nothing in this bug suggests it's a regression and given how late we are in the cycle I'm not sure it would qualify for uplift if not.

(same question as in bug 1668137)

Flags: needinfo?(eitan)

Yes, this bug is regressed by bug 1657418.

Flags: needinfo?(eitan)
Regressed by: 1657418
Has Regression Range: --- → yes

Since it is late in the cycle, and VoiceOver support in mac is still experimental, I think it is fine if this is declined beta.

Attachment #9180223 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Attachment #9180223 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: