Closed Bug 1669172 Opened 1 year ago Closed 10 months ago

Remove all code related to framescript usage (listener.js)

Categories

(Testing :: Marionette, task, P3)

Default
task

Tracking

(Fission Milestone:Future, firefox87 fixed)

RESOLVED FIXED
87 Branch
Fission Milestone Future
Tracking Status
firefox87 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [marionette-fission-reserve])

Attachments

(4 files)

Once all the WebDriver commands work with the JSWindowActor implementation successfully in all the Firefox builds we can go ahead and remove all the code related to the listener.js framescript.

We might still want to wait 1 or 2 releases after bug 1669169 reached mozilla-release to be sure to not regress anything.

This bug shouldn't block the Fission project.

Depends on: 1669174
Depends on: 1669176

Given that we enabled actors by default (bug 1669169) for Firefox 84, we will keep all the framescript code around for Firefox 85 (to be released on 2021-01-26). That way we have two major releases to bake the actor code, and to fix regressions as reported by users.

With the development on Firefox 86 - its merge day is set to 2020-12-14 - we should then plan to remove all the framescript code.

Summary: Remove code related to framescript usage (listener.js) → Remove all code related to framescript usage (listener.js)
Whiteboard: [marionette-fission-mvp]

Tracking marionette-fission-mvp bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7
No longer depends on: 1669176

Moving to the reserved backlog given that we cannot finish this bug this year. See comment 1 for details.

Whiteboard: [marionette-fission-mvp] → [marionette-fission-reserve]

Note that we are a bit behind with landing relevant code. As such we may have to delay this bug a bit further. Lets check back early in January what the stability of Marionette tests show.

Priority: P3 → P2
Blocks: 1681973
Depends on: 1683755

Just to see how it looks like I pushed a try build yesterday:
https://treeherder.allizom.org/jobs?repo=try&revision=3b0652c62be5390e0c624e9d0f28203aed0c96ce

By doing that work I noticed a couple of things we still have to do before we can get rid of the old code.

Depends on: 1684054
Blocks: 1684367
Blocks: 1684690
Depends on: 1664881
Depends on: 1684827

Blocked by various dependencies. Moving to P3 for now.

Priority: P2 → P3
Depends on: 1683193
Assignee: nobody → hskupin
Status: NEW → ASSIGNED

I just pushed the the code as WIP so that we have it publicly available. As mentioned before we should still wait probably until the 86 release before landing those pieces.

Depends on: 1685454
No longer depends on: 1664881
Depends on: 1661591

Does this marionette-fission-reserve bug need to block shipping Fission MVP?

Fission Milestone: M7 → ?

For now, I am assuming marionette-fission-reserve bugs don't need to block shipping Fission MVP.

Fission Milestone: ? → Future

As discussed with Julian we will do the required work for bug 1683193 once the old framescript code has been removed, simply to avoid an unnecessary duplicated implementation in an area that gets removed now.

Also bug 1661591 shouldn't be an actual blocker because it's not happening that often, and isn't forcing us to disable the actor support for end-users.

Given that no further bug reports have been filed for both Marionette and geckodriver since actors are enabled and the framescript code not running anymore, I'll go ahead and start the review process for these patches.

Blocks: 1683193
No longer depends on: 1661591, 1683193

There is actually one reported issue at https://github.com/mozilla/geckodriver/issues/1837 that I want to investigate / fix first, before landing these changes.

Depends on: 1690308
No longer blocks: 1681973
Blocks: 1680479
No longer depends on: 1690308

(In reply to Henrik Skupin (:whimboo) [⌚️UTC+1] from comment #15)

There is actually one reported issue at https://github.com/mozilla/geckodriver/issues/1837 that I want to investigate / fix first, before landing these changes.

This should actually not block. It's a rare situation that should basically not happen. We should only allow a single connection at a time. I filed bug 1691047 for restricting it.

Depends on: 1691348
Depends on: 1691683
Blocks: 1691683
No longer depends on: 1691683

With bug 1690308 another instance of the framescript decorator for the Marionette test had to be added. Once merged I will have to update the 2nd patch here.

Depends on: 1690308
Blocks: 1692542
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8781218cfac4
[marionette] Remove Marionette Framescript test jobs from Taskcluster. r=marionette-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/74add9dbce91
[marionette] Remove --disable-actors command line argument. r=marionette-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/07e433cbf1d8
[marionette] Remove all code related to framescripts. r=marionette-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/226b7b7e0ee8
[marionette] Remove references to Element Store. r=marionette-reviewers,jdescottes

I forgot to rebase and to remove the newly added usage of the framescript decorator.

Flags: needinfo?(hskupin)
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b4021ee7f0dc
[marionette] Remove Marionette Framescript test jobs from Taskcluster. r=marionette-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/1e6088681f84
[marionette] Remove --disable-actors command line argument. r=marionette-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/ec293f45d826
[marionette] Remove all code related to framescripts. r=marionette-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/791cc5bb75e7
[marionette] Remove references to Element Store. r=marionette-reviewers,jdescottes
Blocks: 1675175
Blocks: 1641273
See Also: → rm-framescripts
You need to log in before you can comment on or make changes to this bug.