Widgets in Modern skin should use CSS2 system fonts

VERIFIED FIXED

Status

P2
blocker
VERIFIED FIXED
19 years ago
8 years ago

People

(Reporter: ian, Assigned: hewitt)

Tracking

(Depends on: 1 bug, {access})

Trunk
access
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Since moving the XUL things like the size of the menus and the folder listing in
mail/news ignore the windows
 settings and just use the default ones. These should be linked to the windows
settings (ie the windows settings should be checked at Moz startup)


Lemming

Updated

19 years ago
Depends on: 3371
Summary: Font sizes not respected → Widgets should use CSS2 system fonts

Updated

19 years ago
OS: other → All
Hardware: PC → All

Updated

19 years ago
Assignee: trudelle → shuang
Component: XUL → UE/UI

Comment 1

19 years ago
UI detail dependent upon bug #3371

Updated

19 years ago
Assignee: shuang → pierre
Target Milestone: M15

Comment 2

19 years ago
reassign it to pierre since I don't really know what to do. Also set ( a much
later)same milestone as the dependency bug #3371.

Updated

19 years ago
Summary: Widgets should use CSS2 system fonts → Font sizes not respected
Target Milestone: M15

Comment 3

19 years ago
Something doesn't sound right here. I'm not sure Ian was refering to some
settings in the Windows-OS Control Panels.

Ian's comments, as well as his original summary line ("Font sizes not
respected"), make me think that the bug was about some settings from the
AppRunner Preferences panel that are currently ignored by the application.

Ian, could you confirm? Or if I'm wrong, could you rephrase your bug report
according to the guidelines? http://www.mozilla.org/quality/bug-writing-
guidelines.html

Changing the summary line back to "Font sizes not respected" from "Widgets should
use CSS2 system fonts".

Updated

19 years ago
Whiteboard: waiting for more info from reporter
(Reporter)

Comment 4

19 years ago
Sorry, I was unclear in my original report.

What I mean is that by default, UI componants such as the name of menus, text
under icons on toolbars etc are set to around size 10. This size can be modified
in the appearance tab of the windows display properties (right click desktop >
Properties).

By using XUL instead of the standard windows hooks, the size of the names on
menus etc _do not_ change according to the settings in the windows display
properties dialog. It should.

Updated

19 years ago
Summary: Font sizes not respected → Widgets should use CSS2 system fonts
Whiteboard: waiting for more info from reporter
Target Milestone: M15

Comment 5

19 years ago
Thanks Ian.

I'm keeping this bug for now. I'll reassign it to the XPToolkit team when the
CSS2 fonts are implemented (see #3371).

Comment 6

19 years ago
Pushing my M15 bugs to M16

Comment 7

19 years ago
Maybe this bug should be re-assigned to the UI team when you have fixed 3371?
I think the UI team is writing the CSS "skins" for the UI.

Comment 8

19 years ago
Sherry Wang (Browser Development - IBM, Austin TX - xiaotong@us.ibm.com) 

volunteered to do the work when I'm done with bug 3371.

Comment 9

19 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Updated

19 years ago
Blocks: 18135

Updated

19 years ago
Depends on: 33312, 33313
No longer depends on: 3371

Comment 10

19 years ago
Reassigned to ben. The Mac implementation works. GFX on Windows (bug 33312) and 
Unix (33313) needs to be completed.

Sherry: if you want to help on Windows or Unix (the 2 bugs above) or for the 
chromes (this bug), please contact the respective assignees: rods, pavlov and 
ben. Thanks!
Assignee: pierre → ben
Status: ASSIGNED → NEW

Updated

19 years ago
Blocks: 31417

Comment 11

19 years ago
I still would like to volunteer for this bug - modifying the chromes to use CSS2 
system fonts and colors.

Sherry Wang
xiaotong@us.ibm.com

Comment 12

19 years ago
This bug is similar to bug 1021.

Updated

19 years ago
Blocks: 37529

Updated

19 years ago
No longer blocks: 31417
non-essential skin work. shifting off. 
Status: NEW → ASSIGNED
Target Milestone: M16 → M30

Comment 14

19 years ago
Perhaps it is not essential to use CSS system fonts in the UI skins, but it does
seem quite important that the product adhere to the user's choice of font face
and size. This is an accessibility issue. Some people cannot read the default
font because it is too small, or not the right font face for them, etc. Ben, are
you saying that it is not important to consider these needs, or just that we can
achieve that goal via some means other than CSS system fonts?
*** Bug 18135 has been marked as a duplicate of this bug. ***

Comment 16

19 years ago
I'm surprised this has been pushed past M20, because based on my reading of the 
chrome files, all it requires (once the dependencies have been fixed) is a quick 
blat through one CSS file (xul.css, I think it was), adding relevant `font:' 
lines to the properties for each widget. And the improvement in appearance of the 
UI would be quite substantial.

Ben, if you really don't have time for this before M20, *please* reassign it to 
xiaotong@us.ibm.com who has volunteered to do it.

Comment 17

19 years ago
Ben, I will send you the changes to skin using CSS2 system fonts and colors 
shortly.

Comment 18

19 years ago
*** Bug 31417 has been marked as a duplicate of this bug. ***
Classic has been using system fonts on windows since the start. 
Unfortunately there are problems. Supposedly the system font support 
doesn't understand bitmap fonts like MS Sans Serif on Windows 95/98, 
so all fonts appear to be Times New Roman. Windows 2000 supplies MS 
Sans Serif in a different format however and it is understood and used by 
Mozilla correctly. cc'ing Michael Lowe, in case he has any ideas (?) 

Pierre informs me that system font support works on mac, but I've never 
seen it myself (running OS8.6 on my G3-450 all system font CSS is 
ignored.. now I *know* that it is possible on 8.6 because IE5 does it ;) I 
keep meaning to ask Pierre about this... 
(Reporter)

Comment 20

19 years ago
This bug really applies to the modern skin, since it will be the default. If 
Netscape are going to include other skins then they should also use system fonts 
(and the same when fonts are unspecified).

I have changed the summary to reflect this, change it back if you disagree.
Severity: minor → blocker
Summary: Widgets should use CSS2 system fonts → Widgets in all skins shipped with Mozilla/Netscape should use CSS2 system fonts

Comment 21

19 years ago
Ben: Just FYI, system fonts don't appear to be working at all under Linux. In
fact, in a build I compiled last night, changing the document font from "sans
serif" to "serif" in the prefs changed the UI font. (Maybe that's a separate
bug?)

Comment 22

19 years ago
*** Bug 44806 has been marked as a duplicate of this bug. ***
hm. Closing this bug as WONTFIX as I don't believe there was any intent to use 
system * in Modern. If you want a skin that tries to match your system settings, 
use classic ;) 
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX

Comment 24

18 years ago
This would handily solve the problems in bug 5236, and as Erik pointed out, it's
an accessibility issue, especially since the fonts in Modern are hardwired to be
so small, and since a patch has apparently already been supplied.

Sherry, do you still have your patch?  Could you attach it to this bug and add
the keyword "patch"?

Will reassign to Don since Ben doesn't want it.

Braden: I reopened bug 33313 since I agree with you that gtk system fonts don't
seem to be working (at least, Classic skin comes up with miniscule fonts whereas
normal gtk apps come up with nice readable fonts). 
Status: RESOLVED → REOPENED
Keywords: access
Resolution: WONTFIX → ---

Comment 25

18 years ago
Someone suggested reassigning this to don, but I'll wait and let Ben comment on
it.

Comment 26

18 years ago
adding "loose" dependency to 5236.
Blocks: 5236

Updated

18 years ago
Blocks: 51748

Comment 27

18 years ago
Turns out Pav's bug 33313 is a dup (but not marked as such) of 48907; adding
that dependency as well.
Depends on: 48907
To Paul, who will probably mark as WONTFIX again...
Assignee: ben → hangas
Status: REOPENED → NEW

Comment 29

18 years ago
*** Bug 55441 has been marked as a duplicate of this bug. ***

Comment 30

18 years ago
*** Bug 55463 has been marked as a duplicate of this bug. ***

Comment 31

18 years ago
adding dependancy - we can't do this till the modern skin is totally scalable.
Depends on: 55464

Comment 32

18 years ago
Changing summary slightly:

 * Remove "Netscape". They might feel differently about this, and they can track
this issue in the Netscape bug database if they need a separate resolution.

 * Changing "all skins" to "Modern2". That seems to be what this bug is tracking
at this point, and the notion that all skins that ship with Mozilla *must* use
system fonts seems a bit heavy-handed.
Summary: Widgets in all skins shipped with Mozilla/Netscape should use CSS2 system fonts → Widgets in Modern2 skin should use CSS2 system fonts

Comment 33

18 years ago
I don't understand. Is there such a thing as "Modern2"? Or are you saying that
we should create a new theme called Modern2, and make it use system fonts?

Comment 34

18 years ago
Alec, I found the place where the font-size is being set to 8.5pt (it's set to
3mm, which is the same):

  mozilla/xpfe/global/resources/locale/en-US/intl.css

In a commercial debug build on Linux, it's installed in:

  ns/dist/bin/chrome/en-US/locale/en-US/global/intl.css

Comment 35

18 years ago
For some reason I was under the impression that the Modern skin was called
Modern2.
Summary: Widgets in Modern2 skin should use CSS2 system fonts → Widgets in Modern skin should use CSS2 system fonts

Comment 36

18 years ago
erik: gack! We should see how things look without that... but I'll bet we still 
need to fix this.

Comment 37

18 years ago
nominate for rtm
Keywords: rtm

Comment 38

18 years ago
jar and/or hamerly to check this out on akkana's machine, since alecf sez the
bug can be demonstrated there.

Comment 39

18 years ago
This is my favorite bug.  I really want this one fixed, it is huge for everyone 
that wants to change their system fonts.  If we don't get this in rtm we will 
checkin a fix on the trunk for Modern as soon we can.  We may even create a 
version of Modern with this fix to be made available for those folks running N6.
Status: NEW → ASSIGNED
Priority: P3 → P2
Whiteboard: [rtm need into]

Comment 40

18 years ago
sending to hewitt
Assignee: hangas → hewitt
Status: ASSIGNED → NEW

Comment 41

18 years ago
Sadly marking rtm-
Whiteboard: [rtm need into] → [rtm-]

Comment 42

18 years ago
--> Themes. (Out of my component! Shoo! Shoo!)
Component: User Interface: Design Feedback → Themes
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 43

18 years ago
Created attachment 20584 [details] [diff] [review]
big long patch
changes look OK. andreww has provided review, 

a=ben@netscape.com
(Assignee)

Comment 45

18 years ago
Fixed.  System fonts are now honored -- all widgets that contain text can now
stretch in both dimensions.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Comment 46

18 years ago
Argh! I don't like this fix! On XFree86 3.3.6 under Linux with 100 dpi fonts,
the widgets become HUGE! Even at 75 dpi they're bigger than they were. I thought
that modern was beautiful before this, but now I'm just frustrated. Can anybody
tell me how to put this back to the way that it was?????
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 47

18 years ago
This bug _IS FIXED_.  The problem with large Linux fonts is a separate bug.

For those of you Linux users who can't stand the enormity of the new fonts, and 
don't want to wait for it to be fixed, you can put this in your userChrome.css 
file to restore sanity:

button, menubutton, menulist, menu, menuitem, tab, .button-toolbar, window {
  font-size: 12px !important;
}

You may want to tweak that font size to fit your preference.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
actually, things look really good now.  especially the mailnews thread pane.

thanks for the fix, hewitt.

Comment 49

18 years ago
Why do I have this?  This should never have been assigned to me...

qacontact->pmac
QA Contact: ckritzer → pmac

Comment 50

18 years ago
Marking verified (2001-01-24-09-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.