Closed Bug 167408 Opened 18 years ago Closed 13 years ago

padding on inline makes table cell overflow (incorrect max-element-width)

Categories

(Core :: Layout: Block and Inline, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: foux, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: testcase, Whiteboard: [line-breaking])

Attachments

(2 files, 1 obsolete file)

430 bytes, text/html
Details
742 bytes, text/html
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

In the page http://www.foux.net/CSS_padding_bug.html, the padded text in the
second cell of the table, is displayed beyond the table limits. When text
padding settings of the <B> style are removed, the text is displayed correctly.

Reproducible: Always

Steps to Reproduce:
1. http://www.foux.net/CSS_padding_bug.html


Actual Results:  
The text in the second cell of the table is displayed beyond the table limits.

Expected Results:  
The text in the second cell should not exceed the table limits.
I suspect the padding is not included in the MES... or this is a tables bug. 
bernd?  What do you think?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Hardware: PC → All
Blocks: 172565
this might be a dupe of bug 109927
Depends on: 109927
Priority: -- → P3
Target Milestone: --- → Future
Attached file testcase
It looks like this is problem with inline frames MES computation

      cell 02EDC13C r=0 a=UC,UC c=UC,UC cnt=865 
       block 02EDC19C r=0 a=UC,UC c=UC,UC cnt=866 
        inline 02EDC360 r=0 a=UC,UC c=UC,UC cnt=867 
         text 02EDC3CC r=0 a=UC,UC c=UC,UC cnt=868 
         text 02EDC3CC d=3000,285 me=3000 
        inline 02EDC360 d=4500,285 me=3000 
       block 02EDC19C d=4500,300 me=3000 
      cell 02EDC13C d=4560,360 me=3060 
Attached patch patch (obsolete) — Splinter Review
Comment on attachment 105208 [details] [diff] [review]
patch

Shouldn't you only add the right border if the border is adjacent to the chunk
of text that's causing the MES?  And doesn't the MES computation need to span
inline frames anyway, to handle things like

<span>foo</span>bar

?  What about the case where that span has a border, and you need to get the
correct value for both:

<span>a aoeuidhtns b</span>c

and

<span>abc</span>def

?
Attached file testcase
testcase with different scenarios as proposed by David
Attachment #105208 - Attachment is obsolete: true
*** Bug 194133 has been marked as a duplicate of this bug. ***
To correct component.
Assignee: attinasi → block-and-inline
Component: Layout → Layout: Block & Inline
QA Contact: petersen → ian
Priority: P3 → P2
Summary: text padding in a cell causes the text to be displayed beyond the table limits → padding on inline makes table cell overflow (incorrect max-element-width)
Whiteboard: [line-breaking]
Blocks: 161008
*** Bug 161008 has been marked as a duplicate of this bug. ***
Blocks: 217714
*** Bug 219995 has been marked as a duplicate of this bug. ***
*** Bug 239222 has been marked as a duplicate of this bug. ***
I've encountered this with an anchor tag in a table cell.  In my case (under
both 0.8 and 0.9.3), it seems to correctly honor left/right padding, but
top/bottom padding spills beyond cell boundaries.  Interestingly, IE also
correctly honors left/right, but clips top/bottom (rather than spilling over or
expanding cell).
*** Bug 185815 has been marked as a duplicate of this bug. ***
*** Bug 280572 has been marked as a duplicate of this bug. ***
*** Bug 305176 has been marked as a duplicate of this bug. ***
Fixed by reflow branch.
Status: NEW → RESOLVED
Closed: 13 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.