Closed Bug 1689986 Opened 3 years ago Closed 9 months ago

One-off search engines removed via the tick are reactivated when changing browser-language

Categories

(Firefox :: Search, defect, P3)

Firefox 85
defect

Tracking

()

VERIFIED FIXED
116 Branch
Tracking Status
firefox116 --- verified

People

(Reporter: boontje, Assigned: klubana)

References

()

Details

(Keywords: papercut, Whiteboard: [snt-scrubbed][search-papercut])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0

Steps to reproduce:

  1. Disable all search-engines (remove the blue ticks in this example screenshot https://i.postimg.cc/sgjXNJT7/search-Engines-Bug.jpg
  2. Set browser-language from german to english or english to german
  3. click "apply and restart"

Actual results:

search-engines are reactivated in that menu from that screenshot...

Expected results:

Changing the browser-language should definitely not mess with the user's search-engine customization.

Component: Untriaged → Search

Only appears to reset the entire search-engine customization if user did not tick any single search engine:
If user only leaves "Google" entry in that list (removes all others), and ticks that one blue, this bug appears to not occur.

Component: Search → Untriaged

This only affects the one-click enable/disable, removing the engine in the UI works correctly.

Marking this as depending on bug 1650874 where we're working towards a rewrite of the search preferences UI, that may remove the separate option.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Depends on: search-alias
Ever confirmed: true
Priority: -- → P3
Summary: Search-engines are reactivated when changing browser-language → One-off search engines removed via the tick are reactivated when changing browser-language

Is this the same as or related to bug 1628405?

Flags: needinfo?(standard8)

It is very loosely related, it is a different preference stored in a different place.

Flags: needinfo?(standard8)
Duplicate of this bug: 1815074
Keywords: papercut
See Also: → 1643887

It has been this way for a long time - the preference that stores this is a comma-separated list of values (browser.search.hiddenOneOffs).

We should migrate it into the search settings and have it as a flag on the search engine object. It'd also make it better as then all the data would be stored together.

Blocks: 1643887
See Also: 1643887
Whiteboard: [snt-scrubbed][search-papercut]
Duplicate of this bug: 1835552

Bug 1643887 is currently fixing this.

No longer blocks: 1643887
Depends on: 1643887
No longer depends on: search-alias

Fixed by bug 1643887

Assignee: nobody → klubana
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 116 Branch

Reproducible on a 2023-06-10 Nightly build on Windows 10.
Verified as fixed on Nightly 116.0a1(build ID: 20230620212415) on Windows 10, macOS 12, Ubuntu 22.
Changing the browser language does not re-check the previously unchecked search engines.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.