Closed Bug 1692399 Opened 7 months ago Closed 2 months ago

TB with XNote crashes on Mac @ __pthread_kill | abort | gpusGenerateCrashLog.cold.1 at random during save email, send, receive

Categories

(Thunderbird :: General, defect)

Unspecified
macOS
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: press, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: crash, topcrash-thunderbird)

Crash Data

Attachments

(1 file)

Attached file xnote-tb-crash.txt

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 11_2_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.150 Safari/537.36

Steps to reproduce:

With XNote installed, TB constantly crashes on Mac (from one to multiple times a day).

I do know that it's an add-on issue. However, the XNote author doesn't have access to Mac:

https://github.com/xnotepp/xnote/issues/54

So I post this issue here in hope that the crash report may help resolve the issue.

I'm confident that TB is only crashes with XNote installed. I ran TB for a week without XNote with no issues.

However, to me personally XNote is essential. Prior to TB 78 there were no issues.

I hope that this issue can be resolved.

Actual results:

TB with XNote installed crashes multiple times a day at random during the following operations: save email, send email, email received (even when TB is in the background).

Please find crash report attached.

Please post your crash IDs form Help > Troubleshooting

Flags: needinfo?(press)

Giacomo,
Do you crash when using xnote on Mac with version 78?

Flags: needinfo?(giacomo.mazzini)
Summary: TB with XNote crashes on Mac → TB with XNote crashes on Mac @ __pthread_kill | abort | gpusGenerateCrashLog.cold.1

No crash detected ever. Running XNote++ 3.1.3 (ID xnote@froihofer.ne) in TB 78.7.1 (64 bit) on MacOS 10.13.6 (RAM 16GB).

Flags: needinfo?(giacomo.mazzini)

No crash detected ever. Running XNote++ 3.1.3 (ID xnote@froihofer.ne) in TB 78.7.1 (64 bit) on MacOS 10.13.6 (RAM 16GB).

But within one day I could try on MacOS 10.15

(In reply to Giacomo Mazzini from comment #5)

No crash detected ever. Running XNote++ 3.1.3 (ID xnote@froihofer.ne) in TB 78.7.1 (64 bit) on MacOS 10.13.6 (RAM 16GB).

But within one day I could try on MacOS 10.15

I've just tried XNote++ 3.1.3 in TB 78.7.1 TB 78.7.1 (64 bit) on MacOS 11.1 (RAM 8GB): no crash.

Keeps crashing for me several times a day... If you need additional logs or any other info, please let me know.

Leo, your crashes are all using Big Sur?

Flags: needinfo?(press)

(In reply to Wayne Mery (:wsmwk) from comment #8)

Leo, your crashes are all using Big Sur?

yes i only updated to 78.x on Big Sur

Flags: needinfo?(press)
See Also: → 1577886

(In reply to Leo from comment #10)

(In reply to Wayne Mery (:wsmwk) from comment #8)

Leo, your crashes are all using Big Sur?

yes i only updated to 78.x on Big Sur

What are your crash IDs ?

The crash rate for Firefox dropped by half between mid November and January. https://crash-stats.mozilla.org/signature/?product=Firefox&signature=__pthread_kill%20%7C%20abort%20%7C%20gpusGenerateCrashLog.cold.1&date=%3E%3D2020-09-14T16%3A25%3A00.000Z&date=%3C2021-03-14T16%3A25%3A00.000Z#graphs - roughly in the time frame of Firefox 84. Firefox esr 78.x crash rate has stayed steady (not a surprise). Unclear whether the reduced crash rate is from fixes, or crash. signature changes.

Like Firefox, Thunderbird crashes for macOS 11 are roughly zero.

There are several Firefox bug reports - it is unclear which, if any, have a direct correlation to Thunderbird crashes

  • Bug 1696358 - macOS Crash in [@ mozilla::detail::MutexImpl::unlock | mozilla::ipc::IToplevelProtocol::CreateSharedMemory]
  • Bug 1576767 - [10.15+11] Crash in [@ libsystem_kernel.dylib@0x744e] in mozilla::gl::GLContextCGL::SwapBuffers()
  • Bug 1535120 - Crash in [@ __pthread_kill | abort | gpusGenerateCrashLog]
Crash Signature: [@ __pthread_kill | abort | gpusGenerateCrashLog.cold.1]

bp-db0e8497-2cd0-44bf-ae56-55fa20210212

0 libsystem_kernel.dylib __pthread_kill
1 libsystem_c.dylib abort
2 libGPUSupportMercury.dylib gpusGenerateCrashLog.cold.1
3 libGPUSupportMercury.dylib gpusGenerateCrashLog
4 AMDRadeonX4000GLDriver gpusKillClientExt
5 libGPUSupportMercury.dylib gpusSubmitDataBuffers
6 AMDRadeonX4000GLDriver glrATI_Hwl_SubmitPacketsWithToken
7 XUL mozilla::gl::GLContextCGL::SwapBuffers() gfx/gl/GLContextProviderCGL.mm:218
8 XUL mozilla::layers::CompositorOGL::EndFrame() gfx/layers/opengl/CompositorOGL.cpp:2038
9 XUL mozilla::layers::LayerManagerComposite::Render(mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&) gfx/layers/composite/LayerManagerComposite.cpp:1266
10 XUL mozilla::layers::AddTransformedRegion(mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits>&, mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::Matrix4x4TypedFlagged<mozilla::gfx::UnknownUnits, mozilla::gfx::UnknownUnits> const&) gfx/layers/LayerTreeInvalidation.cpp:106

Summary: TB with XNote crashes on Mac @ __pthread_kill | abort | gpusGenerateCrashLog.cold.1 → TB with XNote crashes on Mac @ __pthread_kill | abort | gpusGenerateCrashLog.cold.1 at random during save email, send, receive

Dear developers,

I wonder if you had any luck to pinpoint the reason for the crashes?

78.9.1 still crashes multiple times a day. Which is especially annoying in the middle of writing an email.

Being myself a developer, I know how hard it can be to solve crashes that you can't reproduce. Still. Hope you can fix it.

There was no such issues in pre-78 versions.

Thanks,
Leo

Dear devs,

Any news on this?

The recent update, TB 78.11.0 made situation even WORSE:

-Crashes are more frequent
-New issue: after a crash, the last deleted email can return to the inbox
-New issue: TB can now also crash when just selecting a message in the inbox.

I know how hard it is to reproduce and fix crashes. But with all due respect. v78 so far has been an unspeakable disaster. There was nothing like this in years that I've been using TB.

Right now I just wasted 10 minutes just trying to reply to a message - which only leads to constant crashes.

Thank you for your attention to this!

Leo

Duplicate of this bug: 1716701

#1 Mac crash, and #23 crash overall for 78.11.0, combined rate for two crash signatures
And crash rate definitely increased for buildid 20210503211912 = 78.10.1. Perhaps even increased at 78.10.0.

Can you try 78.9.0 from http://archive.mozilla.org/pub/thunderbird/releases/78.9.0/mac/en-US/Thunderbird%2078.9.0.dmg ?

Crash Signature: [@ __pthread_kill | abort | gpusGenerateCrashLog.cold.1] → [@ __pthread_kill | abort | gpusGenerateCrashLog.cold.1] [@ __pthread_kill | pthread_kill ]
Component: Add-Ons: General → General
Flags: needinfo?(press)
OS: Unspecified → macOS
See Also: → 1716611

Thanks for the prompt reply,

I installed 78.9.0 as you suggested, will keep you updated on this.

Flags: needinfo?(press)
Duplicate of this bug: 1693153

At least some of the Firefox crashes are noted as being Apple bugs, as noted in bug 1711801 and others.

Depends on: 1535120
Blocks: gfx-triage

This is in the old graphics pipelines, which we're really close to deprecating in Firefox. We really don't have the resources to investigate this.

No longer blocks: gfx-triage

(In reply to Leo from comment #19)

Thanks for the prompt reply,

I installed 78.9.0 as you suggested, will keep you updated on this.

Results?

Flags: needinfo?(press)

78.9 didn't make any difference.

BUT I then installed beta 90 - and NO CRASHES so far.

Flags: needinfo?(press)

Good to hear. Non-version 78 crashes are extremely rare. I'd bet others would have the same results

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
Crash Signature: [@ __pthread_kill | abort | gpusGenerateCrashLog.cold.1] [@ __pthread_kill | pthread_kill ] → [@ __pthread_kill | abort | gpusGenerateCrashLog.cold.1] [@ __pthread_kill | pthread_kill | abort | gpusGenerateCrashLog.cold.1 ] [@ __pthread_kill | pthread_kill ]
You need to log in before you can comment on or make changes to this bug.