Closed Bug 1692628 Opened 10 months ago Closed 9 months ago

Update labeling and ordering of developer items in the content context menu

Categories

(Firefox :: Menus, enhancement, P3)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- verified

People

(Reporter: Gijs, Assigned: masterwayz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

"Inspect Element" should be "Inspect".

"View Page Source" and "View Selection Source" should be grouped before "Inspect Accessibility Properties", which should come before "Inspect" (which should be at the bottom).

This should probably be done after the patch for bug 1686929 lands, to avoid conflicts.

Looks like this work has already been completed. The string change was covered in Bug 1690561. View page source is already grouped above the inspect elements. I'm going to dupe this into Bug 1690561

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1690561

(In reply to Emma Malysz from comment #1)

Looks like this work has already been completed. The string change was covered in Bug 1690561. View page source is already grouped above the inspect elements. I'm going to dupe this into Bug 1690561

*** This bug has been marked as a duplicate of bug 1690561 ***

I'm a little confused - there's still a separator after View page / view selection source, right? And in the latter case, it's together with other selection items, rather than separated from them. We should still execute those bits, I think? Sorry if my language in comment #0 was not clear enough...

Flags: needinfo?(emalysz)

Oh, got it! Didn't know you were referring to the separators as well.

So for non-selected it should be:

______
View Page Source
Inspect Accessibility Properties
Inspect

Selected items:

_____
View Selection Source
Inspect Accessibility Properties
Inspect
Status: RESOLVED → REOPENED
Flags: needinfo?(emalysz)
Resolution: DUPLICATE → ---
Assignee: nobody → michelle
Status: REOPENED → ASSIGNED
Attachment #9206183 - Attachment description: WIP: Bug 1692628 - Update ordering of developer items in the content context menu r?emalysz → Bug 1692628 - Update ordering of developer items in the content context menu r?emalysz,Gijs
Blocks: 1696574
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/02b347b94d5a
Update ordering of developer items in the content context menu r=emalysz
Status: ASSIGNED → RESOLVED
Closed: 9 months ago9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Verified that the items from page context menu respect the order from comment 3 and their functionality is not affected by the changes. Verified using latest Nightly 88.0a1 across platforms Windows 10, macOS 11.3 and Ubuntu 18.04. Removing the tracking flag for firefox87 since this was targeted for firefox88.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.