Closed Bug 1693805 Opened 7 months ago Closed 3 months ago

Add support for handling BiDi connections

Categories

(Remote Protocol :: WebDriver BiDi, task, P2)

task
Points:
8

Tracking

(firefox91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Whiteboard: [bidi-m1-mvp])

Attachments

(3 files)

With the work on bug 1693802 we should have a connection module that should allow us to implement accepting an incoming connection, and closing it.

Note that it won't have to handle the session yet. Another bug will be filed for that.

Blocks: 1693812
No longer blocks: 1691396
Points: --- → 8
Priority: -- → P2
Depends on: 1712902
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Blocks: 1691446

While the constructor should only do the initialization
of the class, anything else related to the HTTP server
should be delayed until the protocol gets actually
started.

Further the protocol constructor needs the reference
to the Remote Agent itself instead of only the
HTTP server.

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a1a48314a6f2
[remote] Delay registration of CDP path handlers until protocol gets started. r=webdriver-reviewers,jgraham,jdescottes
https://hg.mozilla.org/integration/autoland/rev/34acfc33e07a
[remote] Reorganize RemoteAgent component. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/946c4ba45c96
[remote] Add support for handling WebDriver BiDi connections. r=webdriver-reviewers,jgraham,jdescottes

This failure came in due to the rebase that I did before pushing to autoland. With that we set the recommended preferences in the constructor of the CDP module, which gets immediately loaded now. As such this needs to be delayed until CDP actually gets started.

The underlying problem needs to be fixed, and I filed bug 1719667 for that work.

Flags: needinfo?(hskupin)
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3c883527d366
[remote] Delay registration of CDP path handlers until protocol gets started. r=webdriver-reviewers,jgraham,jdescottes
https://hg.mozilla.org/integration/autoland/rev/0a1b4a96c1cf
[remote] Reorganize RemoteAgent component. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/4b6ec8e2cf78
[remote] Add support for handling WebDriver BiDi connections. r=webdriver-reviewers,jgraham,jdescottes

Backed out 3 changesets (Bug 1693805) for causing bc failures in browser_all_files_referenced.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/6fa18226d738435952f76e2eeb7ae69ebdca1e2f
Push with failures, failure log.

Flags: needinfo?(hskupin)

That's sad, but WebDriverBiDiConnection.jsm isn't used at this point. It means this browser chrome test always fail, and I have to wait with the push until bug 1691446 has a reviewed patch.

Flags: needinfo?(hskupin)
Backout by dluca@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/e2c9d9f0aad2
Backed out 3 changesets for causing bc failures in browser_all_files_referenced.js

Julian had the idea to just remove the inclusion of the module from the jar.mn file for now. That actually fixes the test. I'll try to land again, and hopefully it works this time.

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d23409efae3
[remote] Delay registration of CDP path handlers until protocol gets started. r=webdriver-reviewers,jgraham,jdescottes
https://hg.mozilla.org/integration/autoland/rev/12bc4a9548c2
[remote] Reorganize RemoteAgent component. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/7102bff7059a
[remote] Add support for handling WebDriver BiDi connections. r=webdriver-reviewers,jgraham,jdescottes
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Regressions: 1720070
Regressions: 1720676
You need to log in before you can comment on or make changes to this bug.