Closed Bug 1693838 Opened 7 months ago Closed 7 days ago

Add support for command's payload deserialization

Categories

(Remote Protocol :: WebDriver BiDi, task)

task
Points:
13

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1693839

People

(Reporter: whimboo, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

When receiving commands the contained payload needs to be deserialized. We should get the basics implemented so that the logging feature can be implemented.

It would be good to know which commands would be necessary, and as such which data types are required.

See Also: → 1693839
No longer blocks: 1693834
Depends on: 1693834
Points: --- → 13
Priority: -- → P2
Blocks: 1713784
Priority: P2 → P3
No longer blocks: 1713784
Blocks: 1723102
No longer blocks: 1694144

For the next milestone 2 we might want to have more than just basic support. Updating the summary for now, triage will happen early in September.

Summary: Add basic support for command's payload deserialization → Add support for command's payload deserialization
Whiteboard: [bidi-m1-mvp] → [bidi-m2-mvp]
Priority: P3 → --

This bug might not be needed for milestone 2 given that none of the commands that we need (session.subscribe, session.unsubscribe, browsingContext.navigate) actually have complex data types. I would propose P3.

Status: NEW → RESOLVED
Closed: 7 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1693839

Talked with Julian, and we want to first introduce generic code for serialization / deserialization over on bug 1693839. Then we will follow-up with new bugs for specific data types. As such duping this bug to bug 1693839.

Whiteboard: [bidi-m2-mvp]
You need to log in before you can comment on or make changes to this bug.