Closed Bug 1694144 Opened 7 months ago Closed 1 month ago

Implement basic support for session.subscribe (for log.entryAdded)

Categories

(Remote Protocol :: WebDriver BiDi, task, P2)

task
Points:
8

Tracking

(firefox93 fixed)

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 2 open bugs, )

Details

(Whiteboard: [bidi-m1-mvp], [wptsync upstream])

Attachments

(6 files, 2 obsolete files)

For subscribing to events we need the following command implemented:
https://w3c.github.io/webdriver-bidi/#command-session-subscribe

Blocks: 1694145
Depends on: 1693838
Depends on: 1694389
Depends on: 1694390
Points: --- → 13
Priority: -- → P2
Blocks: 1719292

This bug should only implement the necessary bits of session.subscribe that are needed to register for log events. It can even miss setting certain browsing contexts, so that we register the event for all tabs. As such we can reduce the scope.

Points: 13 → 8
Summary: Implement session.subscribe → Implement basic support for session.subscribe (for log.entryAdded)
Blocks: 1723102

As we actually agreed on in one of the last triage sessions none of the actual dependencies are needed for the basic implementation that has to support log.entryAdded. We are going to subscribe to all browsing contexts, and for extracting the event name we do not need any special deserialization logic.

Assignee: nobody → hskupin
Status: NEW → ASSIGNED
No longer depends on: 1693838, 1694389, 1694390

Julian pointed out that there are WiP patches available that my work could be based on:

https://phabricator.services.mozilla.com/D120655
https://phabricator.services.mozilla.com/D121118

Attachment #9235177 - Attachment description: WIP: Bug 1694144 - [WebDriver BiDi] Add basic support for session.subscribe command. → Bug 1694144 - [WebDriver BiDi] Add basic support for session.subscribe command.
Attachment #9235178 - Attachment description: WIP: Bug 1694144 - [wdspec] Improve BiDi client and add basic tests for "session.subscribe". → Bug 1694144 - [wdspec] Improve BiDi client and add basic tests for "session.subscribe".
Duplicate of this bug: 1723591
Attachment #9235177 - Attachment description: Bug 1694144 - [WebDriver BiDi] Add basic support for session.subscribe command. → WIP: Bug 1694144 - [WebDriver BiDi] Add basic support for session.subscribe command.
Attachment #9235178 - Attachment description: Bug 1694144 - [wdspec] Improve BiDi client and add basic tests for "session.subscribe". → WIP: Bug 1694144 - [wdspec] Improve BiDi client and add basic tests for "session.subscribe".
Attachment #9235177 - Attachment description: WIP: Bug 1694144 - [WebDriver BiDi] Add basic support for session.subscribe command. → Bug 1694144 - [WebDriver BiDi] Add basic support for session.subscribe command.
Attachment #9235178 - Attachment description: WIP: Bug 1694144 - [wdspec] Improve BiDi client and add basic tests for "session.subscribe". → Bug 1694144 - [wdspec] Add basic tests for "session.subscribe".
Depends on: 1724227
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9fb6c43c144d
[WebDriver BiDi] Add basic support for session.subscribe command. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/118ad1445b60
[wdspec] Split fixture module for WebDriver HTTP and BiDi. r=webdriver-reviewers,jgraham
https://hg.mozilla.org/integration/autoland/rev/c3cf28582710
[wdspec] Add BiDi error classes to BiDi client. r=webdriver-reviewers,jgraham,jdescottes
https://hg.mozilla.org/integration/autoland/rev/34b56695cd5c
[wdspec] Add basic tests for "session.subscribe". r=jgraham,webdriver-reviewers,jdescottes
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/29996 for changes under testing/web-platform/tests
Whiteboard: [bidi-m1-mvp] → [bidi-m1-mvp], [wptsync upstream]

Depends on D122019
Probably misses comments. Actually inspired by the CDP domain caches.

Depends on D122019

This is a minimal change only to satisfy the browser_all_files_referenced.js test
The module imports are not actually used here, but at least there is very little code change to review

Attachment #9235915 - Attachment description: Bug 1694144 - [remote] Add a fake ModuleRegistry to keep track of all BiDi modules → Bug 1694144 - [remote] Add a simple ModuleIndex to keep track of all BiDi modules
Attachment #9235869 - Attachment description: Bug 1694144 - [remote] Add a basic ModuleRegistry to keep track of all BiDi modules → Bug 1694144 - [remote] Add a simple ModuleIndex to import BiDi modules
Attachment #9235869 - Attachment is obsolete: true

Going to re-land with the module registry in place, which references all the known modules.

Flags: needinfo?(hskupin)

This patch also includes the addition of the Module Registry,
which has been done by Julian Descottes <jdescottes@mozilla.com>.

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6184d54ab163
[WebDriver BiDi] Add basic support for session.subscribe command. r=webdriver-reviewers,jdescottes
https://hg.mozilla.org/integration/autoland/rev/b4ff28974976
[wdspec] Split fixture module for WebDriver HTTP and BiDi. r=webdriver-reviewers,jgraham
https://hg.mozilla.org/integration/autoland/rev/c6b0d34d017e
[wdspec] Add BiDi error classes to BiDi client. r=webdriver-reviewers,jgraham,jdescottes
https://hg.mozilla.org/integration/autoland/rev/78a950fc4caf
[wdspec] Add basic tests for "session.subscribe". r=jgraham,webdriver-reviewers,jdescottes
Pushed by imoraru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/452e5b72978f
[remote] Add missing EXPORTED_SYMBOLS export for new module registry.
Attachment #9235975 - Attachment is obsolete: true
No longer blocks: 1694145
Upstream PR merged by jgraham
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/34d48ab3f222
[wpt PR 29996] - [Gecko Bug 1694144] [wdspec] Split fixture module for WebDriver HTTP and BiDi., a=testonly
You need to log in before you can comment on or make changes to this bug.