Closed Bug 1693994 Opened 3 months ago Closed 29 days ago

Update subject handling and GenericSendMessage function in compose window

Categories

(SeaMonkey :: MailNews: Composition, enhancement)

enhancement

Tracking

(seamonkey2.53? affected, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.86
Tracking Status
seamonkey2.53 ? affected
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.8)

Attachments

(1 file, 1 obsolete file)

Port to SeaMonkey the relevant parts of the following bugs:

  • Bug 367698 - avoid pre-populating "(no subject)" text in subject box.
  • Bug 389650 - "Unable to save your message as a draft" and "Assembling mail information" when replying to forwarded attached .eml message.
  • Bug 384842 - Specially crafted subject lines (certain length, space at the end) generated invalid mail headers.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Chance of generating invalid headers
Testing completed (on m-c, etc.): 2.53.7
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: 4 new strings, 2 strings removed

Attachment #9204397 - Flags: review?(frgrahl)
Attachment #9204397 - Flags: approval-comm-release?
Attachment #9204397 - Flags: approval-comm-esr60?
Whiteboard: SM2.53.8
Blocks: 1693997
Blocks: 1628671

Comment on attachment 9204397 [details] [diff] [review]
1693994-genericsendmessage-2538.patch

LGTM

nits

+ var servertype = account.incomingServer.type;
+
+ if (servertype != "nntp" && msgCompFields.newsgroups != "") {

servertype in only used here so could be used directly. See corresponding mail file.

+ gAutoSaving = msgType == Ci.nsIMsgCompDeliverMode.AutoSaveAsDraft;

Could use brackets around the comparision for readability. See corresponding mail file.

Attachment #9204397 - Flags: review?(frgrahl)
Attachment #9204397 - Flags: review+
Attachment #9204397 - Flags: approval-comm-release?
Attachment #9204397 - Flags: approval-comm-release+
Attachment #9204397 - Flags: approval-comm-esr60?
Attachment #9204397 - Flags: approval-comm-esr60+

Revised as suggested.

Attachment #9204397 - Attachment is obsolete: true
Attachment #9215283 - Flags: review+
Attachment #9215283 - Flags: approval-comm-release+
Attachment #9215283 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4c65b79798e1
Update subject handling and GenericSendMessage function in compose window. r=frg

Status: ASSIGNED → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.86
Blocks: 1708909
Regressions: 1708909
You need to log in before you can comment on or make changes to this bug.