Closed Bug 1704865 Opened 8 months ago Closed 8 months ago

Update the bookmark icon and animation

Categories

(Firefox :: Theme, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: sfoster, Assigned: sfoster)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-icons] [proton-uplift])

Attachments

(1 file)

We have a newly drawn bookmark icon - in its hollow and filled state. We will not be redrawing the bookmark animation so that will need to be removed in this bug.

The doc at https://docs.google.com/document/d/114gLvaDoZpYnhtK_pPGgbMizphBbjrKp23_YHmWHHLE which provides links to where to find the new icon assets, suggested procedure and tracking spreadsheet for icon updates.

Assignee: nobody → sfoster
Attachment #9216482 - Attachment description: WIP: Bug 1704865 - Update the boomark icons and remove the bookmarked transition filmstrip animations → Bug 1704865 - Update the boomark icons and remove the bookmarked transition filmstrip animations. r?jaws

Apologies jaws, in the process of digging while investigating some (unrelated as it turns out) test failures, I realized I'd missed some important bits in this animation removal, and they have knock-on effects that should definitely have other eyes on them.

Flags: needinfo?(jaws)
Status: NEW → ASSIGNED
Blocks: 1513228

We currently have logic tied to the bookmark animation: when the star drops into toolbarbutton we decide not to also trigger a confirmation hint (aka toast) telling the user the page is bookmarked. Removing this animation changes the parameters here. I talked with KatieC/UX about how to handle this, and we agreed to skip the confirmation hint entirely after the first 3 times. The user having confirmed the bookmark panel and the hollow star icon becoming filled are enough confirmation of the action.

Clearing ni for :jaws, harry is reviewing.

Flags: needinfo?(jaws)
Duplicate of this bug: 1706437
Attachment #9216482 - Attachment description: Bug 1704865 - Update the boomark icons and remove the bookmarked transition filmstrip animations. r?jaws → Bug 1704865 - Update the boomark icons and remove the bookmarked transition filmstrip animations. r?harry
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a119c6860f42
Update the boomark icons and remove the bookmarked transition filmstrip animations. r=desktop-theme-reviewers,dao,harry
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Regressions: 1706901

The icons updated here can be seen in the following places:

  • Addressbar (icon replaced in both bookmarked and not-bookmarked states)
  • "dropping star" animation removed from library and bookmarks toolbar button
  • about:newtab,
  • content context menu,
  • Mac touchbar,
  • Places window (the bookmarks icon in the tree navigation control)

Comment on attachment 9216482 [details]
Bug 1704865 - Update the boomark icons and remove the bookmarked transition filmstrip animations. r?harry

Beta/Release Uplift Approval Request

  • User impact if declined: User will see old icons and animation
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Bookmark any page. There should be no animation on either the star in the addressbar, or when the library button is in the toolbar.
    Bookmark icon should have the thinner stroke weight of all the other Proton icons
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Icon update
  • String changes made/needed: None
Attachment #9216482 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]
Whiteboard: [proton-icons] → [proton-icons] [proton-uplift]

Comment on attachment 9216482 [details]
Bug 1704865 - Update the boomark icons and remove the bookmarked transition filmstrip animations. r?harry

Approved for 89 beta 6, thanks.

Attachment #9216482 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified the fix using latest Nightly 90.0a1 on Windows 10 x64, Ubuntu 18.04 x32 and macOS 10.15. Everything seems fine.
However, on the mac touchbar the icon for bookmarks is not displayed.

Flags: needinfo?(sfoster)

(In reply to Oana Botisan, Desktop Release QA from comment #11)

Verified the fix using latest Nightly 90.0a1 on Windows 10 x64, Ubuntu 18.04 x32 and macOS 10.15. Everything seems fine.
However, on the mac touchbar the icon for bookmarks is not displayed.

:harry can I redirect this to you as you've been updating icons in the mac touchbar recently? I can get a hold of a mac, but I don't have it here with me today to investigate this.

Flags: needinfo?(sfoster) → needinfo?(htwyford)

I have another question regarding the icons. Did the icons for "Bookmarks Toolbar" and "Bookmarks Menu" change? Because we were not able to find them among the list that was provided in comment 0. Can you please provide us with images for the changed icons if there are any?
Thank you.

Flags: needinfo?(sfoster)

Oana, can you still reproduce the Touch Bar issue? I can't reproduce on my machine. If you can, can you please file a new bug and needinfo me there?

The new icon for the bookmarks menu is here. It was changed in bug 1702690. The icon spreadsheet indicates there's no change to the bookmarks toolbar icon.

Flags: needinfo?(sfoster)
Flags: needinfo?(oana.botisan)
Flags: needinfo?(htwyford)

Verified the fix using Firefox 89.0b6 (treeherder) on macOS 10.15, Windows 10 x64 and Ubuntu 18.04 x64. Everything seems fine.
According to comment 11 and comment 12 I will mark this bug as verified fixed.
For the touch bar issue you cand see bug 1708479.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(oana.botisan)
You need to log in before you can comment on or make changes to this bug.