Closed Bug 1705927 Opened 6 months ago Closed 6 months ago

Do not go into overscroll if prefers-reduced-motion is specified

Categories

(Core :: Panning and Zooming, enhancement)

Firefox 89
enhancement

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: erwinm, Assigned: botond)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-uplift])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

Just saw video of new overscroll animations.

Actual results:

Got migraine, pain, nausea.

Expected results:

If prefers-reduced-motion is true, then Firefox should not use the new overscroll ui animations.

related to bug 1478597

bug 1605234

I have not been able to test with Nightly, with prefers-reduced-motion true and false, to compare the behavior.

This is something to check rather than a known defect or an enhancement.

The Bugbug bot thinks this bug should belong to the 'Core::Panning and Zooming' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Panning and Zooming
Product: Firefox → Core

If my testing is correct then this is something that needs to be fixed. overscroll was still active when I set ui.prefersReducedMotion=true

Blocks: overscroll
Status: UNCONFIRMED → NEW
Ever confirmed: true

Thanks for the report. This is something we should fix before the release.

Summary: Confirm that prefers-reduced-motion stops overscroll animations. → Do not go into overscroll if prefers-reduced-motion is specified
Assignee: nobody → botond
Attachment #9216929 - Attachment is obsolete: true
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30af8f80e275
Make GenericOverscrollEffect a no-op if prefers-reduced-motion is set. r=hiro

Backout changeset for causing failures at test_group_hittest-2.html.

Push with failures

Failure log

Backout link

Flags: needinfo?(botond)

Looks like the platform in question has set the prefers-reduced-motion pref by default.

Backout by imoraru@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/083f2a8fe4c5
Backed out changeset 30af8f80e275 for causing failures at test_group_hittest-2.html. a=backout

(In reply to Hiroyuki Ikezoe (:hiro) from comment #8)

Looks like the platform in question has set the prefers-reduced-motion pref by default.

Thanks. It looks like the pref "ui.prefersReducedMotion" takes precedence over any system-level setting, so setting it to 0 in the test fixes the failure.

Flags: needinfo?(botond)
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ea07fbb411c
Make GenericOverscrollEffect a no-op if prefers-reduced-motion is set. r=hiro
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Verified fixed on the latest version of Nightly 90.0a1 (2021-04-21) (20210421095627) on MacOS 11.2.3 (MacBook Pro) and Mac Mini M1 11.0.1.
When the system option "reduce motion" is checked the overscroll effect is disabled.

Status: RESOLVED → VERIFIED
Whiteboard: [proton-uplift]

Comment on attachment 9216918 [details]
Bug 1705927 - Make GenericOverscrollEffect a no-op if prefers-reduced-motion is set. r=hiro

Beta/Release Uplift Approval Request

  • User impact if declined: Overscroll effect would be shown even if prefers-reduced-motion is specified, causing avoidable motion

Required for MR1 / Proton

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1705826
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Patch is small and only affects rendering when the page is overscrolled and prefers-reduced-motion is specified
  • String changes made/needed:
Attachment #9216918 - Flags: approval-mozilla-beta?

Comment on attachment 9216918 [details]
Bug 1705927 - Make GenericOverscrollEffect a no-op if prefers-reduced-motion is set. r=hiro

Approved for 89 beta 3, thanks.

Attachment #9216918 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified fixed on Beta 98.0b3 (20210422190146) on MacOS 11.2.3.

Question, is this the official desired behaviour from Mozilla? It seems to be unique to Firefox — Safari, Chrome and Edge all still have overscrolling enabled when reduced motion is turned on in System Preferences on MacOS.

I really doubt I'm the only one to get migraines from overscroll, or any of the other common animations.

(In reply to Ethan from comment #18)

Question, is this the official desired behaviour from Mozilla?

I think the overscroll animation is a good example of the sort of "non-essential motion" that prefers-reduced-motion is intended to avoid.

It seems to be unique to Firefox — Safari, Chrome and Edge all still have overscrolling enabled when reduced motion is turned on in System Preferences on MacOS.

My guess is that's likely an oversight.

If it turns out not to be an oversight -- for example, if someone files an issue similar to this one in one of these other browsers' issue trackers, and it gets closed as "wontfix" with a reason given -- please feel free to mention that reason here, and we can discuss it further.

You need to log in before you can comment on or make changes to this bug.