Closed Bug 1708224 Opened 3 months ago Closed 3 months ago

Make draw_perspective more resilient with NaNs.

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox89 + fixed
firefox90 --- fixed

People

(Reporter: lsalzman, Assigned: lsalzman)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

No description provided.
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a7bc6a84d165
Make draw_perspective more resilient to NaNs. r=aosmond
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9218972 [details]
Bug 1708224 - Make draw_perspective more resilient to NaNs. r?aosmond

Beta/Release Uplift Approval Request

  • User impact if declined: Linux users running SWGL get hangs in 89 as documented in bug 1714779, bug 1716160 and bug 1717089. We haven't been able to reproduce it locally and don't know the root cause yet so it's difficult to estimate the number of effected users.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's very low risk and has ridden the trains into 90. The change just adjusts things so that we handle NaNs better.
  • String changes made/needed:
Attachment #9218972 - Flags: approval-mozilla-release?

Comment on attachment 9218972 [details]
Bug 1708224 - Make draw_perspective more resilient to NaNs. r?aosmond

Driver for 89.0.2

Attachment #9218972 - Flags: approval-mozilla-release? → approval-mozilla-release+
Duplicate of this bug: 1717231
Blocks: 1717105
Duplicate of this bug: 1712561
Duplicate of this bug: 1714199
Duplicate of this bug: 1715829
Duplicate of this bug: 1715934
Duplicate of this bug: 1717089
Duplicate of this bug: 1708352
You need to log in before you can comment on or make changes to this bug.