IME should use OS system color for selection instead of inverting

RESOLVED FIXED in mozilla1.9alpha1

Status

()

P1
normal
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Brade, Assigned: masayuki)

Tracking

(Blocks: 1 bug, {inputmethod, intl})

Trunk
mozilla1.9alpha1
inputmethod, intl
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

16 years ago
When typing with IME, I expect it to use the system color rather than inverting.
 I spoke with Frank Tang briefly and he said it'd be ok to submit a patch that
was not OS specific to use the system selection color instead of inverting the rect.
(Reporter)

Comment 1

16 years ago
Created attachment 100717 [details] [diff] [review]
patch to hilite IME with selection color instead of inverting

This patch leaves the old code available (via #if 0) for the time being.  I
hesitate to remove it entirely until it has landed and there are no major
complaints on any platforms.

Simon--I intend to land this on the Chimera branch, please sr= for trunk as
well as Chimera branch.

Comment 2

16 years ago
*** Bug 170950 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Doesn't cocoa have its own color (yellow) for such selection? Should we add to
nsILookAndFeel to get this color?

Comment 4

16 years ago
this code looks like it should work. put me for an r= if you like.  I talked to
kathy and I suggested that maybe putting an #if IME_INVERT instead of the #if 0
and adding the #if !IME_INVERT around all the new code.  so we can quickly
compile it one way or the other.  then once ime users can whack on the new way
and it passes mustard, we remove all the #ifs.  however you decide is cool.
r=pink, but use an ifdef label rather than #if 0 so we know what's going on and
can find it more easily later.
(Reporter)

Comment 6

16 years ago
Created attachment 101163 [details] [diff] [review]
updated patch which landed on Chimera branch
Attachment #100717 - Attachment is obsolete: true
(Reporter)

Comment 7

16 years ago
Comment on attachment 101163 [details] [diff] [review]
updated patch which landed on Chimera branch

carry forward r= from pinkerton and mjudge
Attachment #101163 - Flags: review+

Comment 8

15 years ago
*** Bug 236996 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Attachment (id=101163) once landed on Chimera 1.7.1 branch, but didn't land on
trunk.
Are there any problems?
This patch should not be check-in to Trunk.
Because it is XP source code, not for only Mac.

Please wait, I will re-implement IME composition string rendering soon.
*** Bug 159263 has been marked as a duplicate of this bug. ***
Blocks: 113161
Depends on: 236996
I take this bug.
Assignee: brade → masayuki
Component: Editor → Internationalization
Keywords: intl
Priority: -- → P2
QA Contact: sujay → amyy
Target Milestone: --- → mozilla1.9alpha
Status: NEW → ASSIGNED
Priority: P2 → P1
Attachment #101163 - Attachment is obsolete: true
Blocks: 292191
Depends on: 307396
Depends on: 307532
*** Bug 312838 has been marked as a duplicate of this bug. ***
fixed by bug 113161.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.