Closed Bug 1715001 Opened 3 months ago Closed 13 days ago

Easier to misclick download main action when attempting to click download secondary action after proton redesign

Categories

(Firefox :: Downloads Panel, defect, P3)

Firefox 89
Desktop
Unspecified
defect
Points:
1

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- wontfix
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- fixed

People

(Reporter: hong620, Assigned: Gijs)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [proton-cleanups][proton-modals])

Attachments

(2 files)

Attached image Example.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Click the right space of 'Downloaded File' in 'Download List GUI'

Actual results:

it open the File itself

Expected results:

it should open a 'File Saved Directory' just like FF before transaction to NEW UI

in almost of times, need to percise adjust click space to proper function call.

it's sacrifice massive lower the productivity.

The Bugbug bot thinks this bug should belong to the 'Firefox::File Handling' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → File Handling
Component: File Handling → Downloads Panel
Hardware: Unspecified → Desktop

Reproduced on the latest versions of Firefox Nightly 91.0a1 (2021-06-10), beta 90.b5 and release 89.0.
Setting flags and a severity of S4.
Not a regression since it's the new Proton design.

Severity: -- → S4
Status: UNCONFIRMED → NEW
Ever confirmed: true

This was deliberately changed in bug 1706777.

Katie, the designs for the new downloads panel suggested using the "ghost button" style here. Do we want to keep doing this? In principle (with some work) we could make this behave similarly to e.g. the main browser window hamburger button and back button - that is, we could treat some of the area around the visual hover state of the button as also hovering the button, rather than the main download panel action (see also attachment 9225595 [details] from the reporter).

Flags: needinfo?(kcaldwell)
Regressed by: 1706777
Summary: Download GUI got little design fault that direct to wrong function. → Click area of download secondary action button was reduced by proton redesign
Whiteboard: [proton-cleanups][proton-modals]
Duplicate of this bug: 1716081
Priority: -- → P3

Yes, agreed 2 buttons stacked on top of each other introduces an unnecessary frustration. Rather than make the click target bigger for the ghost button (show in finder / directory), let's remove the active target space for the file (open file) behind the button. This way we eliminate the issue and keep our button pattern.

Flags: needinfo?(kcaldwell)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Summary: Click area of download secondary action button was reduced by proton redesign → Easier to misclick download main action when attempting to click download secondary action after proton redesign
Points: --- → 1
Depends on: 1708866

This addresses a few things:

  • it doesn't really make sense to have 2 different badge implementations
    for the library and the panel. Just use the panel one for the library.
  • remove the old badge itself
  • remove a bunch of old CSS to do with the old badge
  • rename the 'new' badge now it isn't new anymore
  • share the badge styling between the 'all downloads' view (about:downloads
    and the library) and the downloads panel
  • use the downloadMainArea for hover styling of the non-button bit, and
    update the JS to set the downloadHoveringButton class appropriately for
    this new reality.
  • tighten up hover styles so we don't get a weird double hover for the
    blocked download case
  • tighten up margins of the button, badge and progress meter (see also
    https://bugzilla.mozilla.org/show_bug.cgi?id=1725837). This is also
    helped by the fact that the renaming means we now properly hide the
    badge image when the download isn't blocked; the CSS at
    https://searchfox.org/mozilla-central/rev/a1ab92e0b16631465a946b300493e75be0eacc37/browser/components/downloads/content/downloads.css#44-47
    didn't apply to this badge pre-patch.
Blocks: 1725837
Attachment #9237130 - Attachment description: WIP: Bug 1715001 - rehash downloads markup and tighten up spacing inside downloads item, r?mhowell → Bug 1715001 - rehash downloads markup and tighten up spacing inside downloads item, r?mhowell
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/86dd58a44d20
rehash downloads markup and tighten up spacing inside downloads item, r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 13 days ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

You need to log in before you can comment on or make changes to this bug.