Closed Bug 1720621 Opened 3 months ago Closed 3 months ago

PDF output is cut off on cp24.com, likely others

Categories

(Core :: Printing: Output, defect)

Firefox 90
defect

Tracking

()

VERIFIED FIXED
92 Branch
Tracking Status
relnote-firefox --- 90+
firefox-esr78 --- unaffected
firefox90 + verified
firefox91 + verified
firefox92 + verified

People

(Reporter: yoasif, Assigned: mattwoodrow)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

From https://www.reddit.com/r/firefox/comments/okhqub/firefox_90_print_to_pdf_printing_cuts_off_14_of/

Steps to reproduce:

  1. Go to https://www.cp24.com/news/live-music-to-return-to-the-budweiser-stage-in-august-with-back-to-back-shows-by-the-arkells-1.5509243
  2. Do Print
  3. Save to PDF

What happens:

The right side of the page is cut off - missing parts of sentences (words).

Expected result:

Content should not be missing from output.

10:58.39 INFO: Narrowed integration regression window from [3557d61e, 411d3031] (3 builds) to [d7a58cff, 411d3031] (2 builds) (~1 steps left)
10:58.39 INFO: No more integration revisions, bisection finished.
10:58.39 INFO: Last good revision: d7a58cff3e920dfbfdfe29c76a2822f7b916c0d3
10:58.39 INFO: First bad revision: 411d3031b1b4c0f8b9ff3009ceb21ba4cfdc601e
10:58.39 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d7a58cff3e920dfbfdfe29c76a2822f7b916c0d3&tochange=411d3031b1b4c0f8b9ff3009ceb21ba4cfdc601e

[Tracking Requested - why for this release]:

Regression in PDF output that - may also affected printed output, which would be a waste of paper.

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1540737

This is a new regression in the just-released 90. Can you take a look?

Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jmathies)

Also see my bug 1720622 for additional examples and characterization.

See Also: → 1720622

Matt noted bug 1717703 may fix this.

See Also: → 1717703

Same bug here. Firefox 90

when auto scaling is on in Print dialog. Scaled Page on the left gets cut of

added in my print.css

body {
transform-origin: 0 0;
transform: scale(.65); //thats what i need
}

so the print dialog has nothing to scale...

Then the Printout is okay

Assignee: nobody → matt.woodrow
Status: NEW → ASSIGNED

Same type of bug as bug 1717703, though in a different spot.

Would be nice to add a test here, but haven't had time for that.

This is super low risk, so happy to push it through for uplift if it's deemed important enough.

Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jmathies)

I've added this bug as a known issue in the 90.0 release notes.

(In reply to Matt Woodrow (:mattwoodrow) from comment #8)

Same type of bug as bug 1717703, though in a different spot.

Would be nice to add a test here, but haven't had time for that.

This is super low risk, so happy to push it through for uplift if it's deemed important enough.

Given that this is a bug reported by end users both in SUMO and bugzilla, I think we should uplift a safe fix to beta, thanks!

Flags: needinfo?(matt.woodrow)
See Also: → 1720719
Attached image Printing being cropped

Another test case: https://webpack.js.org/configuration/printable/

Perhaps it's helpful for testing and verifying the fix.

Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d71ea8ccda7b
Adjust display list building rect for page scale transform within nsPageContentFrame. r=miko
See Also: 1720719
Duplicate of this bug: 1720719
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
See Also: 1720622
Duplicate of this bug: 1720622

It would be nice if we could get it earlier than September. It's messing with my companies POS system and removing vital information on pages that we are printing. They turned off auto-update and downgraded it to 89.0.2 but for some reason, it will still update to 90 overnight.

(In reply to davidflypei from comment #16)

It would be nice if we could get it earlier than September. It's messing with my companies POS system and removing vital information on pages that we are printing. They turned off auto-update and downgraded it to 89.0.2 but for some reason, it will still update to 90 overnight.

I have left 89.0.2 on one of my machines and I only use that one now for printing. While I would think one could look at that version and see what changed in the Print routine(s) with 90.0 forward (including all the subsequent beta versions) I guess it is not that easy but I did notice that even with the "Check for Updates but let you choose" enabled and "Use Background Service" unchecked it still asks me to update but I dismiss the request to do so. While this is a bit of a pain it is workable. Don't know if this helps you but figured I would let you know.

Hopefully the fix for this bug will be remedied before September as indeed it is more than a pain to have happening.

Virtually every web page I print from Firefox requires "shrink to fit". As such, the print function is practically useless. I would like to see the fix put in the next update.

(In reply to Bruce Barrett from comment #18)

Virtually every web page I print from Firefox requires "shrink to fit". As such, the print function is practically useless. I would like to see the fix put in the next update.

I agree with Bruce that it breaks almost every website you use which renders it useless. Lots of our customers will print off a product page from our website and bring it to us (and we do the same for them if they are thinking something over and want to do some more research on a product) and if there is info missing then its useless. It also makes us not look great because our site "doesn't work" as they would say.

(In reply to Wayne from comment #17)

(In reply to davidflypei from comment #16)

It would be nice if we could get it earlier than September. It's messing with my companies POS system and removing vital information on pages that we are printing. They turned off auto-update and downgraded it to 89.0.2 but for some reason, it will still update to 90 overnight.

I have left 89.0.2 on one of my machines and I only use that one now for printing. While I would think one could look at that version and see what changed in the Print routine(s) with 90.0 forward (including all the subsequent beta versions) I guess it is not that easy but I did notice that even with the "Check for Updates but let you choose" enabled and "Use Background Service" unchecked it still asks me to update but I dismiss the request to do so. While this is a bit of a pain it is workable. Don't know if this helps you but figured I would let you know.

Hopefully the fix for this bug will be remedied before September as indeed it is more than a pain to have happening.

The store that was having issues with it updating with everything turned off said that it asked this time and they denied so hopefully it stays like that until we unfreeze the installed version.

It would be nice to get it in a minor version of 90 or at least in 91 as 91 is only 3 weeks away instead of over a month away.

(In reply to davidflypei from comment #16)

It would be nice if we could get it earlier than September. It's messing with my companies POS system and removing vital information on pages that we are printing. They turned off auto-update and downgraded it to 89.0.2 but for some reason, it will still update to 90 overnight.

Same things here: several POS software broken printing.

In my case, no rezise, but print a HTML of 80mm in a printer of 58mm paper width; the DIV is 100%; the option "adjust to paper size" work fine until FF89 and lost the rigth side on FF89.

(In reply to Bruce Barrett from comment #18)

Virtually every web page I print from Firefox requires "shrink to fit". As such, the print function is practically useless. I would like to see the fix put in the next update.

Yes.. I am in the same position and having to print from another computer still on 89.0.2 is proving to be a pain in the you know what but it is workable. Agreed though that after the aforementioned version PRINT no longer works with pretty much everything (as I too must print virtually everything scaled down) is not workable for the most part. Hopefully they will accelerate the fix and see what they changed between 89.0.2 and 90.0+.(In reply to Bruce Barrett from comment #18)

Virtually every web page I print from Firefox requires "shrink to fit". As such, the print function is practically useless. I would like to see the fix put in the next update.

(In reply to davidflypei from comment #19)

(In reply to Bruce Barrett from comment #18)

Virtually every web page I print from Firefox requires "shrink to fit". As such, the print function is practically useless. I would like to see the fix put in the next update.

I agree with Bruce that it breaks almost every website you use which renders it useless. Lots of our customers will print off a product page from our website and bring it to us (and we do the same for them if they are thinking something over and want to do some more research on a product) and if there is info missing then its useless. It also makes us not look great because our site "doesn't work" as they would say.

(In reply to Wayne from comment #17)

(In reply to davidflypei from comment #16)

It would be nice if we could get it earlier than September. It's messing with my companies POS system and removing vital information on pages that we are printing. They turned off auto-update and downgraded it to 89.0.2 but for some reason, it will still update to 90 overnight.

I have left 89.0.2 on one of my machines and I only use that one now for printing. While I would think one could look at that version and see what changed in the Print routine(s) with 90.0 forward (including all the subsequent beta versions) I guess it is not that easy but I did notice that even with the "Check for Updates but let you choose" enabled and "Use Background Service" unchecked it still asks me to update but I dismiss the request to do so. While this is a bit of a pain it is workable. Don't know if this helps you but figured I would let you know.

Hopefully the fix for this bug will be remedied before September as indeed it is more than a pain to have happening.

The store that was having issues with it updating with everything turned off said that it asked this time and they denied so hopefully it stays like that until we unfreeze the installed version.

It would be nice to get it in a minor version of 90 or at least in 91 as 91 is only 3 weeks away instead of over a month away.

On my other machines I have gone to the BETA versions and am now running 91b4 which seems fine although obviously the Print bug has not been addressed in those versions either. Hopefully soon but at least it looks like that store can now stay on 89.0,2 and they can keep saying decline to updates until this is fixed.

In last night's build of Nightly (version 92.0a1, Build ID 20210720094604), both the reported page and my test page print without content truncation when downscaled using Fit to page width or manual scaling.

Excellent work, thank you very much!

Can someone approve this for as much uplift as possible? It's one of the top bugs on SUMO for Firefox 90.x and there is no good workaround.

(In reply to jscher2000 from comment #22)

In last night's build of Nightly (version 92.0a1, Build ID 20210720094604), both the reported page and my test page print without content truncation when downscaled using Fit to page width or manual scaling.

Excellent work, thank you very much!

Can someone approve this for as much uplift as possible? It's one of the top bugs on SUMO for Firefox 90.x and there is no good workaround.

It looks like it works and is good to go. We need to uplift this as high as possible as I can't imagine how many people it's actually affecting in their day to day.

Comment on attachment 9231682 [details]
Bug 1720621 - Adjust display list building rect for page scale transform within nsPageContentFrame. r?miko

I am taking this as an uplift to 91 beta 5 as we need to have a beta build with the patch rapidly to evaluate the feasability of an uplift into a dot release.

Attachment #9231682 - Flags: approval-mozilla-beta+

(In reply to davidflypei from comment #23)

(In reply to jscher2000 from comment #22)

In last night's build of Nightly (version 92.0a1, Build ID 20210720094604), both the reported page and my test page print without content truncation when downscaled using Fit to page width or manual scaling.

Excellent work, thank you very much!

Can someone approve this for as much uplift as possible? It's one of the top bugs on SUMO for Firefox 90.x and there is no good workaround.

It looks like it works and is good to go. We need to uplift this as high as possible as I can't imagine how many people it's actually affecting in their day to day.

Just downloaded and installed 92.0a1 (Nightly) as you indicated. Indeed.. Tried Print out to a PDF scaled with two or three sites that previously with the same scaling had removed last line(s) and truncated text on the right. With 92.0a1 build all worked perfectly, scaled and printed correctly and as expected... Whoppeeee

(In reply to Pascal Chevrel:pascalc from comment #24)

Comment on attachment 9231682 [details]
Bug 1720621 - Adjust display list building rect for page scale transform within nsPageContentFrame. r?miko

I am taking this as an uplift to 91 beta 5 as we need to have a beta build with the patch rapidly to evaluate the feasability of an uplift into a dot release.

Sweet! Hopefully, we can get it into a minor release.

(In reply to davidflypei from comment #27)

(In reply to Pascal Chevrel:pascalc from comment #24)

Comment on attachment 9231682 [details]
Bug 1720621 - Adjust display list building rect for page scale transform within nsPageContentFrame. r?miko

I am taking this as an uplift to 91 beta 5 as we need to have a beta build with the patch rapidly to evaluate the feasability of an uplift into a dot release.

Sweet! Hopefully, we can get it into a minor release.

Just so you know it appears that 92.0a1 while apparently fixing the Print bug is, in itself a bit unstable.. It's hung on me a few times now so I went back to 91b4 and am still printing using 89.0.2 on one of my other PCs BUT.. If you can do whatever you did on Nightly 92.0a1 to 91.0b5 with respect to the Print fix that would be great.

Flags: needinfo?(matt.woodrow)
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9231682 [details]
Bug 1720621 - Adjust display list building rect for page scale transform within nsPageContentFrame. r?miko

Beta/Release Uplift Approval Request

  • User impact if declined: Scaled printing might be broken on certain sites
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change expands the area included in the printing. Any excess area should get clipped away, which makes this change unlikely to break things.
  • String changes made/needed:
Attachment #9231682 - Flags: approval-mozilla-release?

Hello

I have been able to reproduce this issue on 92.0a1(20210714215010) using Windows 10x64.

Confirming this issue as verified fixed on macOS 11, Windows 10x64 and Ubuntu 20/21 using 91.0b5(20210720190304) and 92.0a1(20210721092353).

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9231682 [details]
Bug 1720621 - Adjust display list building rect for page scale transform within nsPageContentFrame. r?miko

approved for 90.0.2, thanks!

Attachment #9231682 - Flags: approval-mozilla-release? → approval-mozilla-release+

Installed 91.0b5 earlier this morning and have been testing out the print on some of the sites were my PDFs (Adobe 2017 PRO) where truncating on the right and cutting off bottom lines and so far all those tested printed perfectly as they have been in 89.0.2 so will continue to use 91.0b5 and see how the day goes but it looks good, stable and printing nicely for the PDFs.

(In reply to Wayne from comment #32)

Installed 91.0b5 earlier this morning and have been testing out the print on some of the sites were my PDFs (Adobe 2017 PRO) where truncating on the right and cutting off bottom lines and so far all those tested printed perfectly as they have been in 89.0.2 so will continue to use 91.0b5 and see how the day goes but it looks good, stable and printing nicely for the PDFs.

OH... Nightly was also fine but will stop using that one for now.

(In reply to Julien Cristau [:jcristau] from comment #34)

https://hg.mozilla.org/releases/mozilla-release/rev/a1c14279cea1

I have been running 91.0b5 (64-bit) all day.
Just finished printing 58 items scaled variously from 60% to 110% (all in PDF format) from 45 different sites. Everything printed perfectly.

Hello,
Confirming this issue as verified fixed on macOS 11, Windows 10 x64 and Ubuntu 20/21 using 90.0.2 (20210721174149)

I just installed FF 90.0.2 and when I read the notes that this bug had been fixed, I was overjoyed. But when I went in to my banking site which has regularly given me bad printing issues recently, I see the problem remains. When I look at transactions, the page image is never complete -- the line-items migrate down the page (bigger white space at the top of each succeeding page) while those at the bottom just vaporize (don't spill to the next sheet of paper nor do they merge into the next page of the report) -- the bottom lines are truncated and just go missing from the output.

I never reported or commented on this before because I could never say whether what I see is a FF issue or a problem with the printer driver (a new HP LaserJet Pro M118dw with complete software & firmware updates). BUT... the same print run works fine right now on Google Chrome, while failing on FF.

Today I'm testing only with PDF generation and not to paper because I'm very low on toner at the moment and can't waste pages -- but the problem still exists in PDF, and I find the paper is usually as bad or worse so no reason to suspect hardcopy works any better.

Running Windows 7 Pro/32
HP driver is 8.00.1329.6503
Printer is HP LaserJet Pro, identifies as "M118-M119 (v3)", running on USB 2.0 port

BTW, I did have printing issues previously (~ Summer 2020) with this banking page and worked with their tech support people on it. They swore they were doing everything right -- and sure enough, it worked fine after a major release of FF. I'm sure they had programmed ahead for that release, and this was before the current printer...

Dan, please file a new bug for your remaining issue.

Flags: needinfo?(dannyfox)

Seems to be good on my dev edition. Ubuntu hasn't updated their repo yet so I can't say for sure on 90.0.2 but I told my stores to update so I will let you guys know if I hear anything bad. Otherwise looks to be good!

See Bug #1721895...

Flags: needinfo?(dannyfox)
Duplicate of this bug: 1721174

FYI -- Did not go back to V90.x.. Am now running 91.0b6 (64-bit) Windows 10.. Working just fine... Have printed a few things to PDF, various scaling(s) all have worked just fine.

Just a reminder — although the bug is qualified as PDF output, the truncation exists when printing any webpage "shrink to fit", whether to a PDF file or a printer.

(In reply to Bruce Barrett from comment #43)

Just a reminder — although the bug is qualified as PDF output, the truncation exists when printing any webpage "shrink to fit", whether to a PDF file or a printer.

No problem but as I only ever print to PDF it would not be appropriate for me to comment on whether or not the print function works in on-line printer. It's not that I avoid them it's just that when I do use my live printer it's not when using FF.

(In reply to Wayne from comment #44)

(In reply to Bruce Barrett from comment #43)

Just a reminder — although the bug is qualified as PDF output, the truncation exists when printing any webpage "shrink to fit", whether to a PDF file or a printer.

No problem but as I only ever print to PDF it would not be appropriate for me to comment on whether or not the print function works in on-line printer. It's not that I avoid them it's just that when I do use my live printer it's not when using FF. Although (this is very rare) that is not totally true when I do print something from FF to my on-line printer it is from the PDF I have formed first so that is using the Adobe print interface.

Duplicate of this bug: 1721886
Duplicate of this bug: 1722187

Confirming bug fixed in 90.0.2 - No truncation when printing reduced scale, whether to PDF file, to printer, or PDF > printer. Prints correctly as in v89.0.
Windows 7 Home Premium 64-bit SP1.

(In reply to Bruce Barrett from comment #48)

Confirming bug fixed in 90.0.2 - No truncation when printing reduced scale, whether to PDF file, to printer, or PDF > printer. Prints correctly as in v89.0.
Windows 7 Home Premium 64-bit SP1.

Good news and thank you for the update. As I am now successfully running 91.0b6 (64-bit) in Windows 10 on my machines I will continue to do so until V91.x gets promoted to the Production version. Glad though that all is back to where it was. Nice job folks. Appreciated.

Was at the shop yesterday and can confirm that 90.0.2 is working. Thanks guys!

Hi, First of all I created an account with Bugzilla only to report this issue and I am not a developer of any kind I am a user of Firefox but lately it seems that after this printing bug (1720621) is fixed I started to have quality issues using my Zebra LP2844 barcode label printer where text quality is negatively affected and so is the barcode started to show rough edges and harder to scan. I tried various setups, but issue persisted. I only experience this issue with Firefox. I don't see it with MS Edge, MS IE or Chrome. Please have a look and see if any part of the recent fix caused this issue or if this is an entirely new issue. Currently I am running Firefox latest update 90.0.2. This issue is preventing me from being able to use Firefox with my eBay account. This issue is primarily evident when I try to print shipping labels with eBay. Thanks.

Flags: needinfo?(matt.woodrow)

(In reply to JoeH from comment #51)

... lately it seems that after this printing bug (1720621) is fixed I started to have quality issues using my Zebra LP2844 barcode label printer where text quality is negatively affected and so is the barcode started to show rough edges and harder to scan.

You should consider filing a new bug. https://bugzilla.mozilla.org/enter_bug.cgi

Please include information on the shipping labels, for example, are they simply web pages, or are they PDFs? If eBay has a "sample" label that demonstrates the same problem, you could provide a link to it or attach it to the new bug.

This change appears to have caused a massive reduction in print quality for PDF shipping labels printed on a Rollo thermal printer (rendering shipping labels unusable), which I assume is the same issue affecting JoeH. I have filed bug 1722842 as a result, but I wanted to mention it here since it seems like this fix may be the cause.

I'd like to rescind that, the print quality issue is not present in 89.0.2, and is present in 90.0.0, which seem to rule out this change being the cause.

Duplicate of this bug: 1721015

I found a website where the printout seems to be incomplete, although I'm not sure if this was possible to do in the past. Learned about the site recently:
https://www.google.com/url?q=https://tasks.google.com/embed/?origin%3Dhttps://mail.google.com%26fullWidth%3D1%26amp;lfhs%3D2&sa=D&ust=1588840789247000

This is the way to access Google Tasks in a tab. Printing a long list as PDF, only prints the first page. Not sure if this issue is the same.

Running FF 90.0.2 64bit under latest Ubuntu here.

Please file new bugs for remaining issues such as comment 56.

I think there are pre-existing bugs that 90.0.2 did not correct. See my Bug #1721895 (particularly Comment #10) where I found a note listing problems I had starting with FF 89.0, some of which still exist in v90's. I didn't like 89.0 when it arrived (I had written "bad" at the top of the note, and unfortunately didn't file any bugs at the time.) Most importantly, I wrote: "PRINT PAGES fails with stuff that worked fine before!" This definitely includes my banking transactions and Amazon orders, two things that always had worked reliably.

So there are several print issues going on -- which may or may not be related to each other. I've run some test documents by request which prove that the 90.0.2 version patches certain specific issues. But it seems the door is still wide open on some other print-related matters. For now, my only remedy is to use Google Chrome for my critical print jobs even though it too has some spacing issues in the service-providers' programming.

(In reply to Dan Pernokis from comment #58)

I think there are pre-existing bugs that 90.0.2 did not correct. See my Bug #1721895 (particularly Comment #10) where I found a note listing problems I had starting with FF 89.0, some of which still exist in v90's. I didn't like 89.0 when it arrived (I had written "bad" at the top of the note, and unfortunately didn't file any bugs at the time.) Most importantly, I wrote: "PRINT PAGES fails with stuff that worked fine before!" This definitely includes my banking transactions and Amazon orders, two things that always had worked reliably.

So there are several print issues going on -- which may or may not be related to each other. I've run some test documents by request which prove that the 90.0.2 version patches certain specific issues. But it seems the door is still wide open on some other print-related matters. For now, my only remedy is to use Google Chrome for my critical print jobs even though it too has some spacing issues in the service-providers' programming.

Just an FYI.... I was running the 91.xb versions and just installed 91.0 (production), just released... Have printed several of my banking transactions, scaled variously and same with a few of my Amazon transactions, also scaled variously... All worked just fine. At least to a PDF.

(In reply to tweedbeats from comment #56)

I found a website where the printout seems to be incomplete, although I'm not sure if this was possible to do in the past. Learned about the site recently:
https://www.google.com/url?q=https://tasks.google.com/embed/?origin%3Dhttps://mail.google.com%26fullWidth%3D1%26amp;lfhs%3D2&sa=D&ust=1588840789247000

This is the way to access Google Tasks in a tab. Printing a long list as PDF, only prints the first page. Not sure if this issue is the same.

There are a number of longstanding issues with breaking blocks of content properly over multiple pages with specific style rules applied. I can't open that link (requires Google login) so I don't know which bug is being triggered, if any, but it's not this bug. (This bug was about truncation-after-scaling within each page, not division of content over multiple pages.)

Flags: needinfo?(matt.woodrow)

My print issue described above is fixed with the Firefox update 91.0 (64-bit). Awesome .. Thanks

... my issue was after updating to 90.0.2 my Thermal Label printer model Zebra LP2844 started to print labels with low resolution and overall jagged print quality on barcodes and unreadable small text. This made my shipping labels unusable. Now I am able to print clearer labels after updating to 91.0.

You need to log in before you can comment on or make changes to this bug.