Closed Bug 1720622 Opened 3 months ago Closed 3 months ago

Print scaling (manual or Fit to page width) causes missing content in printout

Categories

(Core :: Printing: Output, defect)

Firefox 90
defect

Tracking

()

RESOLVED DUPLICATE of bug 1720621
Tracking Status
firefox90 --- fixed
firefox91 --- fixed
firefox92 --- fixed

People

(Reporter: jscher2000, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

Open a page that needs to be scaled down to print, for example, https://www.jeffersonscher.com/res/widepage.html, and print.

Actual results:

Text on the printout is truncated in both directions in rough proportion to the applied scaling.

Expected results:

Printout should not be truncated. Mozregression points to:

Bug 1540737 - Don't use PushLayerWithBlend since it's not implemented by all backend. r=jrmuizel

Differential Revision: https://phabricator.services.mozilla.com/D115432

Attached file Slightly Wide Page.pdf
Component: Untriaged → Printing: Output
Product: Firefox → Core
Regressed by: 1540737
See Also: → 1720621
See Also: → 1720706

Same problem here with FF 90.
A ticket printer (paper 58mm, printing area 48mm) do not show de right side of ticket, but show properly images.

Change scale or adjust to printing area chage size, but still don't print de right side.

In FF 89 work fine. Broken after update.

Same problem, Firefox 90.1 Mac, texts and whole tables are suddendly cutted off from printing - print preview is ok. Same problem outputting to pdf or actual printer.

Why does this major bug of Firefox 90.x not get high priority?

I was happily using scaled printing with Firefox all the time, but Version 90 has made that impossible - nearly all printouts of multiple web pages are truncated (see the attached PDF examples from pvinsights.com with Firefox 89 and Firefox 90 - scaling: 57%) . Some pages can't even be printed with 100% scaling without cutting text off, such as this one: https://www.diescheune.de/veranstaltungen

This bug makes Firefox almost useless for me. If it doesn't get fixed quickly, I have to think about alternatives.

(In reply to umweltjournalist from comment #7)

Why does this major bug of Firefox 90.x not get high priority?

I was happily using scaled printing with Firefox all the time, but Version 90 has made that impossible - nearly all printouts of multiple web pages are truncated (see the attached PDF examples from pvinsights.com with Firefox 89 and Firefox 90 - scaling: 57%) . Some pages can't even be printed with 100% scaling without cutting text off, such as this one: https://www.diescheune.de/veranstaltungen

This bug makes Firefox almost useless for me. If it doesn't get fixed quickly, I have to think about alternatives.

Your link goes to a 404 page.

It did get high priority.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
See Also: 1720621
Duplicate of bug: 1720621

Print preview shows/prints correctly on any other webpage than web-print from www.americanthinker.com, which when printing shows large right and bottom margin, missing some right edge/bottom text.

Hey all, the patch for this bug is in today's "Nightly" build (alpha test version of Firefox 92) and is working there.

The next step is to add it to the beta test release of Firefox 91, which hopefully will occur this week. That also is available as the Developer Edition if you want to install 91 alongside the regular release without messing up your profile.

Whether the patch actually lands in a 90.0.2 update is hard to predict. You can keep an eye on bug 1720621 (no more examples or discussion needed).

This should now be fixed in beta (91.0b5) and will be in 90.0.2 soon.

Duplicate of this bug: 1720102
Duplicate of this bug: 1719268
You need to log in before you can comment on or make changes to this bug.