Closed Bug 1732322 Opened 4 months ago Closed 4 months ago

[Monochromatic Themes] The Search bar inside the Sidebar is not visible while using Balanced Themes.

Categories

(Firefox :: Theme, defect)

Firefox 94
All
macOS
defect
Points:
3

Tracking

()

VERIFIED FIXED
95 Branch
Iteration:
94.2 - Sep 20 - Oct 3
Tracking Status
firefox94 --- verified
firefox95 --- verified

People

(Reporter: oana.botisan, Assigned: bugzilla)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fidefe-theme])

Attachments

(3 files)

Affected versions

  • Firefox 94.0a1

Affected platforms

  • macOS 10.15

Preconditions

  • browser.theme.temporary.monochromatic.enabled = true
  • Select one the Grafitti Balanced theme.

Steps to reproduce

  1. Go to Application menu -> More tools -> Customize toolbar... and drag the "Show sidebars" button on the Toolbar.
  2. Open the Sidebar and make sure you are on the History tab.
  3. Observe the Search bar.

Expected result

  • The Search bar has a proper outline.

Actual result

  • The Search bar is almost invisible.

Regression range

  • Not a regression.

Additional notes

  • All the Balanced themes are effected except Elemental and Cheers.
Blocks: 1725467, 1731038
Has STR: --- → yes

This is a result of us forcing white background colors on a theme that our luminance detectors make a brighttext theme.. I suspect this will have a similar solution to 1732430, where we will need to force light system colors.

See Also: → 1732430
Whiteboard: [fidefe-theme]
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 94.2 - Sep 20 - Oct 3
Points: --- → 1
Points: 1 → 3

This patch will also resolve bug 1732291, since we will use the correct light or dark value of -moz-mac-source-list-selection.

Depends on D127300

Keywords: leave-open
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ed1ab16dd2f
Part 1 - Enable color-scheme CSS property in chrome sheets. r=emilio
Blocks: 1733968
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/425d7064b9e2
Part 2 - Use color-scheme property in sidebar to use the correct system widgets. r=dao
Keywords: leave-open
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Blocks: 1732291

Comment on attachment 9243984 [details]
Bug 1732322 - Part 2 - Use color-scheme property in sidebar to use the correct system widgets. r?dao!

Beta/Release Uplift Approval Request

  • User impact if declined: Users with the new themes introduced in 94 will see elements with poor contrast in the sidebar.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: First part of patch, but I think that landed in 94
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small CSS-only patch, scoped only to the sidebar.
  • String changes made/needed:
Attachment #9243984 - Flags: approval-mozilla-beta?

Comment on attachment 9243984 [details]
Bug 1732322 - Part 2 - Use color-scheme property in sidebar to use the correct system widgets. r?dao!

Approved for 94.0b2.

Attachment #9243984 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified the fix using Firefox 94.0b2 and Firefox 95.0a1 on macOS 10.15. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1734848
You need to log in before you can comment on or make changes to this bug.