Closed Bug 1733968 Opened 4 months ago Closed 4 months ago

Make color-scheme: light/dark work on Linux (draw mismatched widgets using the non-native theme)

Categories

(Core :: Widget: Gtk, defect, P2)

defect
Points:
2

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox94 --- verified
firefox95 --- verified

People

(Reporter: bugzilla, Assigned: emilio)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-theme] )

Attachments

(1 file)

Bug 1732322 updated the sidebar to use color-scheme: light/dark to use the respective light/dark system widgets in the sidebar. However, color-scheme doesn't swap widgets out on Linux due to performance concerns. We should use custom styling for the search box on Linux. This is a follow-up on this review comment.

Whiteboard: [fidefe-theme]
Blocks: 1725467

Alternatively we could use non-native themed controls there. Perhaps we can do that magically, not sure how easy to do that'd be, or alternatively with an internal CSS property.

Whiteboard: [fidefe-theme] → [fidefe-theme]

This will make sure we can draw light textboxes with dark gtk themes and
so on.

I've kept the non-native-theme.enabled check, but perhaps we should
start removing that pref...

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc9028cb90d7
Teach Linux to draw mismatched widgets using the non-native theme. r=mstange
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1734569

ni?emilio to request uplift. I would do it, but Emilio is better equipped to explain what's happening in this patch.

Flags: needinfo?(emilio)

Comment on attachment 9244531 [details]
Bug 1733968 - Teach Linux to draw mismatched widgets using the non-native theme. r=mstange!

Beta/Release Uplift Approval Request

  • User impact if declined: We won't be able to honor color-scheme changes in the browser UI, causing issues like bug 1734569.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: bug 1734569 was filed by QA.
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): We draw light widgets with the non-native theme so as to be able to honor the color-scheme. We were already drawing non-native widgets in some cases (mainly scrollbars), so the patch is reasonably straight-forward.
  • String changes made/needed: none
Flags: needinfo?(emilio)
Attachment #9244531 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9244531 [details]
Bug 1733968 - Teach Linux to draw mismatched widgets using the non-native theme. r=mstange!

Approved for 94.0b5.

Attachment #9244531 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

While using Cheers Balanced the search bar is white and it should be dark. Tested this on Ubuntu 18.04 x64 using Firefox 94.0b5.

Flags: needinfo?(emilio)

It is dark on Nightly, right? Will look into it.

Flags: needinfo?(oana.botisan)

Ouch, yeah, we need bug 1734115, bug 1734723, and bug 1735077 in beta... will request uplifts.

Flags: needinfo?(emilio)

On Nightly it's fine. The problem is reproducing only on beta.

Flags: needinfo?(oana.botisan)
Component: Theme → Widget: Gtk
Product: Firefox → Core
Summary: [Linux] Add custom styling for the search box input in the sidebar → Make color-scheme: light/dark work on Linux (draw mismatched widgets using the non-native theme)

Verified the fix on Firefox 94.0b6 both using macOS 10.15 and Ubuntu 18.04 x64. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.