Closed Bug 1732430 Opened 4 months ago Closed 4 months ago

[Monochromatic Themes] The user and password field in the Save login panel has a black backgroud while using Bold and Balanced themes

Categories

(Firefox :: Theme, defect)

Firefox 94
defect
Points:
2

Tracking

()

VERIFIED FIXED
95 Branch
Iteration:
94.2 - Sep 20 - Oct 3
Tracking Status
firefox94 + verified
firefox95 --- verified

People

(Reporter: oana.botisan, Assigned: bugzilla)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [fidefe-theme])

Attachments

(2 files)

Affected versions

  • Firefox 94.0a1

Affected platforms

  • macOS 10.15
  • Ubuntu 18.04 x64

Preconditions

  • browser.theme.temporary.monochromatic.enabled = true
  • Select one the Grafitti Balanced theme.

Steps to reproduce

  1. Go to Facebook and write a set on credential in the user and password field.
  2. Click on key icon from the URL bar.

Expected result

  • The background color for the user and password fields is white (for Balanced themes) or a darker grey color (for Bold themes).

Actual result

  • The background color for the user and password fields is black.

Regression range

  • Not a regression.

Additional notes

  • All the Bold and Balanced themes are effected except Elemental Balanced and Cheers Balanced.
  • There are no other elements that are black in the themes design.
  • This issue is reproducing inside the Bookmark panel as well.
  • Even when Dark theme is enabled the fields are not black, are a darker grey.
Summary: [Monochromatic Themes] The user and password field in the Save login panel has a black backgroud → [Monochromatic Themes] The user and password field in the Save login panel has a black backgroud while using Bold and Balanced themes
Has STR: --- → yes
See Also: → 1732322

I suspect this is the result of us forcing white backgrounds on a brightext theme. We are still using dark mode system colors, and the two conflict.

Whiteboard: [fidefe-theme]
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 94.2 - Sep 20 - Oct 3
Points: --- → 2

[Tracking Requested - why for this release]:
Contrast issue in the new themes. It has a CSS-only fix that is already close to landing.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76a965804210
Use theme-aware system colors in panel inputs. r=dao
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Comment on attachment 9243561 [details]
Bug 1732430 - Use theme-aware system colors in panel inputs. r?dao!

Beta/Release Uplift Approval Request

  • User impact if declined: Users will see the wrong color inputs in some panels while using the new themes. They would see dark inputs in a light panel or vice versa. This is a pre-existing issue made more visible by the new themes.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small CSS-only fix.
  • String changes made/needed:
Attachment #9243561 - Flags: approval-mozilla-beta?
Blocks: 1734455

Comment on attachment 9243561 [details]
Bug 1732430 - Use theme-aware system colors in panel inputs. r?dao!

Approved for 94.0b2.

Attachment #9243561 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Backed out from Beta due to bug 1734655. We can re-land when there's an upliftable fix ready for that bug also.
https://hg.mozilla.org/releases/mozilla-beta/rev/3d93aa395045

Regressions: 1734716

I can still reproduce this issue while using macOS 10.15 and Windows 10 x64 on Firefox 94.0b4.

Re-landing this for 94.0b5 alongside bug 1733968 and bug 1734716. Please be sure to test the various bugs associated with this issue as part of verifying the fix.

Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified the fix using Firefox 94.0b5 and Nightly 95.0a1 on macOS 10.15 and Ubuntu 18.04 x64. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1742918
You need to log in before you can comment on or make changes to this bug.