Closed Bug 1733052 Opened 4 months ago Closed 4 months ago

Revise the popup state if there is valid transient user activation

Categories

(Core :: DOM: Core & HTML, task)

task

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: edgar, Assigned: edgar)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

This is a temporary solution to make the popup blocker could support new user activation model. For long term, we still need to clean up the popup state bit and remove the old user interaction stuff from popup blocker.

Blocks: 1656444

This is a temprorary solution to make popup block could work with new user
activation model (timer base). I think this should cover most of async case for
window.open(). For long term, we still need to clean up the popup state which
is tracked by bug 1656444.

Blocks: 1732478

Currently the state could be openAbused or openBlocked, the reason for the difference
is for bug 918780 where we would like to fix a issue of opening input dialog might
trigger popup blocker if allowed list is empty. But after bug 1678389, opening input
dialog now checks the transient user activation instead, we don't need this difference
anymore.

Attachment #9243393 - Attachment description: WIP: Bug 1733052 - Revise popup abuse level if there is a valid transient user activation; → Bug 1733052 - Part 2: Revise popup abuse level if there is a valid transient user activation;
Assignee: nobody → echen
Status: NEW → ASSIGNED
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2852026ef9f
Part 1: Have a consistent popup control state setup when handling a event that is not in allowed list; r=smaug
https://hg.mozilla.org/integration/autoland/rev/d5ec74c1e5ea
Part 2: Revise popup abuse level if there is a valid transient user activation; r=smaug
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Duplicate of this bug: 1374498
Duplicate of this bug: 1596614
Duplicate of this bug: 1611063
You need to log in before you can comment on or make changes to this bug.