Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 173638 - Unable to save any files
: Unable to save any files
Status: RESOLVED DUPLICATE of bug 171441
Product: SeaMonkey
Classification: Client Software
Component: Download & File Handling (show other bugs)
: Trunk
: x86 Windows XP
: -- major with 2 votes (vote)
: ---
Assigned To: Blake Ross
: Chris Petersen
Depends on:
  Show dependency treegraph
Reported: 2002-10-09 18:29 PDT by Brian Kaul
Modified: 2004-11-22 17:25 PST (History)
0 users
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Brian Kaul 2002-10-09 18:29:03 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla version

When trying to save any files (right-click link -> save link target as, or
right-click image -> save image as were tested), saveas dialogue appears, and
behaves properly, but download manager never appears, and the file is never saved.

This happened even on a clean profile and clean install of this build.

Moz 1.2a and 1.1 do not exhibit this behavior (though 1.2a doesn't wrap text
properly - ie. articles); I have reverted to 1.1, but will test future
nightly builds for this issue.

I have not tested with any OS other than XP, or other methods of saving files
(save page, etc).  The destination drive is NTFS, but this occurs when logged in
as admin with full perms... Download manager simply never appears and the
request to save the file seems to vanish.

Reproducible: Always

Steps to Reproduce:
1. Attempt to save a file from Mozilla build 2002100911
2. Check to see if file is actually in the destination directory

Actual Results:  
Save as dialogue displayed normally, and allows to choose destination directory,
but download manager never appears, and file is not saved.

Expected Results:  
Save the file to the destination directory selected.
Comment 1 Brian Kaul 2002-10-15 13:01:42 PDT
Seems to be resolved on 2002101508 - test case of save image as now works.
Comment 2 Brian Kaul 2002-10-16 00:09:00 PDT
Still on 2002101508; worked a few hours ago, now doesn't - only thing that's
changed is a crash of Mozilla in between... exiting/restarting has no effect -
won't save files or bring up dl manager.  When set to show progress window
rather than dl manager, it also does nothing - file is not saved.  Clearing the
disk cache, etc. also has no effect.
Comment 3 Ray Trent 2002-10-16 13:00:30 PDT
Might be related to bug 174815, or bug 174485, or even bug 173771 (which started
happening to me around the same time). 
Comment 4 Brian Kaul 2002-10-16 14:49:34 PDT
The fix at of deleting
compreg.dat works, but this doesn't seem to be just an installer issue as that
bug suggests since this problem also began after a Mozilla crash on an
installation that previously worked fine.  If it were an installer issue, it
should happen only when installing over an old build, which is one case in which
it does occur, but apparently not the only one.
Comment 5 Jim Willeke 2002-10-18 06:25:49 PDT
I see similar items as above.
When ever I go to a site to download a file, I get an error message like:
C:\docume~1\jwilleke\LOCALS~1\TEMP\woifior.exe could not be saved, because the
source file could not be read.

Try Again Later or contact the server administrator.

This is true on ANY FILE, eve trying to download mozilla builds.
Always works in IE.
Download manager never starts.
I am on BUILD ID: 2002101708
Even if I go to menu TOOLS->DONWLOAD MANAGER
Please fix this as MOZILLA is Unusable in this condidtion!
Comment 6 Jim Willeke 2002-10-18 06:49:17 PDT
This appears to be a DUPE of 171441 which provided a fix by:

1. Closing Mozilla
2. Deleting \\Mozilla\components\compreg.dat (Or Renaming)
Comment 7 Chris Petersen 2003-01-06 15:10:29 PST

*** This bug has been marked as a duplicate of 171441 ***

Note You need to log in before you can comment on or make changes to this bug.