Closed Bug 1746110 Opened 8 months ago Closed 29 days ago

Turn on OffscreenCanvas by default in nightly only

Categories

(Core :: Graphics: CanvasWebGL, task, P3)

task

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

It would be good to collect feedback.

Depends on: 1746276
Depends on: 1746883
See Also: → 1746962
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2429b99637c7
Turn on OffscreenCanvas in nightly only by default. r=gfx-reviewers,emilio,jrmuizel
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
Regressions: 1747431
Status: RESOLVED → REOPENED
Flags: needinfo?(aosmond)
Resolution: FIXED → ---
Target Milestone: 97 Branch → ---
Regressions: 1748139

Is the intent for this to be fixed and merged back in in FF97 timeframes? (for the docs)?

Further, if this is not in, is it still worth looking at docs for https://bugzilla.mozilla.org/show_bug.cgi?id=1738971 or will that get backed out too?

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:aosmond, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)
Flags: needinfo?(aosmond)
Flags: needinfo?(emilio)
Flags: needinfo?(aosmond)
Attachment #9255567 - Attachment is obsolete: true
Depends on: 1746750
See Also: 1746962
Depends on: 1757820
Duplicate of this bug: 1750354

This patch turns on FontFaceSet in workers and OffscreenCanvas on
workers and the main thread in nightly only.

Duplicate of this bug: 1778765

This time we are providing the full OffscreenCanvas implementation -- webgl, webgl2, 2d, bitmaprenderer and when it is available, webgpu. This should resolve many of the webcompat issues experienced last time when only turning on webgl and webgl2.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0edcbb9a1895
Enable OffscreenCanvas by default on nightly. r=emilio
Blocks: 1779009
Status: REOPENED → RESOLVED
Closed: 8 months ago29 days ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Regressions: 1779519
Regressions: 1779531
You need to log in before you can comment on or make changes to this bug.