Conn: dialup dialog appears for non-existent domains

RESOLVED DUPLICATE of bug 160846

Status

()

RESOLVED DUPLICATE of bug 160846
16 years ago
16 years ago

People

(Reporter: carroll, Assigned: dougt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2) Gecko/20020512 Netscape/7.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2) Gecko/20020512 Netscape/7.0b1

When entering a domain name that  does not exist (e.g.,
http://www.no-such-domain.com), or referencing it via a SRC= tag on a web site
(maybe a domain that no longer exists), Mozilla generates the following dialog,
even if the user is already connected to the Internet:

 Network Connections

  You (or a program) have requested information from 
  www.no-such-domain.com.  Which connection to you want to use?

  (followed by a list of configured ISPs)

This is the case even when the user is already connected.

Reproducible: Always

Steps to Reproduce:
1. Open Web Location
2. enter "http://www.no-such-domain.com"
3. wait for error.

Actual Results:  
Dialog as described.

Expected Results:  
Error message along the lines of "domain www.no-such-domain.com" not found" or
"Mozilla could not find www.no-such-domain"
win2k build 20021016 and linux 20021020 :
I get the error message : 
"no-such.domain could not be found.Please check the name and try again"

>Windows NT 5.1; en-US; rv:1.0rc2) Gecko/20020512 Netscape/7.0b1
-> invalid

This is no place to report Netscape bugs. We accept only bug reports from
mozilla.org builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
actually this works in newer netscapes too but I agree this is invalid
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
I am reporting a Mozilla bug, not a Netscape bug.  This is Mozilla 1.2b, build
20021016.

User agent: 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016

If the useragent was automatically generated before, it was probably a spoofed
user agent string, to circumvent a Hotmail bug.

Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
This exact problem is already reported.
Whiteboard: DUPEME

Comment 5

16 years ago
Works for me with the 10/24 mozilla build. (www.no-such.domain.com could not be 
fond. Please check the name and try again.) Reporter, can you try a clean 
install, delete the mozilla directory before reinstalling?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Thanks you for your comments.  This is a clean install.

My configuration is behind a router, which is connected to DSL.  I wonder if 
Mozilla for some reason believes that there is no Internet connection and wants
to start one?

I suggest that a simple "works for me" in a different environment really doesn't
resolve the bug.

Comment 4 mentions that this bug report is a duplicate of another.  What bug is
it a duplicate of?  I could not find the dupe.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
i have exactly the same configuration (and this is wfm):
My configuration is behind a router, which is connected to DSL.

What is your setting in :
Control Panel/Internet/connections/ ?
Have you tried a installtion in a complete empty directory and a new profile ?

Comment 8

16 years ago
This might be related to NT autodial.

Take a look at:
http://www.mozilla.org/quality/networking/docs/autodial.html
Whiteboard: DUPEME

Comment 9

16 years ago
+clean-report.

smeredith: do you need more info to address this problem report?
Keywords: clean-report
Summary: Mozilla tries to make network connection for non-existent domain → Conn: dialup dialog appears for non-existent domains
This is functioning as designed. It's a dupe of bug 160846. 

If you don't want this to happen, use the Windows control panel to turn autodial
off.

See the document mentioned in comment #8 for full details.

Comment 11

16 years ago
per bug 181135: all bugs owned by previous default owner that were not futured
are being reassigned to default owner.
Assignee: new-network-bugs → dougt

Comment 12

16 years ago
also see bug 169841

*** This bug has been marked as a duplicate of 160846 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.