Last Comment Bug 160846 - Conn: Site not found dialog preceded by Error 623 could not find phone book entry
: Conn: Site not found dialog preceded by Error 623 could not find phone book e...
Status: VERIFIED WONTFIX
: helpwanted
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Windows 2000
: -- minor (vote)
: ---
Assigned To: general
: John Unruh
:
Mentors:
http://nonexistentsite.mozilla.org
: 162471 176323 184632 196630 207123 213374 235663 237182 273322 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 06:32 PDT by gekacheka
Modified: 2005-09-27 10:43 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description gekacheka 2002-08-03 06:32:01 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072204 (1.1beta)

When I get a URL "could not be found" dialog (failed connection), it is preceded
by an windows dialog:

  Network and Dialup Connections
    Cannot Load Dialog
    Error 623: The system could not find the phone book entry for this connection.

When I click "OK", the normal mozilla dialog appears:
  Alert
    nonexistentsite.mozilla.org could not be found.  Please check the name and
try again.

This has only occurred since I installed 1.1beta (from 1.1alpha).
This problem does not occur in IE6 or Netscape 4.79, so I don't think it is a
network problem on this system.

Reproducible: Always
Steps to Reproduce:
1. type a url that produces a failed connection (or browse until the network is
slow and some slow ad site connection fails)


Actual Results:  First get windows gray dialog box that says

  Network and Dialup Connections
     Cannot Load Dialog
     Error 623: The system could not find the phone book entry for this connection.

Once I click OK, I get the normal mozilla dialog:

  Alert
    nonexistentsite.mozilla.org could not be found.  Please check the name and
try again.

Expected Results:  I expect only the mozilla dialog to appear, not the gray
windows dialog.  Having to always close the extra dialog box is a minor
annoyance to me (happens several times a day, apparently due to ad sites).

Other possibly relevant info:
In 
  Start > Settings > Network and Dialup Connections
I have three connections set up, one is the LAN connection I normally use, and
two others are dialup connections I only use while traveling.  Perhaps mozilla
is trying to use them for some reason?
Comment 1 Kai Lahmann (is there, where MNG is) 2002-08-03 06:45:46 PDT
have you installed the new Mozilla over the old Version? Try a clean install. If
that doesn't help, try a fresh profile.
Comment 2 gekacheka 2002-08-03 09:53:04 PDT
Ok, I tried the following:

1. Clean reinstall of 1.1b with new profile (problem persists)

  Uninstalled Mozilla1.1b:
  (a) uninstalled mozilla (via control panel add/remove programs)
  (b) renamed dir /Program Files/Mozilla.org 
  (c) renamed dir /Docs and Settings/../Application Data/Mozilla
      (where only profile is).

  Clean reinstall of Mozilla1.1b:
  (a) reinstalled mozilla 1.1b, 
  (b) deleted the default profile (avoid converting netscape info), 
  (c) created a new default profile.   

    Result:
      After clean reinstall of 1.1b, extra error dialog still appears 
      when I type in the nonexistentsite.mozilla.org example url.

2. Clean reinstall of 1.1a with new profile (problem disappears)

  Uninstalled Mozilla1.1b again as above
    (deleting rather than renaming directories in b and c, 
     since they don't have anything I want to save.)

  Clean reinstall of Mozilla1.1a
    (as above, deleting default profile and creating new default profile)

    Result:  
      After clean reinstall of 1.1a, extra error dialog does NOT appear
      when I type in the nonexistentsite.mozilla.org example url.

3. Clean reinstall of 1.1b with new profile (problem reappears)

  Uninstalled Mozilla1.1a
    (deleting directories as above)

  Clean reinstall of Mozilla1.1b
    (as above, deleting default profile and creating new default profile)

  Result:
    After clean reinstall of 1.1b, extra error dialog reappears
    when I type in the nonexistentsite.mozilla.org example url.

So now I'm more strongly convinced the problem is with Mozilla 1.1b.

(afterward: restored original profile by renaming profile directory back)
Comment 3 Olivier Cahagne 2002-08-03 10:06:28 PDT
may be related to recent checkin that enable DUN on demand to work on Win2k: bug
93002.
Comment 4 benc 2002-08-07 01:49:56 PDT
Steve, this needs immediate analysis.
Comment 5 Steve Meredith (gone) 2002-08-07 10:29:06 PDT
This should probably be fixed by the fix for bug 157733, which was checked in on
7/23. The 1.1b build doesn't have this fix.

To work-around, turn off RAS auto-dial from Control Panel | Internet Options |
Connections. 
Comment 6 gekacheka 2002-08-07 20:29:03 PDT
Ok, I tried a clean install of trunk build 2002080713.

The "Error 623" dialog still appears when I type in the nonexistent url, 
so unfortunately this problem appears NOT yet fixed.

(However, the workaround does prevent the problem.)
Comment 7 Steve Meredith (gone) 2002-08-08 09:17:14 PDT
If you have the autodial setting turned on, Windows will now try to autodial for
not-found addresses in Mozilla, so this part is working correctly. It sounds
like perhaps the connection you have set for the default connection is not valid
any longer. 

Please check Control Panel | Internet Options | Connections and see which dialup
connection is selected as the default. This name should match one of your dialup
connections.

Please look in the registry and tell me the value of
HKCU/RemoteAccess/InternetProfile. The same name should also be here.
Comment 8 gekacheka 2002-08-08 11:28:07 PDT
Ok, "None" was set as the default.  I set one of the dialups as the default.

"Dial whenever a network connection is not present" is selected.

Now whenever Mozilla fails to connect to a site it pops up the password dialog
for the dialup instead of the "Error 623" dialog.  

As the LAN connection IS present, this seems wrong to me. 
Comment 9 Steve Meredith (gone) 2002-08-08 11:44:34 PDT
If you have autodial turned on, then this is the expected behavior. 

However, if you don't have any connection set as default, it should bring up a
list of connections and allow you to choose one. Unless the registry setting I
mentioned in comment 7 had some left over garbage in it. Did you happen to look
at it before selecting a default connection?
Comment 10 gekacheka 2002-08-08 16:46:03 PDT
1. I beg to differ with "this is the expected behavior".  From a LAN-to-internet
and traveling laptop user's point of view (with the setting "Dial whenever a
network connection is NOT present"), popping up a dialup login on failed URLs is
NOT expected.  Neither Netscape4.79 nor IE6 pop up the dialup login on failed
URLs.  This dialog now pops up not infrequently when visiting major sites with
ads, after most of the page is rendered (I've gotten it intermittently on yahoo
mail, on time.com, on msnbc.com, ...) There must be something more Mozilla can
do to detect whether there is a LAN connection before auto-dialing when set to
"Dial whenever a network connection is NOT present".  (ping a gateway?)

(For dialup-to-internet SOHO systems which also happen to be connected to a
local office LAN, the setting "Always dial my default connection" seems more
appropriate.)

2. HKCU/RemoteAccess/Profile [not /InternetProfile]
contained two folders, one for one of the connections (the one I set as default)
and another that looks old (it is not the other connection).  (I'm pretty sure I
checked it before I set the default, and it looks the same now.)
Comment 11 Steve Meredith (gone) 2002-08-08 17:21:23 PDT
I guess "this is the expected behavior" should be "this is the expected behavior
based on how I coded it" ;-) 

In fact IE 6 does do this, at least on Windows XP. I'll argue that if this is
how you set your autodial settings, this is how apps are supposed to behave.
Why? Because that's how IE handles this setting, and IE "owns" this setting. As
far as I can tell, starting with NT 4, this control panel setting isn't meant to
control autodial for all applications: only IE and Outlook. MS Windows provides
and supports the RAS autodial service for non-NS applications starting with NT
4. But it was decided in bug 93002 that we would support this control panel
setting as well because most users don't understand Windows services, and this
setting used to work for them on Windows 98. 

See bug 93002 for more discussion on this. I'm willing to listen to arguments
that it should work some other way, but it's doing the correct thing based on
the decisions that were made.
Comment 12 gekacheka 2002-08-08 21:30:36 PDT
Hmm.  IE6.0.26 does not do this on W2k-sp2.

With dialup setting at "Dial whenever a network connection is NOT present", 
when a LAN connection is present and a URL fails, IE6 puts up its "This page
cannot be displayed...cannot find server or DNS error" page.  The dialup
password dialog never appears.
Comment 13 Steve Meredith (gone) 2002-08-13 17:20:59 PDT
*** Bug 162471 has been marked as a duplicate of this bug. ***
Comment 14 benc 2002-09-10 09:49:47 PDT
-> NEW, dupe means two people have this.

Is there any way to turn this off?

Also, why does this happen only on some machines, my test system didn't do this.
Comment 15 Steve Meredith (gone) 2002-09-10 09:58:59 PDT
It's functioning as designed.

Yes, you can turn off the autodial behavior via Control Panel | Internet Options
| Connections. 

You can disable the feature completely in Mozilla by setting the pref
network.autodial-helper.enabled to false.
Comment 16 benc 2002-09-11 07:09:16 PDT
I'm concerned about the problem as presented in #10. I don't think anyone who
was looking at bug 93002 thought this was the expected behavior. If it was, I
would have objected to us checking in a feature that acts like this.

I think I understand the specific nature of the problem now, so I'll try to go
to the lab and see if this happens there as well.
Comment 17 benc 2002-09-21 12:46:15 PDT
gekacheka: can you try Stephen's suggestion, and mark RESOLVED/WFM if fixes the
problem?

-regression: I will be posting some documentation on this features soon.
Comment 18 Sean Vickery 2002-09-28 15:36:31 PDT
I had this "error 623" problem on my system and fixed it, without reconfiguring
Mozilla (1.1R).  I think the below will illustrate one cause of the problem, viz
that Mozilla gets "confused" if the owner of the connection is Administrator
rather than the current user.

CONFIGURATION THAT GAVE ERROR 623

- Win 2K SP2

- Default dialup connection owned by administrator

WHAT I CHANGED

- Logged into Windows as Administrator

- Deleted default connection

- Logged out, logged back in as Sean

- Created connection (with same settings as previously)

Thus without any changes to my Mozilla configuration things got fixed.

CONCLUSION:

Looks like Mozilla bugs out (under Win2K SP2 at least) if the connection is
either (a) not owned by the current user, or (b) owned by Administrator.

Btw, other applications on my system that know to prompt for a dialup connection
(viz IE6 & OE6) weren't having any problems with my original configuration.

I think someone should change the status of this bug to ASSIGNED now.
Comment 19 Sean Vickery 2002-09-29 07:00:10 PDT
NOT QUITE WHAT I THOUGHT

My induction that it's the ownership of the connection (Admin or user) that's
causing this problem for Mozilla isn't right.  After several reboots today, but
without any further changes to my connection properties, Mozilla is back to
giving me Error 623.  :(

Good luck to you all with this one.  I'll be watching earnestly.
Comment 20 Doug Turner (:dougt) 2002-10-22 21:11:23 PDT
http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q227391&

Microsoft's problem: WONTFIX
Comment 21 gekacheka 2002-10-23 08:57:02 PDT
Both workarounds appear to work.

comment #5:  Disable autodial completely
1. start | settings | control panel | internet options | connections
2. select (*) never dial a connection 
Disables autodialing a connection when disconnected and something tries to
access the internet.  You'll have to start a connection manually 
(with start | settings | network and dialup connections) when you need dialup.


or 

comment #15: Disable autodial in Mozilla only
0. exit mozilla completely (including quickstart)
1. edit c:/Documents and Settings/(user)/Application
Data/Mozilla/Profiles/(profile)/(random)/prefs.js
2. inserted (in alphabetical order)
user_pref("network.autodial-helper.enabled", false);
3. restart mozilla

I'd suggest this preference be set to false by default for windows 2000
installations (assuming this is a w2k-only problem), as it is much less annoying
to users to not get autodial than to continually get popup dialogs.
Comment 22 John Unruh 2002-10-23 12:26:26 PDT
V
Comment 23 Chris Lyon 2003-03-09 20:52:50 PST
*** Bug 196630 has been marked as a duplicate of this bug. ***
Comment 24 Jason M. Abels 2003-06-30 11:42:58 PDT
*** Bug 176323 has been marked as a duplicate of this bug. ***
Comment 25 Asa Dotzler [:asa] 2004-07-15 18:49:06 PDT
*** Bug 207123 has been marked as a duplicate of this bug. ***
Comment 26 Asa Dotzler [:asa] 2004-07-15 18:49:34 PDT
*** Bug 237182 has been marked as a duplicate of this bug. ***
Comment 27 Asa Dotzler [:asa] 2004-07-15 18:49:35 PDT
*** Bug 184632 has been marked as a duplicate of this bug. ***
Comment 28 Asa Dotzler [:asa] 2004-07-15 18:49:51 PDT
*** Bug 235663 has been marked as a duplicate of this bug. ***
Comment 29 Asa Dotzler [:asa] 2004-07-15 18:55:42 PDT
*** Bug 213374 has been marked as a duplicate of this bug. ***
Comment 30 Matt Corby 2004-11-17 03:52:40 PST
I also get this error. 

I disagree this is Microsofts problem "WONTFIX", both my dial up connections
(adsl modem connection and 56.6k modem connection) and are still present and
function when I need them. I am on a T1 Lan most of the time, with a 11Mbps
Wireless connection as well. 

The Microsoft problem describes an issue with connections that "do not exist any
more" set as default connections, which I do not have. 

I've tried the profile fix above which worked for the session but has reverted
back to the old behaviour now. I am reluctant to remove "autodial" as it is
quite annoying having to dial a connection from home when I shouldnt have to.

IE 6 does not produce this behaviour, and I would expect Firefox not to either -
 dialing whenever a network connection is NOT present should be the way forward.


Comment 31 Matt Corby 2004-11-30 03:59:43 PST
The error number I am getting is Error 797; and is with Firefox 1.0
Comment 32 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-09-27 10:43:01 PDT
*** Bug 273322 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.