Closed Bug 1779392 Opened 1 month ago Closed 1 month ago

Updating from TB 91 to 102 causes major issues for legacy users (broken filters, repeated POP downloads, Trash folder not recognized)

Categories

(Thunderbird :: General, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1778111

People

(Reporter: daviddenby, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

TB 102 was shown as an upgrade option for stable release users (not beta) when it first appeared several days ago. When I updated my TB, I immediately started having problems with mail filter not working, duplicate mail downloads, TB not recognizing certain folders (i.e. Trash) other users have reported a multitude of other problems.
TB developers created this issue by not blocking this "beta" upgrade when first released.

Actual results:

(1) Mail filters stopped working.
(2) Downloaded mail wasn't marked when retrieved from POP3 server so mail was repeatedly downloaded at each startup.
(3) Trash folder was not recognized.
(4) couldn't easily revert to stable release version (91.x)

Expected results:

TB developers should release a patch that reverts to earlier stable release for non-tech savvy users. I have already gone though a painful restoration process myself and I see that when using 91.11.0 that version 102 and above are no longer offered as updates but that doesn't help the large number of users that were shanghaied onto version 102 when first offered.
PLEASE fix this with a patch for TB users that are stuck with malfunctioning mail client... There are a LOT of them judging by the TB forum pleas for help.

(In reply to David from comment #0)

Thanks David for the feedback, and sorry for that experience!
Can you check if some of the bugs already on record match what you've seen?

(1) Mail filters stopped working.

Also reported in bug 1777731.

(2) Downloaded mail wasn't marked when retrieved from POP3 server so mail was repeatedly downloaded at each startup.

This looks like bug 1778037.

(3) Trash folder was not recognized.

Bug 1778111?

(4) couldn't easily revert to stable release version (91.x)

Unfortunately, we cannot support downgrades. But we're working hard to fix the upgrading experience and the problems of 102.

Blocks: tb102found
Component: Untriaged → General
Flags: needinfo?(daviddenby)
Summary: Thunderbird causing major issues for legacy users. → Updating from TB 91 to 102 causes major issues for legacy users (broken filters, repeated POP downloads, Trash folder not recognized)

It looks as if these bugs are very similar to the ones I reported, but the fact remains that many users were trapped into upgrading to 102 as if were a release candidate. These folks at least deserve a reliable set of instructions from the developer team to guide them into downgrading to version 91.11.0 or earlier.

Flags: needinfo?(daviddenby)

This bug has too many issued combined, so not actionable.
I'm going to dupe it to one of the above.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1778111
See Also: → 1779551
You need to log in before you can comment on or make changes to this bug.