Closed Bug 1786397 Opened 2 years ago Closed 2 years ago

HCM Recently Closed focus color

Categories

(Firefox :: Firefox View, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox106 --- verified

People

(Reporter: jberman, Assigned: tgiles)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [fidefe-2022-mr1-firefox-view])

Attachments

(4 files)

for MacOS, when the HCM colors are set up in the Firefox itself, the implementation on recently closed focus is confusing because the outline is visited link color and the underlying element doesnt carry any link text. While on mac OS links do not need to carry a link text style on Windows OS they do. Would be best just to be consistent and apply changes to both.

Recommendation: Style all text inside each row with hyperlink text color (MozNativehyperlinktext), then the default behavior would be to have an outline with text color (WindowText)

Severity: -- → S2
Priority: -- → P2

@Anna - We are having trouble reproducing this. Is this still an issue?

Flags: needinfo?(ayeddi)
Severity: S2 → S3
Keywords: access

The issue on Windows OS with HCM enawbled is that the Recently Closed tabs are styled as static text (not links or buttons) and when focused, the outline includes both white (could work for link styling) and blue (likely hardcoded, not and HCM color).

Please refer to the screenshot attached with examples of existent button and link behaviors

Flags: needinfo?(ayeddi)
Assignee: nobody → tgiles
Status: NEW → ASSIGNED

Hi team,
as promised on the call, these are the styling issues on the Fx View on Windows OS with HCM enabled (Win 11 with Night Sky HCM theme in this case):

  1. Tab pickup summary: Default Fx outline (not ButtonText)
  2. Tab pickup summary: Static WindowText color (not ButtonText + ButtonFace for bg)
  3. Tab pickup green links: CurrentColor green text (not MozNativeHyperlinktext)
  4. Tab pickup green links: ButtonText outline for links (not WindowText)
  5. Tab pickup purple links: ButtonText outline for a link (not WindowText) - link text color is as expected here
  6. Recently Closed summary: Default Fx outline (not ButtonText)
  7. Recently Closed summary: Static WindowText color (not ButtonText + ButtonFace for bg)
  8. Recently Closed tabs buttons: Default Fx outline (not ButtonText)
  9. Recently Closed tabs buttons: Static WindowText color (not ButtonText + ButtonFace for bg)
Attachment #9293754 - Attachment description: WIP: Bug 1786397 - Fix focus color on Recently Closed items on HCM. → WIP: Bug 1786397 - Fix Windows HCM issues in Firefox View.
Attachment #9293754 - Attachment description: WIP: Bug 1786397 - Fix Windows HCM issues in Firefox View. → Bug 1786397 - Fix Windows HCM issues in Firefox View. r=dao
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a87bcab99d4
Fix Windows HCM issues in Firefox View. r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch

We should get the double/blue focus outline issue on Windows resolved at the implementation level instead of using a media query to override it since that looks to have been a recent change. I've filed a bug 1791024 for that, and we can remove that portion of the media query once that's resolved (see bug 1791028).

Flags: qe-verify+

Reproduced the issue on Firefox 106.0a1 (2022-08-22) on Windows 11 with Night Sky HCM theme.

The issue is fixed on Firefox 106.0b9 on the same system.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1802902
See Also: → 1846603
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: