Non-ASCII characters in the titles of imported IE Favorites are misconverted

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Frédéric Kayser, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

On a French MacOS X setup, default IE bookmarks have a few diacritical marks (É,
é, à, ç...). Mozilla imports those bookmarks but is unable to display them
correctly in the Bookmarks menu: "É", "à" etc. appear instead of
the expected  letter.



Reproducible: Always

Steps to Reproduce:
1. Have accented titles in IE bookmarks
2. Import them in Mozilla (which is automatically done in a new account)
3. Display the Bookmarks menu
(Reporter)

Comment 1

16 years ago
Created attachment 106533 [details]
Bookmarks menu with default French IE bookmarks (imported)

The faulty signes are underligned in red.
please read bug 134535

*** This bug has been marked as a duplicate of 134535 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
Are you sure this is a duplicate ?
I do not complain about the refresh of the bookmarks list, but rather a display
problem of accented chars.

Comment 4

16 years ago
Not a duplicate of bug 134535.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

16 years ago
Blocks: 120814

Comment 5

16 years ago
Seems to WorkForMe using FizzillaMach/2003021203. I create a Bookmark containing
an e+acute in IE and manually import the IE Favorites into Mozilla's bookmarks,
and the e+acute is imported just fine.

Frédéric, can you still reproduce this problem using a current nightly build?
Summary: Imported IE Favorites with non ASCII chars in their title are badly listed. → Imported IE Favorites with non ASCII chars in their title are badly listed

Comment 6

15 years ago
reporter (Frédéric Kayser), does this bug still exist?

related? (bug 195061)

Updated

15 years ago
Summary: Imported IE Favorites with non ASCII chars in their title are badly listed → Non-ASCII characters in the titles of imported IE Favorites are misconverted

Comment 7

15 years ago
Marking WFM as no one seems to be able to reproduce the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
No longer blocks: 120814
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.