Closed Bug 1805924 Opened 2 years ago Closed 1 year ago

Allow to re-order the list of extensions in the unified extensions panel

Categories

(WebExtensions :: General, enhancement, P2)

enhancement

Tracking

(relnote-firefox 114+, firefox114 fixed)

RESOLVED FIXED
114 Branch
Tracking Status
relnote-firefox --- 114+
firefox114 --- fixed

People

(Reporter: willdurand, Assigned: willdurand)

References

(Blocks 1 open bug)

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

Currently, we cannot re-order the list of extensions in the panel. We should be able to, e.g. when entering the customization mode (similar to what we have for the overflow menu).

Severity: -- → N/A
Priority: -- → P3
Duplicate of this bug: 1806266

We will also explore hiding some extensions from the panel that users don't need to interact with (original request from bug 1806266).

Coming from a power user using FF non-stop for 15 years now and having 30+ add-ons installed, I think the MVP (as seen in 109 beta) of this unified extensions panel is good, but UI refinements are much needed in future releases.
My number one concern now is the inability to reorder items. I hope this can be implemented in the Customize panel, as was done for the Overflow menu.

Regarding the order of pinned extensions, some great suggestions including mock-ups were posted on Connect:
https://connect.mozilla.org/t5/ideas/unified-add-ons-ui-improvements/idi-p/20964
Can you guys have a look at it? I think the proposal makes much sense. Thanks!

The order should be automatically grabbed from the order of the items in the overflow items when the user enables the huge icon menu.

I think by default extensions should be in alphabetic order. Maybe in 2 sections, with actionable extensions above and non-interactive ones below, or hidden.

See Also: → 1809378
See Also: → 1805565
Duplicate of this bug: 1805565
Duplicate of this bug: 1809509
Duplicate of this bug: 1809378

Here's a proposal for implementing the re-ordering functionality:

Currently, it's a bit tedious to pin browser actions to the toolbar from the unified extensions panel, because the only option it allows you is to click the gear icon > pin to toolbar. That just appends it to the toolbar. After you've done that, you still need to go to customize mode and move the button around.

This is also compounded by the fact that the unified extensions panel does not open in customize mode. The button appears and is not disabled, but clicking it has no effect (a bug in its own right). That eliminates one of the possible mitigations — being able to do this while in customize mode would significantly speed things up. Though it's still not perfect, since users really shouldn't need to open a panel to customize widgets.

So, the unified extensions button adds an extra step by removing these buttons from the customization palette. This issue would be resolved by creating a fake panel in the customization palette area, similar to the one that already exists for the regular widget overflow list. We could show two fake panels in the palette area. That would allow users to modify placements in the unified extensions panel, and it would also allow users to move widgets from the unified extensions panel to the toolbar without the tedious extra step of interacting with the panel outside of customize mode. I wasn't around for this, but I imagine the problem I'm detailing here was exactly the rationale that motivated the creation of the fake overflow panel shown in customize mode. It seems like we're just running into a new instance of the very same UX issue.

Of course, some styles would need to be adjusted, and the dragging behavior would need to visually convey that extension widgets are illegal in the palette and overflow menu, and regular widgets are illegal in the unified extensions panel. (This could be done with the 'not allowed' cursor we already use when trying to move non-removable widgets like the urlbar)

Edit: I think the buttons could be represented in a smaller way in the pseudo panel. They're very large in the unified extensions panel, but in customize mode we could shrink them down into little square icons, and make the panel a grid just like the palette. So don't show the icon labels and allow them to layout horizontally and wrap vertically, instead of laying out vertically. This would help alleviate the issue of finding room to show all these buttons in customize mode with two pseudo panels instead of one.

(In reply to Tomislav Jovanovic :zombie from comment #2)

We will also explore hiding some extensions from the panel that users don't need to interact with (original request from bug 1806266).

Bug 1800883 should also be brought in.

Priority: P3 → P2
Duplicate of this bug: 1811221
No longer duplicate of this bug: 1811221

@willdurand can you please elaborate why Bug 1805565 is supposedly a duplicate?

Bug 1805565 is about moving the “puzzle piece” button in the Customize Toolbar UI like all other toolbar buttons.
This bug is about re-shuffling the contents of the menu that appears when clicking that button.

That seems to be two completely separate proposals to me. Is there any underlying technical reason why the two are linked or did you just misread Bug 1805565?

No longer duplicate of this bug: 1805565

(In reply to flying sheep from comment #14)

@willdurand can you please elaborate why Bug 1805565 is supposedly a duplicate?

Bug 1805565 is about moving the “puzzle piece” button in the Customize Toolbar UI like all other toolbar buttons.

I've marked it a dupe of bug 1795235 instead.

Duplicate of this bug: 1820981
Assignee: nobody → wdurand
Status: NEW → ASSIGNED
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f15619d42800
Allow to re-order the list of extensions in the unified extensions panel. r=rpl,bolsson
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 114 Branch

Release Note Request (optional, but appreciated)
[Why is this notable]:

This is a feature some users will like to know about.

[Affects Firefox for Android]:

No.

[Suggested wording]:

It is now possible to reorder the extensions listed in the extensions panel.

[Links (documentation, blog post, etc)]:

SUMO page: https://support.mozilla.org/en-US/kb/extensions-button (which will be updated accordingly)

relnote-firefox: --- → ?

Note added to 114 beta, thanks.

No longer duplicate of this bug: 1827071
Duplicate of this bug: 1834017
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: