Closed Bug 1812636 Opened 1 year ago Closed 1 year ago

"Manage bookmarks" link on empty bookmarks toolbar has stopped working for clicks (but works when doubleclicked), only on Windows

Categories

(Firefox :: Bookmarks & History, defect)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
111 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox109 --- wontfix
firefox110 --- verified
firefox111 --- wontfix
firefox112 --- verified

People

(Reporter: Gijs, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. clean profile, Win10, open Firefox
  2. remove "getting started" bookmark using the context menu
  3. remove "import bookmarks" button using the context menu
  4. try clicking the "Manage bookmarks..." link

ER:

it opens the library

AR:

it does not.

Double-clicking opens the window, but that makes even less sense. I don't know why the single click is getting eaten and the double-click isn't. I'm fairly sure this is a regression but haven't yet tried to figure out when it broke. It still works fine on macOS.

(In reply to Alice0775 White from comment #1)

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4ff88d45f59c4357dcc71ddf4ad5344a38f9944d&tochange=aa325161aae5e555cab4d44b6662bbe029d26a5d

Thanks Alice!

Emilio, another thing that hopefully just takes removing some silly code to fix? 😉

Potentially relevant: bug 1680762.

Flags: needinfo?(emilio)

#personal-toolbar-empty-description { min-width:100vw; } seems fix this.

Set release status flags based on info from the regressing bug 1790616

Flags: needinfo?(emilio)

The width: 0 was never honored and acted like min-width: 0 effectively.

The issues that they supposedly fixed still work with this change, I'm
confused about why so much CSS is needed for this message.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Flags: needinfo?(emilio)

Ok, so I dug a bit more, and what happens is that, given the description is width: 0 and now we actually honor it, this line doesn't add the area of the link and message to the no-drag region. And since it's part of the drag region the OS eats the click.

So, pretty sure the patch as submitted is correct. width: 0 wasn't getting honored and the description ended up being the width of all its contents (so behavior was like min-width: 0 with modern flexbox). Does that make you happier about the patch?

Flags: needinfo?(emilio) → needinfo?(gijskruitbosch+bugs)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cea865489ae7
Fix empty bookmarks toolbar message width with flexbox emulation. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch
Flags: needinfo?(gijskruitbosch+bugs)
Flags: qe-verify+

Emilio, do we want to take it into the dot release? Thanks

Flags: needinfo?(emilio)

Comment on attachment 9314364 [details]
Bug 1812636 - Fix empty bookmarks toolbar message width with flexbox emulation. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-liner
  • String changes made/needed: none
  • Is Android affected?: Yes
Flags: needinfo?(emilio)
Attachment #9314364 - Flags: approval-mozilla-beta?
Attachment #9314364 - Flags: approval-mozilla-beta? → approval-mozilla-release?

Comment on attachment 9314364 [details]
Bug 1812636 - Fix empty bookmarks toolbar message width with flexbox emulation. r=Gijs

Approved for planned dot release 110.0.1
Thanks

Attachment #9314364 - Flags: approval-mozilla-release? → approval-mozilla-release+
QA Whiteboard: [qa-triaged]

Reproduced the issue on Firefox 111.0a1 (2023-01-26) on Windows 10 by following the STR provided in Comment 0.

The issue is fixed on Firefox 111.0b6 and Firefox 112.0a1 (2023-02-26) on the same system.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Verified that the fix is working as expected on Firefox 110.0.1-build2 on the same system.

Regressions: 1819980
You need to log in before you can comment on or make changes to this bug.