Allow users to turn off Favicons in the bookmarks toolbar (at least by hidden pref)

RESOLVED FIXED in Camino1.0

Status

--
enhancement
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: will, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
macOS
fixed1.8

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021122 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021122 Chimera/0.6+

IMHO, the favicons look like **** in the toolbar bookmarks area.  Most sites
have **** favicons and Chimera looks more polished with the favicons turned
off in that region.  I would love a pref to allow users to turn them off for all
areas but the location text field.

Reproducible: Always

Steps to Reproduce:
1.load Chimera .6+ with bookmarks in the toolbar bookmarks area with favicons

Actual Results:  
the favicons load and look bad. =)

Expected Results:  
should have a pref to turn them off, for the love of clean UI.

none

Comment 1

17 years ago
Perhaps it should be handled like a normal toolbar, even if it's not one
internally, via a Control menu: text+icon, text or icon and Remove Item.
It would be less confusing.
See Bug 181954

Comment 2

17 years ago
Will, you can disable favicons entirely by adding the line,

   user_pref("browser.chrome.favicons", true);

to your user.js file. Is that sufficient?

Comment 3

17 years ago
(er, make that false rather than true.)
(Reporter)

Comment 4

17 years ago
Ok, that works the way I want.  But it should be listed in the prefs window so
"normal" people can turn it on and off.
(Assignee)

Comment 5

16 years ago
Taking
Assignee: brade → sfraser
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
Is it possible to take this one step further, and disable ALL icons in the
toolbar?  It was brought to my attention by someone I was getting to try out
Camino that this was one of the only apps he used that had icons you could not
disable in the toolbar, and he's got a point (albeit a petty one).

In other words, maybe just a tiny little arrow like Safari or FF have for
folders, and no icon at all for regular bookmarks?

This would be a cool little feature that could be imbedded under the hood perhaps.

Comment 7

14 years ago
(In reply to comment #6)
> Is it possible to take this one step further, and disable ALL icons in the
> toolbar? 

Absolutely gets my vote. I have a tiny screen and every pixel counts. Safari is
better at this, although I guess you'd need a highight on mouseover as they do.
Personally, I don't think there are enough users that want favicons off to
warrant a GUI for the preference.
A GUI pref seems like overkill to me. It can be done in user.js. If anyone wants
it in a pref, pref panels aren't too hard to make and can incorporate other
appearance features people are asking for.

WONTFIXing.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 10

14 years ago
*** Bug 288902 has been marked as a duplicate of this bug. ***
*** Bug 298771 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

14 years ago
Reopening to ensure that the prefsjs prefs work (which they don't).
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Allow users to turn off Favicons in the toolbar, I prefer the clean look of the generic bookmark icon → Allow users to turn off Favicons in the bookmarks toolbar (at least by hidden pref)
Target Milestone: --- → Camino1.0
(Assignee)

Updated

14 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 13

14 years ago
This patch fixes support for the "browser.chrome.favicons" pref, so that
turning it off disables all the site-based favicons. We'll still show the
special icons for local files, history and bookmarks.
(Assignee)

Comment 14

14 years ago
Fixed on trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.