Closed Bug 1824827 Opened 1 year ago Closed 9 months ago

Three pane view fails to synchronize list and message - deleted message still shown in message list, updated only after navigation (dataloss risk if user deletes again)

Categories

(Thunderbird :: Folder and Message Lists, defect, P3)

Thunderbird 112
x86_64
macOS

Tracking

(thunderbird_esr102 unaffected, thunderbird112 wontfix, thunderbird113 affected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 --- wontfix
thunderbird113 --- affected

People

(Reporter: mitra_lists, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, ux-error-prevention, Whiteboard: [Supernova3p][datalossy])

Attachments

(2 files)

I've mentioned UI lag and issues before - I caught this one in a screencapture.

I have just deleted a message, and the message display has updated to the next message but the message list still shows the deleted message. This was stable, i.e. not a timing issue.

If I now click down-arrow, then the message display updates to show the 2nd message in the folder, and the message list updates correctly.

Importantly - this is a data-loss bug, i.e. there is a tendency to hit delete a second time if you are looking at the Message list (as I often am when deleting junk)

I should note that I am working in a Saved-Search folder, I seem to see more problems in Saved-Search than in the main Inbox.

This is not easy to repeat - happens occasionally, as do other issues, but not with a repeatable STR that I've been able to notice.

I'm on 112.0b3 on OSX with no operating extensions (Conversations is installed but disabled). Since I can't repeat it consistently, there is no point opening in Troubleshooting mode.

I wish there was a better way to attach the Error Log , but apart from the many Gloda exceptions I see a couple ... will post in own comments

tree-view.mjs:167

Uncaught
Exception { name: "", message: "Component returned failure code: 0x80550018 [nsITreeView.isContainer]", result: 2153054232, filename: "chrome://messenger/content/tree-view.mjs", lineNumber: 167, columnNumber: 0, data: null, stack: "handleEvent@chrome://messenger/content/tree-view.mjs:167:24\n", location: XPCWrappedNative_NoHelper }

columnNumber: 0

data: null

filename: "chrome://messenger/content/tree-view.mjs"

lineNumber: 167

location: XPCWrappedNative_NoHelper { QueryInterface: QueryInterface(), filename: Getter, name: Getter, … }
​​
QueryInterface: function QueryInterface()
​​
asyncCaller: null
​​
asyncCause: null
​​
caller: null
​​
columnNumber: 24
​​
filename: "chrome://messenger/content/tree-view.mjs"
​​
formattedStack: "handleEvent@chrome://messenger/content/tree-view.mjs:167:24\n"
​​
lineNumber: 167
​​
name: "handleEvent"
​​
nativeSavedFrame: SavedFrame { source: "chrome://messenger/content/tree-view.mjs", sourceId: 872, line: 167, … }
​​
sourceId: 872
​​
sourceLine: ""
​​
toString: function toString()
​​
<get asyncCaller()>: function asyncCaller()
​​
<get asyncCause()>: function asyncCause()
​​
<get caller()>: function caller()
​​
<get columnNumber()>: function columnNumber()
​​
<get filename()>: function filename()
​​
<get formattedStack()>: function formattedStack()
​​
<get lineNumber()>: function lineNumber()
​​
<get name()>: function name()
​​
<get nativeSavedFrame()>: function nativeSavedFrame()
​​
<get sourceId()>: function sourceId()
​​
<get sourceLine()>: function sourceLine()
​​
<prototype>: Object { … }

message: "Component returned failure code: 0x80550018 [nsITreeView.isContainer]"

name: ""

result: 2153054232

stack: "handleEvent@chrome://messenger/content/tree-view.mjs:167:24\n"

<prototype>: ExceptionPrototype { toString: toString(), name: Getter, message: Getter, … }
2 tree-view.mjs:167
handleEvent chrome://messenger/content/tree-view.mjs:167
Uncaught
Exception { name: "", message: "Component returned failure code: 0x80550018 [nsIMsgDBView.getURIForViewIndex]", result: 2153054232, filename: "chrome://messenger/content/about3Pane.js", lineNumber: 2352, columnNumber: 0, data: null, stack: "_onDragStart@chrome://messenger/content/about3Pane.js:2352:30\nhandleEvent@chrome://messenger/content/about3Pane.js:2285:14\n", location: XPCWrappedNative_NoHelper }
about3Pane.js:2352
Uncaught
Exception { name: "", message: "Component returned failure code: 0x80550018 [nsIMsgDBView.getURIForViewIndex]", result: 2153054232, filename: "chrome://messenger/content/about3Pane.js", lineNumber: 2335, columnNumber: 0, data: null, stack: "_onSelect@chrome://messenger/content/about3Pane.js:2335:27\nhandleEvent@chrome://messenger/content/about3Pane.js:2282:14\nonSelectionChanged@chrome://messenger/content/tree-view.mjs:994:10\n_selectSingle@chrome://messenger/content/tree-view.mjs:828:12\nset selectedIndex@chrome://messenger/content/tree-view.mjs:892:10\nconnectedCallback/<@chrome://messenger/content/about3Pane.js:3426:11\n", location: XPCWrappedNative_NoHelper }
about3Pane.js:2335
Uncaught
Exception { name: "", message: "Component returned failure code: 0x80550018 [nsIMsgDBView.getThreadContainingIndex]", result: 2153054232, filename: "chrome://messenger/content/mailCommon.js", lineNumber: 485, columnNumber: 0, data: null, stack: "isCommandEnabled@chrome://messenger/content/mailCommon.js:485:31\nfillMailContextMenu@chrome://messenger/content/mailContext.js:244:40\ninit/<@chrome://messenger/content/mailContext.js:113:14\nconnectedCallback/<@chrome://messenger/content/about3Pane.js:3431:15\n", location: XPCWrappedNative_NoHelper }
mailCommon.js:485
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 4 AddrBookCard.jsm:385
: Component returned failure code: 0x80550018 [nsITreeView.isContainer] 2 tree-view.mjs:1688
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 2 AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean AddrBookCard.jsm:385
Uncaught TypeError: details is null
showImipBar chrome://calendar/content/imip-bar.js:120
onStateChange chrome://messenger/content/msgHdrView.js:530
displayMessage chrome://messenger/content/aboutMessage.js:195
displayMessage chrome://messenger/content/about3Pane.js:3127
_onSelect chrome://messenger/content/about3Pane.js:2336
handleEvent chrome://messenger/content/about3Pane.js:2282
onSelectionChanged chrome://messenger/content/tree-view.mjs:994
_selectSingle chrome://messenger/content/tree-view.mjs:828
handleEvent chrome://messenger/content/tree-view.mjs:365
imip-bar.js:120:9
showImipBar chrome://calendar/content/imip-bar.js:120
onStateChange chrome://messenger/content/msgHdrView.js:530
displayMessage chrome://messenger/content/aboutMessage.js:195
displayMessage chrome://messenger/content/about3Pane.js:3127
_onSelect chrome://messenger/content/about3Pane.js:2336
handleEvent chrome://messenger/content/about3Pane.js:2282
onSelectionChanged chrome://messenger/content/tree-view.mjs:994
_selectSingle chrome://messenger/content/tree-view.mjs:828
handleEvent chrome://messenger/content/tree-view.mjs:365
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 16 AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 14 AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 2 AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 3 AddrBookCard.jsm:385
NS_ERROR_NOT_AVAILABLE: PreferDisplayName: undefined - not a boolean 2 AddrBookCard.jsm:385
<Provider> does not support changing store on the fly. It is most likely that you see this error because you updated to Redux 2.x and React Redux 2.x which no longer hot reload reducers automatically. See https://github.com/reactjs/react-redux/releases/tag/v2.0.0 for the migration instructions. react-redux.js:881:13

Uncaught
Exception { name: "", message: "Component returned failure code: 0x80550018 [nsIMsgDBView.getURIForViewIndex]", result: 2153054232, filename: "chrome://messenger/content/about3Pane.js", lineNumber: 2352, columnNumber: 0, data: null, stack: "_onDragStart@chrome://messenger/content/about3Pane.js:2352:30\nhandleEvent@chrome://messenger/content/about3Pane.js:2285:14\n", location: XPCWrappedNative_NoHelper }

columnNumber: 0

data: null

filename: "chrome://messenger/content/about3Pane.js"

lineNumber: 2352

location: XPCWrappedNative_NoHelper { QueryInterface: QueryInterface(), filename: Getter, name: Getter, … }

message: "Component returned failure code: 0x80550018 [nsIMsgDBView.getURIForViewIndex]"

name: ""

result: 2153054232

stack: "_onDragStart@chrome://messenger/content/about3Pane.js:2352:30\nhandleEvent@chrome://messenger/content/about3Pane.js:2285:14\n"

<prototype>: ExceptionPrototype { toString: toString(), name: Getter, message: Getter, … }
about3Pane.js:2352

: Component returned failure code: 0x80550018 [nsITreeView.isContainer] tree-view.mjs:1688
set index chrome://messenger/content/tree-view.mjs:1688
set index chrome://messenger/content/about3Pane.js:3441
_addRowAtIndex chrome://messenger/content/tree-view.mjs:682
invalidateRow chrome://messenger/content/tree-view.mjs:502
_doInvalidateRows chrome://messenger/content/tree-selection.mjs:86
select chrome://messenger/content/tree-selection.mjs:196
_selectSingle chrome://messenger/content/tree-view.mjs:824
set selectedIndex chrome://messenger/content/tree-view.mjs:892
onMessagesRemoved chrome://messenger/content/mailCommon.js:767
_deleteCompleted resource:///modules/DBViewWrapper.jsm:1336
_notifyHelper resource:///modules/DBViewWrapper.jsm:196
onFolderEvent resource:///modules/DBViewWrapper.jsm:238
cmd_delete chrome://messenger/content/mailCommon.js:211
doCommand chrome://messenger/content/mailCommon.js:580
goDoCommand chrome://messenger/content/globalOverlay.js:100
oncommand chrome://messenger/content/messenger.xhtml:1

Screenshot of actual (provably wrong) situation.

I think this is something for developers to look into.
When deleted messages are still present in the message list as ghosts, and the list only updates after navigation, and the user might delete again and possibly delete something lese, then that's really something else!

Lack of updating reminds me of trying to mark a message (un)read in Unread folders, which I think also only materialized after navigation (can't find it in that bug cluster right now).
This bug seems to see the reverse problem of bug 1818118. Common denominator is perhaps virtual folders.

(In reply to Mitra Ardron from comment #4)

Created attachment 9325292 [details]
Screenshot 2023-03-28 at 6.22.40 am.png

Screenshot of actual (provably wrong) situation.

Yes, this is a wrong UI state.
Message 1 in list is selected (Wayne, 5:42), but message 2 in list is shown (Wayne, 5:22).

Blocks: tb-new-3pane
Severity: -- → S2
Priority: -- → P2
See Also: → 1818118
Summary: Three pane view fails to synchronize list and message → Three pane view fails to synchronize list and message - deleted message still shown in message list, updated only after navigation (dataloss risk if user deletes again)
Whiteboard: [supernova][datalossy]

Mitra, on Wednesday or Thursday, do you still see this after version 113 beta?

Flags: needinfo?(mitra_lists)
Keywords: regression
See Also: → 1824281
See Also: → 1825588

I am not seeing this any more - marking as Fixed, and will re-open if recurs

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mitra_lists)
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Sorry - still seeing this.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
Whiteboard: [supernova][datalossy] → [Supernova3p][wfm]

Reducing priority since this doesn't seem reproducible by anyone else thus far, and severity because it should be possible to undo a delete.

(In reply to Mitra Ardron from comment #1)

I wish there was a better way to attach the Error Log , but apart from the many Gloda exceptions I see a couple ... will post in own comments

The error console provides "save all messages to file", at least on beta. And bugzilla "attach file" provides a field where you can paste the clipboard, or attach a file.

Severity: S2 → S3
Priority: P2 → P3
Whiteboard: [Supernova3p][wfm] → [Supernova3p][datalossy]

@Wayne - there is no (In reply to Wayne Mery (:wsmwk) from comment #9)

The error console provides "save all messages to file", at least on beta. And bugzilla "attach file" provides a field where you can paste the clipboard, or attach a file.

There is no "Save messages to file" in 113.0b5 on Mac, which version are you seeing it on?

I'll try and catch any errors next time it happens, but I certainly saw it 9 days ago. It doesn't happen often, and is different from the possibly related and still common problem where the list takes a LONG time to update after deleting.

Typically I'm working in a window which is a saved search (all messages in my inbox where the sender isnt' in one of my address books), and then I'm using Quick filter to just show Unread ones, then I'm scanning through them quickly hitting delete or "J" to send to junk. I don't if that combination is what is slowing it down, or occasionally causing the update not to happen.

(In reply to Mitra Ardron from comment #10)

@Wayne - there is no (In reply to Wayne Mery (:wsmwk) from comment #9)

The error console provides "save all messages to file", at least on beta. And bugzilla "attach file" provides a field where you can paste the clipboard, or attach a file.

There is no "Save messages to file" in 113.0b5 on Mac, which version are you seeing it on?

I should have specified, it si on the context menu only. So right click in the error console

(In reply to Wayne Mery (:wsmwk) from comment #11)

I should have specified, it si on the context menu only. So right click in the error console

OK, got it - looks like a UX issue, I was looking for this function, had been told by you it was there, and still couldn't find it. I think of a context menu as related to the object I'm hovering over, not the entire window. I'll find it next time, but I'm guessing most people have no idea this option is there even if they are looking for it.

I'm absolutely still seeing this regularly in 114b05, inside a Saved Search - same symptoms as in the screenshot above - i.e. cursor remains on deleted message which remains visible, next message is shown - so if you are looking at the message list there is a high likelihood of hitting Delete again and losing a message by mistake and not noticing. i.e. Data-loss error.

Only way to fix it is to navigate to another folder and back.

Note also we've got bug #1835025 where similar failure to update after delete is happening in Address Books, which makes me suspect there is some list management code common to both which is buggy.

(In reply to Mitra Ardron from comment #14)

Note also we've got bug #1835025 where similar failure to update after delete

That bug should be fixed next week in 115.0b5.

Flags: needinfo?(mitra_lists)
Flags: needinfo?(mitra_lists)

Looks like this is fixed ?

I'm on 115.0b6 and its very noticably better - I'll mark it Fixed/Resolved (I think that is correct).

Status: NEW → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

I don't know if its the same bug, or a new one , so I've re-opened this.

Deletes still dont' work correctly though the behavior might be slightly different.

The most common symptom is that if I'm looking at a message list in three-pane view, that shows messages

A
B
C

I select A and it shows up below.
Idelete A, the list sometimes shows

A
B
C

With A still selected, but B shows below

OR

B
B
C

again with B shown below

Status: RESOLVED → VERIFIED
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Which version are you using?
This sounds like bug 1841208

I think bug#1841208 looks like something internal to the developers, I don't know if its part of the solution to this bug.

I was using 116b01, on a Mac, and it was happening continuously (repeatably) since I moved to 116b02 this morning I haven't seen it.

But on the tb-beta post https://thunderbird.topicbox.com/groups/beta/Tf9b23684fd593016/tb116-0b1-message-list-not-updated-when-deleting-messages someone said it started for them on 116b02, so maybe its a state TB gets into where its failing all the time.

Note - I run TB continuously, don't close and restart it due to bug#1831673 so it is possible that TB gets itself into a state where its internal data structures don't match reality, and its restarting rather than the update that made the bug go away.

There are still problems on deleting in 116b02, but I'm not sure if its the same problem,

For example the screenshot I'll update in a moment, is after deleting a message - the message display below has updated, but the From / Subject/ Date still reflects the deleted message.

As others have reported, this seems to be a problem that disappears after restarting TB and then comes back after time.

I see the error
Uncaught Error: Component returned failure code: 0x80550018 [nsITreeView.isContainer]
set index chrome://messenger/content/tree-view.mjs:2461
set index chrome://messenger/content/about3Pane.js:5714
_addRowAtIndex chrome://messenger/content/tree-view.mjs:1087
#doInvalidateRow chrome://messenger/content/tree-view.mjs:614
invalidateRow chrome://messenger/content/tree-view.mjs:645
_doInvalidateRows chrome://messenger/content/tree-selection.mjs:86
select chrome://messenger/content/tree-selection.mjs:196
_selectSingle chrome://messenger/content/tree-view.mjs:1251
set selectedIndex chrome://messenger/content/tree-view.mjs:1330
onMessagesRemoved chrome://messenger/content/mailCommon.js:932
_timeout chrome://messenger/content/mailCommon.js:851

which I'm guessing is associated with it - note this looks like the same error I posted at Comment#3

I think all the other reports of this have stopped. So I think the most efficient process would be for you to test the current beta, which is 118. If the problem still exists, then see if comment 22 is still valid, post other new information (profile?) and then reinstall version 116.

Flags: needinfo?(mitra_lists)
Blocks: 1824281
Duplicate of this bug: 1824281
See Also: 1824281

Hi Wayne, I am not seeing this problem any more on 118. Which seems much less buggy (except for the blank From and Subject lines occasionally which others are reporting and I also am seeing).

Flags: needinfo?(mitra_lists)
Status: REOPENED → RESOLVED
Closed: 1 year ago9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: