Closed Bug 1835548 Opened 11 months ago Closed 4 months ago

Unread message count on collapsed parent folder on startup not shown until expanded and collapsed

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 122
Desktop
Windows 10
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 affected)

RESOLVED DUPLICATE of bug 1854377
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- affected

People

(Reporter: stevewein, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, triaged, Whiteboard: [Supernova3p])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36

Steps to reproduce:

BETA 114.0b5. Started TB and new mail came in.

I think this is my browser user agent, not sure!
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/113.0.0.0 Safari/537.36

Actual results:

There is often no bubble showing new email count for each account when the view of my 12 email accounts is 'collapsed.'
Also, when hovering over a folder, it no longer opens to show sub-folders. I have to click on the '>.'

Expected results:

Stated above.

I'm not sure what bubble you're referring to?

Sub-folders never expanded unless you click the twisty.

1-next to the unexpanded e-mail account name/address in the left column, the number of unread e-mails showed as a white number on a blue circle background.
2-the old version would expand a folder by hovering on it for several seconds. Now it does not.

For #1, such an indicator shows for me. (Try Help | Troubleshoot mode)
For the hovering, I think you're mistaken. If you had something like that, maybe that functionality was provided by an add-on.

The hovering 'bug' is not a bug, but my mistake. When dragging an e-mail to a collapsed folder, the folder will open to show subfolders and that works as it did before.

Additional clarification: When I open a collapsed e-mail account, the total of unread new e-mails is shown in a 'bubble' next to the various e-mail folders and when collapsed the bubble is present next to the e-mail account name where it was not shown before expanding the e-mail accoutn.

The area above an open e-mail message does not appear for quite a few seconds (sometimes 30) when displaying. This is the area that has the Reply, Forward, Archive, Junk, Delete, More... It will suddenly pop in after a while.

Are you still seeing this in 115.0b5?

Component: Untriaged → Folder and Message Lists
Flags: needinfo?(stevewein)
Keywords: regression
Whiteboard: [Supernova3p]

Yes. I downloaded the update to 115.0b5 today and still the same result. It is easy to duplicate as fowwlos:
-Collapse all accounts to a single line EACH in the lefthand pane.
-Send some email to one of the accounts and wait a minute or two to make sure it has had time to be delivered.
---N.B. The account should be shown in blue bold, but some of mine do and others don't (AOL account specifically do not).
-Click the '>' next to the account.
-Once it is expanded, there should be a 'bubble' next to the inbox showing the number of unread emails.
-If I collapse the account by clicking the down arrow next to the account name, a bubble now appears next to the account name showing the number of unread emails.

I find this useful as I have a dozen accounts and can easily find the ones with new email without opening (expanding) the account.

Flags: needinfo?(stevewein)
See Also: → 1840255
Duplicate of this bug: 1852396
Duplicate of this bug: 1862774
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: triaged
Summary: 114.0b5 Beta release - number of NEW emails in an account do not always show in bubble → Unread message count on collapsed parent folder on startup not shown until expanded and collapsed

Steverino,
Please check 121.0b5 and report your results. Thanks.

Flags: needinfo?(stevewein)

121.0b5 resolves all the original bug issues.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(stevewein)
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop
Resolution: --- → INVALID
Version: Thunderbird 114 → Thunderbird 122
Duplicate of bug: 1854377
Resolution: INVALID → DUPLICATE
No longer duplicate of this bug: 1862774
You need to log in before you can comment on or make changes to this bug.