About Popup Blocking dialog has a _working_ resizer in the status bar example

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
General
P5
trivial
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Dean Tessman, Assigned: Steffen Wilberg)

Tracking

unspecified
Firefox1.5
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
See attachment.  The resizer beside "Document: Done" works.  I can resize the
window by dragging it.
(Reporter)

Comment 1

15 years ago
Created attachment 108704 [details]
the aforementioned screenshot

Comment 2

15 years ago
I'm glad to pay this price to see a working resizer in the ACTUAL statusbar.
It's about time.

Phoenix developers, I think I'd just call this an easter egg and move along. You
could put some extra text on the dialog's status bar that only shows up when you
use the resizer. :-)

By the way, shouldn't the text say simply "Done" instead of "Document: Done"? I
think Phoenix changed that on the actual status bar.
(Reporter)

Comment 3

15 years ago
Tim: that's bug 184353, which I fixed last night

Comment 4

15 years ago
I like that easter egg suggestion! :)

Also, the text should change to "Done".
Severity: normal → trivial
OS: Windows 2000 → All
(Reporter)

Comment 5

15 years ago
David: see comment 3

Comment 6

15 years ago
heh.
Target Milestone: --- → After Phoenix 1.0

Comment 7

15 years ago
I don't think I see it anymore with the new Qute theme

Comment 8

15 years ago
This is still visible in WinXP with the default luna theme when the window is
not maximized. I like the easter egg idea. That would be cool.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030728 Mozilla
Firebird/0.6.1

Comment 9

15 years ago
I see it now with the resize bug fixed
-> taking

should be easy enough to fix
Assignee: blake → mpconnor
(Assignee)

Comment 11

15 years ago
Copy chrome://browser/content/pageReportFirstTime.xul to the url bar to test this.

Updated

15 years ago
QA Contact: asa

Comment 12

14 years ago
*** Bug 233656 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
Don't fix this... it's a nice easer egg indeed!
The "malfunction" is not anoying in any way!
the reality of this bug is that I don't think this matters, the dialog is only
shown once, who cares if it gets resized? :)

I should probably WONTFIX this :)
Status: NEW → ASSIGNED
Priority: -- → P5

Comment 15

14 years ago
*** Bug 243422 has been marked as a duplicate of this bug. ***
Don't WONTFIX it, but don't feel obliged to have it block anything ;-) 

Comment 17

14 years ago
The problem isn't that it resizes.  The problem is that the resizer is in the
wrong place.

Comment 18

14 years ago
(In reply to comment #17)
> The problem isn't that it resizes.  The problem is that the resizer is in the
> wrong place.

Well, it doesn't really NEED to resize at all. Don't know how much code it
takes, but any streamlining helps.
it doesn't take any code, actually, it'd probably be harder to undo it

although, I don't think this is even valid anymore, since I think the dialog is
dead.

Comment 20

14 years ago
Perhaps the bug should be closed then?
(Assignee)

Comment 21

14 years ago
The dialog isn't dead. It's displayed upon selecting "Don't show info message
when popups are blocked" from the context menu of the popup button on the statusbar.
(Assignee)

Comment 22

14 years ago
Created attachment 154572 [details] [diff] [review]
patch

This is inspired from the code for the main window:
http://lxr.mozilla.org/aviarybranch/source/toolkit/content/xul.css#331

I added it to browser.css because that is already referenced by
pageReportFirstTime.xul. I'm not sure about Pinstripe.
(Assignee)

Updated

14 years ago
Assignee: mconnor → steffen.wilberg
(Assignee)

Updated

14 years ago
Attachment #154572 - Flags: review?(mconnor)
Attachment #154572 - Flags: approval-aviary?

Comment 23

14 years ago
This one should be bumped up to "normal" or at least "minor" priority, though
not a blocker.
(Assignee)

Updated

14 years ago
Severity: trivial → minor
Target Milestone: After Firefox 1.0 → Firefox1.0beta
(Reporter)

Comment 24

14 years ago
(In reply to comment #23)
> This one should be bumped up to "normal" or at least "minor" priority, though
> not a blocker.

Definitely not.  In fact, I'm downgrading it back to trivial (I can do that, I
filed the bug).  It really is a cosmetic bug and nothing more.
Severity: minor → trivial

Comment 25

14 years ago
Comment on attachment 154572 [details] [diff] [review]
patch

Please don't request approval until you've received necessary reviews. Thanks.
Attachment #154572 - Flags: approval-aviary?

Comment 26

14 years ago
Can this one come in before PR?
(Assignee)

Updated

14 years ago
Target Milestone: Firefox1.0beta → Future
Attachment #154572 - Flags: review?(mconnor) → review?(webmail)
Attachment #154572 - Flags: review?(kevin) → review?(mconnor)

Updated

13 years ago
Attachment #154572 - Flags: review?(mconnor) → review+
(Assignee)

Updated

13 years ago
Attachment #154572 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #154572 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
(Assignee)

Comment 27

13 years ago
Finally!

Checking in mozilla/browser/themes/winstripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/browser.css,v  <--  browser.css
new revision: 1.14; previous revision: 1.13
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: Future → Firefox1.1
*** Bug 305022 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.