Closed Bug 1846119 Opened 7 months ago Closed 7 months ago

The elements in the urlbar are not aligned with the dropdown when UI density is set to compact or touch

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 117
Desktop
All
defect

Tracking

()

VERIFIED FIXED
118 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox-esr115 --- unaffected
firefox116 --- unaffected
firefox117 --- verified
firefox118 --- verified

People

(Reporter: tgnff242, Assigned: sam)

References

(Regression)

Details

(Keywords: nightly-community, regression, Whiteboard: [sng-scrubbed][search-regression])

Attachments

(2 files)

Attached image urlbar.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/117.0

Steps to reproduce:

I'm aware that the compact density is marked as unsupported.

  1. Set the UI density to compact by setting browser.uidensity to 1.
  2. Type something in the urlbar.

Actual results:

Icon and text in the urlbar are not aligned with icons and text in the dropdown, and the space between the magnifying glass and text in the urlbar seems larger than before.

Expected results:

This probably was regressed by Bug 1839921, but I can't verify it due to Bug 1845272.

I'm attaching a similar screenshot as the reporter in 1839921 to make the issue obvious.

Has STR: --- → yes
Component: Untriaged → Address Bar
OS: Unspecified → All
Regressed by: 1839921
Hardware: Unspecified → Desktop

:daleharvey, since you are the author of the regressor, bug 1839921, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(dharvey)

Hello, thank you for the bug report!
Managed to reproduce on:

  • Nightly 117.0a1;

Tested and reproduced on:

  • Ubuntu 22;
  • Windows 10:
  • macOS 12:

Setting as NEW.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: -- → S4
Priority: -- → P3
Whiteboard: [sng-scrubbed][search-regression]

This fixes the issue for all density modes, including compact and touch.

Assignee: nobody → sam
Status: NEW → ASSIGNED
Summary: The elements in the urlbar are not aligned with the dropdown when UI density is set to compact → The elements in the urlbar are not aligned with the dropdown when UI density is set to compact or touch

Set release status flags based on info from the regressing bug 1839921

Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4205d3ef6af6
Align urlbar icons regardless of density. r=dao
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 118 Branch

Comment on attachment 9346594 [details]
Bug 1846119 - Align urlbar icons regardless of density. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: We need this to ship the rich suggestions experiment on release as planned
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Should be clear from comments and screenshots
  • List of other uplifts needed: The following bugs should be uplifted in this order: bug 1839921 (already on beta), Bug 1846119, Bug 1846765
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only change that affects rich suggestions, which are preffed off by default except for Nightly
  • String changes made/needed:
  • Is Android affected?: No
Attachment #9346594 - Flags: approval-mozilla-release?
Attachment #9346594 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9346594 [details]
Bug 1846119 - Align urlbar icons regardless of density. r?dao

Approved for 117.0b3
Approved for 116.0.1 dot release

Attachment #9346594 - Flags: approval-mozilla-release?
Attachment #9346594 - Flags: approval-mozilla-release+
Attachment #9346594 - Flags: approval-mozilla-beta?
Attachment #9346594 - Flags: approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

The issue is verified fixed using Fx116.0.1 (treeherder build), Fx 117.0b3 (treeherder build) and Fx 118.0a1 on Windows 10 and Ubuntu 20.04. Icons are now aligned when having the compact view enabled.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

clearing needinfo

Flags: needinfo?(dharvey)
You need to log in before you can comment on or make changes to this bug.