Closed Bug 1863845 Opened 5 months ago Closed 4 months ago

Thunderbird 115 - hover on folder delay is too short

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 115
defect

Tracking

(thunderbird_esr115 fixed, thunderbird121 fixed)

RESOLVED FIXED
122 Branch
Tracking Status
thunderbird_esr115 --- fixed
thunderbird121 --- fixed

People

(Reporter: webmaster2, Assigned: Paenglab)

References

()

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/119.0

Steps to reproduce:

Drag message to folder with sub-folders.

Actual results:

Folder opens too quickly revealing all sub-folders. Much faster than previous versions of Thunderbird.

Expected results:

The delay before opening the folder to reveal sub-folders should be sufficiently long as with previous versions of Thunderbird. Current delay is too short and can cause multiple folders to be opened, which then remain open until manually closed again.

The default delay setting should be reasonable as before, and there should be a way to change the delay in the Config Editor.

Thanks for posting.
I've seen this reported before, don't remember where. Perhaps in support.

Didn't find other bug reports https://mzl.la/3u9HGMN

Yeah, I have seen mention elsewhere, probably support.

I would assume there is a pref somewhere in the background that controls this, but I have no information to offer. My question is, is this a defect as it is different to V102, or is it an enhancement request.

I don't think there's any Config Editor parameter that governs this. I think the guys in the thread (link above) determined the delay value is hard coded.

The behavior is different than the version of Tbird I was running before I inadvertently upgraded to 115. The previous version's delay was reasonable. The new delay is annoying and problematic, and there appears to be no way to change the delay value.

So, I'd say it is a defect.

This is definitely a defect.

We use Thunderbird to drag and drop emails to another ap[p for processing .eml files. Imagine this setup:

  • Wide screen monitor.
  • Thunderbird aligned on the right side of the monitor.
  • Drag and drop an email across the folder pane to the left side, onto the Windows desktop or another app.

In Thunderbird 102 you could just briefly drag over any folder and nothing happened. We do this for years, works perfectly.

In Thunderbird 115 that folder always opens even if you just very briefly drag over it (which you have to in order to get to the desktop or another app). Makes 115 unusable for us. We had to reverted back to 102.

(In reply to pwilly from comment #6)

In Thunderbird 115 that folder always opens even if you just very briefly drag over it...

Exactly. I have a great deal of main folders... mousing along to the target folder often opens another folder by accident. The default tight line spacing in the folders pane makes matters worse. (I like that spacing though, because more folders fit in the pane.)

I just observed another symptom. If I drag a message quickly over the folder pane, and then quickly back into the message list pane, a random folder will open and stay open. It always happens. Note, I am not hesitating whatsoever with the mouse in the folder pane... just moving quickly over the folder pane, and then quickly back to the message list pane. At that point, I hold the dragged message there, and in a second, a random folder will open.

This comment is copied from Support forum and it informs you how bad things are in a business environment.
This comment relates to two bugs which people request some haste in fixing.

  1. Cannot select multiple folder = bug 1817605
  2. Folders open too quickly on hover - as you pass over folders en route to desired folder - this bug report

Working is extremely bad now, because there is an additional new behaviour which makes it even mor worse:
If i move a folder to another subfolder, this subfolder expands. Extremely annoying if i have to move 20 folder to the "_old" subfolders. The "_old" contains already 50 to 100 old folders. And for every single folder i have to scroll back to the top oft the "_old" subfolder tree to close this screen filling subfolder. First then i can see the next folder which i want to move to "_old". Doing this process for 20 folders is absolutely ennoying.
It ennoys in private and professional use, in both cases i use Thunderbird. Maybe not for long, if this cant be solved quickly.

Tbird has been very solid, and I'm very thankful. I've been using it for around 15 years. My profile folder is approaching 30GB, and I have a huge number of mail folders and subfolders.

I have posted several bug reports now on Tbird 115. I was a systems software engineer for over 20 years. It's hard for me to understand how these defects could have been introduced, when previous versions of TB had none of these defects, and we are not talking about new features here. I hate to say this, but it sort of looks like sabotage.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9365465 - Attachment description: Bug 1863845 - Make the open folder on hover delay 1 second. r=#thunderbird-reviewers → Bug 1863845 - Make the open folder on hover delay 1 second. r=micahilbery

Comment on attachment 9365465 [details]
Bug 1863845 - Make the open folder on hover delay 1 second. r=micahilbery

Revision D194694 was moved to bug 1866580. Setting attachment 9365465 [details] to obsolete.

Attachment #9365465 - Attachment is obsolete: true

I guess a simple fix to increase the open folder delay from 500ms to 1000ms will not fix this bug.

Currently the folder opens every time, even if you simply "touch" it below 500ms. It opens delayed, but it opens every time, no matter how fast you drag over a folder.

While a longer delay sounds obvious, my guess is it may makes things worse as the timer seems not to be cancelled for some reason (which is the actual bug) and opens the folder just later. Please test properly!

Target Milestone: --- → 122 Branch

Pushed by benc@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/84eebec2c873
Make the open folder on hover delay 1 second. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Comment on attachment 9365648 [details]
Bug 1863845 - Make the open folder on hover delay 1 second. r=#thunderbird-reviewers

[Approval Request Comment]
User impact if declined: folder open too fast on drop-on
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9365648 - Flags: approval-comm-esr115?
Attachment #9365648 - Flags: approval-comm-beta?

Comment on attachment 9365648 [details]
Bug 1863845 - Make the open folder on hover delay 1 second. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9365648 - Flags: approval-comm-beta? → approval-comm-beta+

👍🙏☮️

Comment on attachment 9365648 [details]
Bug 1863845 - Make the open folder on hover delay 1 second. r=#thunderbird-reviewers

[Triage Comment]
Approved for esr115

Attachment #9365648 - Flags: approval-comm-esr115? → approval-comm-esr115+

reporter, in a day or two we can give you a candidate build to test

Flags: needinfo?(webmaster2)

Thank you, Wayne!

Flags: needinfo?(webmaster2)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

I just tested this fix on Thunderbird daily 122.0a1 (2023-12-06) on Windows 10 and it's like I predicted in my previous comment.

The folder still opens if you drag out of the Thunderbird window. It's even worse now.

As soon as the drag mouse cursor leaves the native Thunderbird window to the left (see my comment #6 for the setup), hovered folder tree folder(s) start to expand (now with 1 second delay).

It's not the folder delay causing the actual issue, even the delay was too short imo.

Reporter, if this proves to not fix the bug for you we can reopen. Until then, let's keep the resolution at fixed

Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Resolution: --- → FIXED

Bug should not be closed until verified fixed? Otherwise, why are you asking me to test it?

I can confirm the problem (Windows 10, 64bit).

Maybe the description is not sufficient to reproduce the bug. so I'll try to give a more detailed analysis here.

In Windows Explorer the user experience for Drag & Drop is as follows:

  1. Select a object with the mouse and hold the mouse button pressed.
  2. Move the object over the desired folder in the folder tree.

Now following can happen:

You release the mouse button "< X msec".

  1. The object is placed in the folder without opening it.

You keep the mouse button pressed "> X msec":

  1. The folder will be opened.
  2. You can move the mouse over the sub-folder and release the mouse button to place the object there.

In Thunderbird the user experience is:

When moving a message to a folder:

Thunderbird behaves like expected in most cases. But I have noticed that sometimes there is no response. Even if the mouse pointer is held over the folder for a long time, it does not open. If I delete the sub-folder and create it again, the parent folder opens. -> Maybe a different bug, I could not find a way to reproduce it reliable (see bug 1840484 comment 3).

When moving a folder in the folder tree to a different folder:

  1. The folder is placed in the desired folder
  2. The desired folder always opens after a few msecs.
    I have some folders with dozens of sub-folders. Whenever I drag and drop a folder to such folder containing lots of sub-folders, it will always expand regardless how fast I release the mouse button. This only change is the time after it opens. (see original bug report comment 0)

When moving an object (message or folder) over the folder tree to a different location outside the folder tree, e.g. when you move a message to a explorer windows to save it in the file system. This is what the bug references .

  1. The message is saved as expected.
  2. The folder in the folder tree that has been passed while moving the object will always opens after a few msecs (see Comment 6, Comment 15).

From what I see there are at least two bugs involved: 1) The folder always opens when an object is dropped regardless of the button release time and 2) the folder always opens when an object passes this folder without dropping it.
I doubt that is it related to the "hover on folder delay" only.

@webmaster2 I'm not sure I've covered all the cases. Maybe you can record the screen to show the problem on your system?

(In reply to webmaster2 from comment #26)

Bug should not be closed until verified fixed? Otherwise, why are you asking me to test it?

The bugzilla process is typically when a patch is landed (comment 16), then the bug is set to FIXED. If the build resulting from the patch is found to not be effective in resolving the issue then the bug may be reopened.

I have confirmed that this bug, "hover on folder delay is too short," has been fixed in 115.5.2.

However, what I said in Comment 8 has not been fixed:

I just observed another symptom. If I drag a message quickly over the folder pane, and then quickly back into the message list pane, a random folder will open and stay open. It always happens. Note, I am not hesitating whatsoever with the mouse in the folder pane... just moving quickly over the folder pane, and then quickly back to the message list pane. At that point, I hold the dragged message there, and in a second, a random folder will open.

Should I open a new bug report?

thanks

Richard Marti (:Paenglab), please advise.

thanks

Flags: needinfo?(richard.marti)

This bug is fixed for the initial issue. Please file a bug for this additional issue.

Flags: needinfo?(richard.marti)

OK, will do

See Also: → 1870573
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: