Closed Bug 1817605 Opened 1 year ago Closed 7 days ago

Can't select multiple folders in new folder tree to move, delete or mark as read

Categories

(Thunderbird :: Folder and Message Lists, defect, P3)

Thunderbird 111

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 wontfix, thunderbird111 wontfix, thunderbird112 affected, thunderbird128 verified)

RESOLVED FIXED
128 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- wontfix
thunderbird111 --- wontfix
thunderbird112 --- affected
thunderbird128 --- verified

People

(Reporter: peter.schlemihl, Assigned: aleca)

References

(Blocks 3 open bugs, Regressed 1 open bug, )

Details

(Keywords: regression, ux-efficiency, Whiteboard: [Supernova3p])

Attachments

(5 files, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/110.0.0.0 Safari/537.36

Steps to reproduce:

Can't select multiple folders in new folder tree:
Click on a folder, use Shift+Down-arrow to select multiple folders.

Actual results:

Only one folder selected.

Expected results:

Should select multiple folders.

Blocks: sn-msglist
Whiteboard: [Supernova]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: Thunderbird 112 → Thunderbird 111
Severity: -- → S3
Blocks: sn-folderpane
No longer blocks: sn-msglist
Duplicate of this bug: 1819572
Priority: -- → P2
No longer duplicate of this bug: 1819572
Priority: P2 → P3

We have no intention of changing this.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX

So how do you move/delete multiple folders? You're removing that functionality? Will the standard selection paradigm (explained in bug 1819572 comment 8) not apply to folders any more?

Flags: needinfo?(geoff)

Unlike for messages, currently you can't select multiple folders, neither with Shift+Click, Ctrl+Click nor Shift+Down/Up-Arrow. Is this by design?

Messages show the standard selection behaviour now that bug 1819572 is fixed. Thanks for that! So is the same not desirable for folders?

Flags: needinfo?(geoff) → needinfo?(alessandro)

I'm not sure we want to do this.
For sure, moving multiple folders at once will be annoying, but how often does a user need to organize multiple folders?

Messages are another thing, where multi selection actions are the norm, and we also offer a proper layout to handle multiselection.
For folders, if we allow selecting multiple folders we will need to create a new view to reflect that state in the message thread.

There are potentially a couple of "good" actions that might be triggered on multi folders, like opening then in separate tabs, or marking them as read all at once.

For now we're not planning to tackle this, but if we get many bug reports with valid workflows, we could consider it.

Flags: needinfo?(alessandro)

I agree, selecting multiple folders is not a common requirement, but when you need it, it will be most surprising that is doesn't work since it's been available for the last 20 or so years in Netscape/Thunderbird and any OS.

One more common use case is deleting or moving multiple folders to the trash. Also after an import from another client, there will be the need to move/delete multiple folders.

Whiteboard: [Supernova] → [Supernova3p]

(In reply to Alessandro Castellani [:aleca] from comment #6)

I'm not sure we want to do this.
For sure, moving multiple folders at once will be annoying, but how often does a user need to organize multiple folders?

Probably not often, but sometimes users need to do fundamental reorganization, for instance when migrating or merging mail accounts. This is something where Thunderbird always had significant edge over web interfaces. So I am sad that this was decided to go to WONTFIX - is it really that hard to implement?

For now we're not planning to tackle this, but if we get many bug reports with valid workflows, we could consider it.

One thing about re-organizing folder locations - it is obviously very very difficult to do with just the folder pane alone - (both as a source and target, and even when just done with a single folder) but once you use a tool like QuickFolders or Nostalgy to select the target folder it becomes quite a simple operation. There may obviously also be a pitfall here - as moving in IMAP can take a long time especially if you go across account boundaries - this may not be obvious to casual users. However if you're aware that it may be time consuming, having to break up moving cherry picked folders to a new target into several lengthy operations will also add to the pain for the user - so I don't think "how often is it needed?" is a good counter argument to "how difficult are we making our user's work when we take it away when it is needed?".

Duplicate of this bug: 1843686
Duplicate of this bug: 1844134
Duplicate of this bug: 1846233
Duplicate of this bug: 1846797

(In reply to Alessandro Castellani [:aleca] from comment #6)

I'm not sure we want to do this.
For sure, moving multiple folders at once will be annoying, but how often does a user need to organize multiple folders?

I need this regularly. I get hundreds of e-mails from people that are either sorted project-related or person-related. When these are done, the folders are moved to an archive.

It is an essential feature, not only a nice to have.

Blocks: 1846969
Summary: Can't select multiple folders in new folder tree → Can't select multiple folders in new folder tree to move, delete or mark as read
Duplicate of this bug: 1855114
Duplicate of this bug: 1846969

This bug is causing a workflow problem in Supernova 115* and we are starting to see comments from users in the Support forum and other forums like reddit (link previously mentioned)
https://support.mozilla.org/en-US/questions/1424967

https://forums.opensuse.org/t/need-features-missing-from-thunderbird-102-they-are-in-betterbird-102-a-thunderbird-fork-by-the-original-thunderbird-developer/166314

I fnd it difficult to believe this omission of functionality was intentional, so I choose to prefer to think of this bug as an accidental omission oversight by the developers.

But now it's known as a bug - a complete none inclusion of an important piece of functionality that effects workflow, to users the comments posted seem to suggest the developers have not grasped the extent this functionality is used.
When a new major upgrade is released, users do not expect the product to offer less.
Surely, the new Supernova is able to provide at least the same functionality of it's predecessor version 102*.
Sorting out this bug would show to users that developers do listen to reasonable requests to maintain normal functionality in new upgrades.

See Also: → 620324, 1780951, 774193
Duplicate of this bug: 1855217
Duplicate of this bug: 1855725
Duplicate of this bug: 1856561
Duplicate of this bug: 1857216
Duplicate of this bug: 1857786
Duplicate of this bug: 1858214
Duplicate of this bug: 1859124
Duplicate of this bug: 1859217
Duplicate of this bug: 1860028
Duplicate of this bug: 1861250

(In reply to Geoff Lankow (:darktrojan) from comment #2)

We have no intention of changing this.

(In reply to Alessandro Castellani [:aleca] from comment #6)

I'm not sure we want to do this.
For sure, moving multiple folders at once will be annoying, but how often does a user need to organize multiple folders?

Messages are another thing, where multi selection actions are the norm, and we also offer a proper layout to handle multiselection.
For folders, if we allow selecting multiple folders we will need to create a new view to reflect that state in the message thread.

There are potentially a couple of "good" actions that might be triggered on multi folders, like opening then in separate tabs, or marking them as read all at once.

For now we're not planning to tackle this, but if we get many bug reports with valid workflows, we could consider it.

You missed the point - this functionality was already available and it was removed either by deliberate action or unintentional omission and that is why there is a problem.
In a business environment this functionality is important for work throughput.

Not fixing this means you are accepting it is ok to perform unnecessary mass scale repeat actions and that can create or trigger RSD and in my personal opion think Thunderbird should not be designed deliberately to aggravate or contribute to causing RSD.

Not everyone complains in Bugzilla when something does not work. Judging by comments in Support Forum many people do not even know Bugzilla exits. Many may believe supernova is an ongoing improving design because that is the kind of comments being made by the developers, so expect things to get fixed soon, so they are sitting it out or just reverting to 102* until supernova has fixed all of it's issues.

But an improved design should be at least as good as it's predecessor.
Therefore, the decision to not fix this is not really an acceptable cause of action and should be reconsidered.

Another report in Support Forum.
https://support.mozilla.org/bm/questions/1427536

For example, I used to be able to select the "Inbox" and "Sent" folders at the same time, allowing me to perform various actions on them simultaneously. This functionality has been essential for my workflow, and its absence in the new version is causing significant inconvenience.
Expected Behavior:
In previous versions of Thunderbird, I was able to select multiple folders from the left panel and perform actions on them, such as marking them as read/unread.
Actual Behavior:
In Thunderbird Supernova 115.3.2, I am unable to select multiple folders from the left panel. Only one folder can be selected at a time, which makes it impossible to perform certain actions on multiple folders simultaneously.

This change in behavior is causing a significant disruption to my workflow, as I frequently need to work with multiple folders at once. I kindly request that this feature be reinstated.

Duplicate of this bug: 1861429
Duplicate of this bug: 1862035
Duplicate of this bug: 1862780

Quotes from different people who need to have multiple folder selection, so developers can understand the kind of normal practise used in a work environment. It's not just being able to eg: mark as read on multiple folders at once, it is also used by some people when performing a backup of specific folders.

The lack of functionality is a big impact on costs and data throughput due the significant increase in time to perform something that should take seconds.

Hello, without the "mark multible folder" feature since version 115 and further we have the same problem as described here by e.g. Kenneth. We get a lot of digital invoices from our suppliers by mail (envelop mail + pdf attachment) every day. To maintain some kind of transparency we sort all these emails in different subfolders (named after suppliers) within the accounting departments mailaccout. As german tax legislation forces us to archive these documents (envelop mail and pdf) to an unchangeable media the easiest way to fullfill this requirement is the export of all these subfolders with the Thunderbird add-on ImportExportTools NG to html-format with the whole structure index and attachments to a filesystem share and burn them on a read only CD periodically. Before version 115 with multible folder selection the export from Thunderbird was a matter of a handful clicks and several seconds. Now this is a job of at least an hour or more because you have to export every subfolder one by one. The risk of errors or forgetting a subfolder is also increased a lot.

I have a lot of local folders where my emails are put.
I use add-on ImportExportTools NG in Thunderbird. This add-on can create e-mails in EML format, which I want as a backup of all e-mails located in different local folders.
As it is now, I can only mark one folder at a time.
It's always been super easy as I hold down Ctrl and just start selecting the number of folders I wanted.
It takes a very long time to backup this way as it is now.
Before Thunderbird was updated, there were no problems and has worked fine for many years.

I use it mainly for marking multiple folders read at the same time.
I get in alerts from various systems and often it is not a matter of what the alert says, but how many of them their are (but I can't just use a counter as just as often I need the content of these emails). My filters direct these emails into certain folders and they sit there and my little number that shows the number of new emails on those folder increases. At certain levels I need to do something and mark a number of these folders as read. It has always been super easy as I hold down Ctrl and just start selecting a dozen or so folders and once I have the ones I need to clear I right click and select mark read and I am all set. I can no longer do that and it is really effecting a pretty important process that has worked fine with thunderbird for 15+ years.
I cannot fathom why this bug was marked won't fix.

What's the last version of Thunderbird that allows this? I'll just downgrade and disable auto updates.
The irony is Thunderbird just asked me to donate today after taking away my most used feature.

I use this feature practically every time I log into Tbird. This is not unnecessary. I probably get 500 emails a day and having filters to move things to folders is the only way I can manage them. Then I can select multiple folders and mark things Read.

It's getting to the point where I'm about to regress a version because traversing dozens of folders to manually mark messages read is annoying at best.

This comment made by someone in the Support Forum shows how exasperating and time consuming it is when you cannot select a group of folders and put them in a suitable folder in one go. Forced to repeat perform an excessive number of times.

Working is extremely bad now, because there is an additional new behaviour which makes it even mor worse:
If i move a folder to another subfolder, this subfolder expands. Extremely annoying if i have to move 20 folder to the "_old" subfolders. The "_old" contains already 50 to 100 old folders. And for every single folder i have to scroll back to the top oft the "_old" subfolder tree to close this screen filling subfolder. First then i can see the next folder which i want to move to "_old". Doing this process for 20 folders is absolutely ennoying.
It ennoys in private and professional use, in both cases i use Thunderbird. Maybe not for long, if this cant be solved quickly.

This comment informs you how bad things are in a business environment.
This comment relates to two bugs.

  1. Cannot select multiple folder = this bug report
  2. Folders open too quickly on hover - as you pass over folders en route to desired folder - bug 1863845

(In reply to Anje from comment #35)

This comment made by someone in the Support Forum shows how exasperating and time consuming it is when you cannot select a group of folders and put them in a suitable folder in one go. Forced to repeat perform an excessive number of times.

can you link to the post? I would like to help them - I have a workflow in QuickFolders that may help alleviate most of the work (even though it would be even better if there was multiple selection possible). Generally the folder tree is a bad tool for navigation / mail or folder management, as scroll=dragging is very difficult. Add-ons are better equipped to deal with this. With QuickFolders you can move folders quickly without using the mouse excessively. If you move many folders to the same new parent it's even faster as it autofills the last target.

Still I would like to eventually have the multiple selection feature back to make it even more comfortable again.

(In reply to Axel Grude from comment #36)

(In reply to Anje from comment #35)

This comment made by someone in the Support Forum shows how exasperating and time consuming it is when you cannot select a group of folders and put them in a suitable folder in one go. Forced to repeat perform an excessive number of times.

can you link to the post? I would like to help them - I have a workflow in QuickFolders that may help alleviate most of the work (even though it would be even better if there was multiple selection possible). Generally the folder tree is a bad tool for navigation / mail or folder management, as scroll=dragging is very difficult. Add-ons are better equipped to deal with this. With QuickFolders you can move folders quickly without using the mouse excessively. If you move many folders to the same new parent it's even faster as it autofills the last target.

Still I would like to eventually have the multiple selection feature back to make it even more comfortable again.

https://support.mozilla.org/en-US/questions/1424967#answer-1619634

After considering feedback and evaluating possibilities, this feature is more a UX efficiency matter for folder management.
Still a fairly edge case as the majority of users don't do any folder management at all, therefore the low priority and the not targeting of 115.

I'll take this in order to explore and scope this work to define objectives, limitations, and implementation.

Assignee: nobody → alessandro
Status: RESOLVED → REOPENED
Keywords: ux-efficiency
Resolution: WONTFIX → ---

Thank you, :aleca for re-opening the discussion on this feature. It feels like an honest attempt to reach out to users who are feel they are being ignored.

To add my two yen, I feel that rather than being an edge case, being able to select multiple objects is an essential productivity feature in Windows, Linux, MacOS, and other GUIs. I (used to) regularly select multiple folders in Thunderbird to delete, copy, move, mark as read, and apply actions from various add-ons.

Some developers indicate that this feature is unessential. I suppose it is. However, the ability to select multiple folders and apply various actions is without doubt a time-saver (what :aleca terms an "UX efficiency matter"). It is critical enough in this regard to motivate me to use a portable and previous version of Thunderbird that still has the feature in question.

This bug has enough comments already, please refrain from writing pure advocacy comments like "I use this too" or "this is very important to me".
We will evaluate this implementation and have it done when we can.

DISCLAIMER: This is not a "I use this too" or "this is very important to me" comment, but an attempt to highlight a flawed (in my opinion) mindset that you have adopted.


Hello Mr. Castellani,

I appreciate the reconsideration of this request, and I'm grateful that you've reopened it. However, I'm curious about the assumption that the majority of users don't engage in folder management.

It's worth noting that most users are not even aware of the Bugzilla platform to voice their concerns. As an experienced programmer, even I had some difficulty locating where to file an issue initially. It's reasonable to assume that a typical user, who may have had Thunderbird installed by a tech-savvy friend, might not even consider expressing feedback or complaints to a major company like Mozilla. Additionally, as long as you had a won't fix status, someone couldn't write a comment, and I don't see any unvoting system anyway. So, all this time, even those who managed to find this issue here couldn't comment or vote for it. What is more, seeing that the staff has marked it with a won't fix status, it obviously made them abandon the case, considering it to be only their own problem. Therefore, the existing number of reported issues on Bugzilla (even though it is not small) definitely does not represent the true scope of user experiences.

As a UX lead, you're undoubtedly aware that multiselection is a fundamental functionality, even in small personal projects nowadays. It's akin to suggesting that including a right-click menu is unnecessary because users can navigate through the menu bar. Multiselection has become an expected and intuitive feature and its absence impacts user experience significantly, like in our case.

I understand that resource constraints might affect the speed of addressing this issue, but suggesting that almost no one uses multi-selection in 2024 seems misleading.

Thank you again for your attention to this matter, and I look forward to the implementation, as I currently spend more than two minutes daily on the serial selection of folders for my five emails.

Duplicate of this bug: 1875685
Restrict Comments: true

Simple conversion from regular JS file to .mjs.
Doing so enables us to remove the code block since we won't have leaks
as well as more easily handle imports from and to other modules.

Keywords: leave-open

Simple code update to separate the tree listbox mixin and its implementaions
into standalone files.
Easier to import only what we need, keep the files small, and enable devs to
work on improvements with fewer collisions.

Simple code update to separate the tree listbox mixin and its implementaions
into standalone files.
Easier to import only what we need, keep the files small, and enable devs to
work on improvements with fewer collisions.

Depends on D199802

Attachment #9377271 - Attachment is obsolete: true

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/f578ddbb7971
Convert the tree-listbox widget into an es6 module. r=leftmostcat
https://hg.mozilla.org/comm-central/rev/400a821cff32
Split the tree-listbox file into separate modules. r=leftmostcat

Restrict Comments: false
Regressions: 1877671
Target Milestone: --- → 124 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/3016967ebaa2
Update tree-listbox stories and support importing chrome:// URIs in storybook. r=aleca

(In reply to Abdülkerim from comment #52)

(In reply to thenterprises2 from comment #53)

(In reply to Alessandro Castellani [:aleca] from comment #6)

I'm not sure we want to do this.
For sure, moving multiple folders at once will be annoying, but how often does a user need to organize multiple folders?

Messages are another thing, where multi selection actions are the norm, and we also offer a proper layout to handle multiselection.
For folders, if we allow selecting multiple folders we will need to create a new view to reflect that state in the message thread.

There are potentially a couple of "good" actions that might be triggered on multi folders, like opening then in separate tabs, or marking them as read all at once.

For now we're not planning to tackle this, but if we get many bug reports with valid workflows, we could consider it.

I do this annually, when I archive my mails from multiple accounts. I like to archive them in folders which are <YYYY>/<accountname>/<folder structure>. Since Tbird does not file them this way, I have to drag all the folders, one by one, to the appropriate year folder. I have maybe 15 e-mail addresses each with multiple folders (some just a few, some over a hundred, nested). It's a royal pain in the butt to have to drag (or right-click/move) each of the top-level folders in each of my archives to the right spot.

Let me reply to your comment even though this is hidden with the advocacy tag.
I think this will be valuable once it lands in Thunderbird 128 - I want to support it from my Add-on QuickFolders in the betas / daily as soon as it is available. With QuickFolders it is relatively trivial to move [many] folders as long as multi-folder selection is somehow supported - you can just drag the folder(s) to the quickMove button and enter the target folder name. It may help you as well if you have to do it one by one as you can us a keyboard shortcut (QF Pro) and it remembers the last entry, so you can just do Shift+M and move the folders one by one without having to scroll through the tree again and again.

thanks to the core team for doing some coding steps towards this goal. Selecting multiple folders may be helpful for other tasks such as coloring / tagging folders which may be provided by new Add-ons.

Quick flyby comment to provide a little update.
After a lot of refactoring and piping, finally things are getting very close to completion.

Multiselection works and the message list also reacts properly to empty folders.
I just need to make sure that the context menu and all various actions (delete, move, repair, etc) work properly for all currently selected folders.

Thanks for your patience.

(In reply to Alessandro Castellani [:aleca] (PTO March 18-22) from comment #56)

Created attachment 9389873 [details]
Recording 2024-03-06 192214.mp4

Quick flyby comment to provide a little update.
After a lot of refactoring and piping, finally things are getting very close to completion.

Multiselection works and the message list also reacts properly to empty folders.
I just need to make sure that the context menu and all various actions (delete, move, repair, etc) work properly for all currently selected folders.

Thanks for your patience.

Finally...!!!

Good job!

Estimated release date?

Estimated release date?

Short answer, version 128 this summer. Longer answer, these are extensive changes which won't happen for version 115.

Attachment #9400858 - Attachment is obsolete: true
Attachment #9388586 - Attachment description: WIP: Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. → Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. r=darktrojan,freaktechnik,mkmelin
Depends on: 1896531
Attachment #9388586 - Attachment description: Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. r=darktrojan,freaktechnik,mkmelin → WIP: Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin.
Attachment #9388586 - Attachment description: WIP: Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. → Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. r=darktrojan,freaktechnik,mkmelin
Attachment #9388586 - Attachment description: Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. r=darktrojan,freaktechnik,mkmelin → Bug 1817605 - Implement a simple multiselection option for the tree-listbox-mixin. r=darktrojan,mkmelin,#thunderbird-front-end-reviewers
Target Milestone: 124 Branch → 128 Branch

Pushed by martin@humanoids.be:
https://hg.mozilla.org/comm-central/rev/bc7a4b8a50f4
Implement a simple multiselection option for the tree-listbox-mixin. r=darktrojan,mkmelin,arschmitz

Status: REOPENED → RESOLVED
Closed: 1 year ago10 days ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Regressions: 1900865
Blocks: 1896531
No longer depends on: 1896531
Blocks: 1901339

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/eec2c8c99c5f
Implement a simple multiselection option for the tree-listbox-mixin. r=arschmitz,darktrojan,mkmelin

Status: REOPENED → RESOLVED
Closed: 10 days ago7 days ago
Resolution: --- → FIXED
Regressions: 1901386

Hello,
Managed to reproduce this issue with the affected build from 2023-03-14 112.0b1(20230314133743) using Windows 10.
Confirming this issue as verified fixed on 128.0b1(20240610221456) using Windows 10 and Mac Sonoma 14.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: