Closed Bug 18642 Opened 20 years ago Closed 20 years ago

dynamic created Select elements don't display the current selection

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3, major)

x86
All

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 19373

People

(Reporter: huang, Assigned: rods)

References

Details

Used 11-10-17-M11 on Linux & WindowNT:

Overview:
The address panel should reflect Cc: & Bcc: after selected addresses for Cc: &
Bcc: from Select Addresses Window of Address Book

1) Select "New Msg" for compose new message.
2) Select "Address" from this compose window.
3) After the "Select Address" Window displayed, select the collected
Address        Book and highlight some addresses and then selecting for To: and
Cc: and Bcc:
   those address.
4) Actual Results: After selected "OK" from "Select Address" Window, the
Addressing Panel not reflect for Cc & Bcc... (only reflect for To:)

Expected Results: The Addressing Panel should reflect Cc & Bcc (not only
reflected To:) after selected To:, Cc: and Bcc: from Select Addresses Window of
Address Book.
Assignee: hangas → ducarroz
JF: sending this to you.  Looks like a compose window problem.  But if it turns
out to be an issue with the select address dialog please pass it back.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Duplicate of bug 17931

*** This bug has been marked as a duplicate of 17931 ***
Esther,

I am thinking that this bug is different as bug#17931, 17931 is regarding to
"cannot send message if the address are over than 2"
But this bug is regarding to the address panel NOT reflect Cc: & Bcc: AFTER
selected addresses for Cc: & Bcc: from "Select Addresses Window"of Address Book.
Isn't it?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
OK, this bug is related so maybe it should be a depends on each other but I will
remove the duplicate and let development decide that.
Release Note for M11
QA Contact: lchiang → esther
Assignee: ducarroz → trudelle
Blocks: 16841
Severity: normal → major
Status: ASSIGNED → NEW
Summary: The address panel should reflect Cc: & Bcc: after selected addresses for Cc: & Bcc: from Select Addresses Window of Address Book → dynamic created Select elements don't display the current selection
It's a problem with the select element. if the select element has been created dynamically, the title of it does show
the current selection. But if you click on the select element, you can see that the selection is correct.

That appends also when the user change manually the recipient type (to, cc, bcc...) during message composition.

WARNING: that doesn't append with the first row in the addressing widget as it's not created dynamically.
Assignee: trudelle → kmcclusk
That's an HTML Forms Control, reassigning to kmcclusk
Assignee: kmcclusk → rods
Re-assigning to Rod
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
this is a duplicate of a dogfood blocker 19373

*** This bug has been marked as a duplicate of 19373 ***
Depends on: 19373
I've added myself to the cc: list of the other bug.  esther, let's keep this one
unverified for now and wait until 19373 is fixed and we can verify this case.
Thanks.
Status: RESOLVED → VERIFIED
Using m12 builds 1999121409 on win98, 1999121411 on linux and 1999121408 on mac
this is fixed.  All (3) addresses I put in the Select Address bucket were
displayed in the new compose window addressing area.  Verified this scenario for
duplicate bug 19373 bug fix.
No longer blocks: 16841
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.