Closed Bug 188263 Opened 17 years ago Closed 16 years ago

MacOS: Cannot launch Netscape from Double-byte Profile

Categories

(Core Graveyard :: Profile: BackEnd, defect, critical)

PowerPC
Mac System 9.x
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: teruko, Assigned: ccarlen)

References

Details

(Keywords: intl, regression)

You can create the double byte profile, but you cannot launch Netscape from the
double-byte Profile name on MacOS.

Steps of reproduce
1. Launch Profile Manager
2. Create Japanese profile on MacOS X with Japanese UI
3. Launch Netscape from the Japanese profile which you create in step #2

Actual result
The error "Component returned failure code : 0x80004005 (NS_ERROR_FAILURE)
[nslProfileInternal.startApprunner]" will display and Netscape does not launch.

Expected result
Netscape will launch.

I tested this in 1-08 trunk Win32 and Linux builds. This does not happen in
Win32 and Linux build.  This happens only on Mac OS build.

I tested this on 12-09 MacOS trunk build on 10.2.  This exists in the build.
Changed QA contact to myself for now.
QA Contact: ktrina → teruko
Keywords: nsbeta1
1. Try this with the Mach-O build.
2. When was the last time this was known to work with CFM build?
I forgot to mention I tested 01-08 trunk MacOS build.

Answer commnet #2.
1. I tested this with 01-08 Mach-o build.  I could not reproduce this.  
2. I am sorry I am not familiar with the terminology. What does CFM bould mean? 
This is 10.2 specific - no reproducible on 01-08 trunk build / Mac 10.1.5.

Not reproducible on N7.01/Mac 10.2.2.

And I don't see it on 11-11 trunk build /10.2.2, Teruko said she had this
problem on 12-09 trunk build, so the regression must be between 11-11 and 12-09.
> What does CFM bould mean? 

CFM build is the type that is built with CodeWarrior. All mozilla milestone
releases, through 1.3a, have been CFM. The Mach-O build is built with gcc and
uses only Unicode file system APIs. CFM is being phased out in favor of Mach-O.
I found out this started to happen from 11-24-03 1.3a trunk build.  This worked
fine in 11-22-12 trunk build. 

And, I do not think this is specific on 10.2.  I could reproduce this on 10.1.4,
too.
*** Bug 188392 has been marked as a duplicate of this bug. ***
Despite comment#4 by ylong, I have observed that 2002010808 trunk for MacOSX is
affected. I have a OSX(10.1.5) boot partition which has its name in Japanese. If
I try to launch 010808 nightly, Mozilla gives the same error message. This
happens even after I create a new profile.
Therefore, the problem is not necessarily caused by the name of the profile,
but, not surprisingly, in the path name of the profile.
Yes. This happens if the profile path contains Japanese.  
See also bug 175991. In my previous comment, I meant 20030108008 trunk.
Did this problem happen with path name in Japanese of the profile?  See bug
158516#4.  In the comment of bug 158516, commentator got same error message. 
And Mozilla created broken profile.  I think that this problem and bug 158516
happened without path name in Japanese of the profile.  Is bug 158516 marked as
a duplicate of this bug?
I do not think bug 158516 is dup of this bug. The same error message will shows
up, but bug 158516 is nothing to do with double byte.  I can create the Ascii
profile name and I can launch Netscape from it.
Blocks: 157673
Does this happen in Mach-O builds?
As in comment#3, Mach-O build is not affected. (Tested with 20030117 Mach-O,
OSX10.1.5.)
CFM is dead; Mach-O is the future, so this bug is wontfixable.
*** Bug 190026 has been marked as a duplicate of this bug. ***
Why is Chimera(Mach-O) crashing now in OSX10.2.3(bug 190026)? AFIK, 030110 build
was OK in 10.1.5.
> Why is Chimera(Mach-O) crashing now in OSX10.2.3

Do you have a crash log for that? If so, please file another bug
(product==Chimera) and CC me. This bug was about CFM Netscape which is quite a
different animal.
#17 was based on my misunderstanding. Chimera is OK. Sorry about that.
per i18n triage meeting: nsbeta1-
Since CFM is being phased out in favor of Mach-O this bug won't be fixed. Please
reopen if you'll see on MacOSx with new builds
Keywords: nsbeta1nsbeta1-
WONTFIX based on last comment.  This is NOT present on OS X, based on comments.
Status: NEW → RESOLVED
Closed: 16 years ago
OS: MacOS X → Mac System 9.x
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.