Sidebar sizes improperly when collapsed without focus

VERIFIED WORKSFORME

Status

SeaMonkey
Sidebar
P4
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Joseph Elwell, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The customizable Sidebar Panel draws improperly when clicked on at the same time
that Mozilla is given focus.

To reproduce:
open Mozilla.
open notepad.
move notepad over so that you can see the light blue part of the sidebar.
click on that light blue part of the sidebar (note: it should get lighter when
you mouse over. even though Notepad still has the focus.)
Watch the side panel be redrawn funny.

I'm using Build ID: 1999111508
1999111108 also has this problem.

Comment 1

19 years ago
Nice bug, I see this too. Clicking on the splitter when apprunner does not have
focus causes funny things. Not sure who should get this. Looks windows only.

Updated

19 years ago
Assignee: slamm → evaughan
Summary: Customizable Sidebar Panel Sizes improperly. → Sidebar sizes improperly when collapsed without focus

Comment 2

19 years ago
Box bug. I see this same sort of bug intermittently on Linux too. This testcase
is the best testcase I have seen to reproduce it.

Reassigning to evaughan.
Changing summary.

Comment 3

19 years ago
*** Bug 18795 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Priority: P3 → P4
Target Milestone: M15

Comment 4

19 years ago
this seems to be very minor, targetting p4 for m15,speak up if there is a bad
case.

Comment 5

19 years ago
*** Bug 22504 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 24700

Comment 6

19 years ago
may be another manifestation of 23858
(Reporter)

Comment 7

19 years ago
bug 23858 seems to have the same end result. Although sometimes repeating the 
steps in this bug 18923 cause the sidebar to open past the right border of 
Mozilla, and with no scroll bar, I can't get it back...

Comment 8

19 years ago
the second bug you refer sounds like bug 23857 though that is marked linux only
(Reporter)

Comment 9

18 years ago
Created attachment 6655 [details]
This is what happens now! If you try to click on the grippy when Mozilla doesn't have focus.
(Assignee)

Comment 10

18 years ago
I can not reproduce this in the current build. Can anyone else?
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
verif
Status: RESOLVED → VERIFIED
QA Contact: paulmac → shrir
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.