Number of unread messages shows a short count

VERIFIED DUPLICATE of bug 147110

Status

MailNews Core
Networking: NNTP
VERIFIED DUPLICATE of bug 147110
15 years ago
9 years ago

People

(Reporter: Stewart Gordon, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126

When I open a newsgroup, the number of unread messages displayed in the
left-hand pane is often somewhat smaller than the number that are actually
there.  Pressing Get Msg corrects the number, but when I then read another
message, the bogus count comes back.

Reproducible: Sometimes

Steps to Reproduce:
1. Open a newsgroup that has unread messages.
2. Read some previously unread messages and/or mark threads as read or ignore.
3. Before marking everything as read, press Get Msg.
4. Read some more unread messages.
Actual Results:  
1. The unread message count might decrease.  At first I thought this was it
marking the new ignored messages as read, but now I know it isn't.
2. The displayed number of unread messages decreases by the number of messages
that have been marked read, until it stops decreasing at zero.
3. The unread message count becomes correct.
4. The bogus number of unread messages comes back, out by the same number as it
was before.

Expected Results:  
Displayed the correct number of unread messages throughout the operation.
(Reporter)

Updated

15 years ago
Blocks: 71728

Comment 1

15 years ago
FYI : other counting bug in mozilla : bug 186650. Related?
(Reporter)

Comment 2

15 years ago
Uh, probably not.  But notice that those are far from all the counting bugs, if you look at 
the tracker bug 71728.
(Reporter)

Comment 3

15 years ago
Just found bug 147710.  But on mine, pressing Get Msg always updates the count
to the correct figure, and otherwise the counting error seems unrelated to the
number of ignored messages or threads.

Comment 4

15 years ago
It _is_ the same as bug 147110 (not 147710 you mentioned).

Just tested on Moz 1.0.1:
0. I have a newsgroup with lots of ignored threads.
1. Mozilla refreshes the number of new posts when I open the newsgroup tree. The
newsgroup shows 5.
2. I click on the NG, Mozilla downloads headers and shows 0 unread. But I can
see 2 unread messages in the message pane.
According to bug 147710, I should see -1 (5 total new minus 3 ignored, counted
twice), but in case of negative number Mozilla stays at zero.
3. Press GetMsg - in the newsgroup tree 2 is displayed.
4. Click on another NG, click back - 2 disappears and newsgroup is 0 unread,
still seeing the 2 msgs in msg pane.
5. Repeating steps 3. and 4. doesn't change anything, as long as there are no
new posts.

On Moz 1.3a release (which fixed bug 147110) I don't see these oddities.
(Reporter)

Comment 5

15 years ago
Oops, typo.  I meant bug 147110.  But why minus _3_ ignored?  You just told me you 
have lots of ignored threads.

Expand the 'group tree, count 48.
Open the 'group, count drops to 25 and then immediately up to 26.
There are actually 48 - count out by 22

OK, so there seem to be about 22 ignored messages that came through since I checked 
yesterday.  But if it were that then, surely, the result of step 4 wouldn't happen, since the 
22-odd ignored messages are no longer 'just in' at this stage?

Stewart.

Comment 6

15 years ago
>But why minus _3_ ignored?  You just told me you have lots of ignored threads.
Because only 3 messages of 5 landed in the ignored threads :)

Could you check a recent build? You may have to mark the newsgroup read to set
all the counts straight before testing again.
(Reporter)

Comment 7

15 years ago
I think you're right, this is bug 147110.  But no such problem happens on 1.3 beta.

*** This bug has been marked as a duplicate of 147110 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: number of unread messages shows a short count → Number of unread messages shows a short count
(Reporter)

Updated

15 years ago
No longer blocks: 71728
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.