keyboard shortcut (accel+Shift+V) for "paste without formatting"

RESOLVED FIXED in seamonkey2.0a2

Status

enhancement
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: jruderman, Assigned: mkmelin)

Tracking

Trunk
seamonkey2.0a2
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Ctrl+Shift+V should be "Paste without formatting" in Midas, Composer, and the
Message Composition window.  This would be consistent with Word Perfect, which
uses Ctrl+Shift+V for "Paste without font/attributes" (bug 64647 comment 42).

Composer and Message Composition currently use Ctrl+Shift+V for "Paste as
quotation". I think it makes sense to change Ctrl+Shift+V to "Paste without
formatting" because

* I paste from web pages into e-mail messages (and therefore need "Paste without
formatting") all the time, but I rarely quote text from multiple e-mails in one
e-mail I send.

* "Paste as quotation" only lets you increase the quotation level, so there
should be "Increase quotation level" and "Decrease quotation level" commands anyway.

* "Paste as quotation" only makes sense in message composition, whereas "Paste
without formatting" also makes sense in Composer and Midas.

* The shortcut for "Paste as quotation" doesn't appear in menus or in
http://www.mozilla.org/docs/end-user/moz_shortcuts.html, so I don't think many
current users know about the shortcut I'm proposing we change.

* Not many people seem to care that they can't find a keyboard shortcut for
"Paste as quotation" (bug 100567 has 0 votes), while bug 64647 for adding a
"Paste without formatting" command has 3 votes.
Ctrl+Shift+V is currently paste as quotation in mail.

I'd like to be consistent in compose, mailcompose and Midas. I don't know -
maybe we should change mail so that Ctrl+Shift+V is paste without formatting.
I could be mis-remembering here but I think that we (Composer team) were
planning for accel-shift-V to be something else (paste special?).  

Regardless, currently in Composer, accel-shift-V pastes as quotation (even tho
the menu item is not listed).
OS: Windows XP → All
Hardware: PC → All
Summary: keyboard shortcut (Ctrl+Shift+V) for "paste without formatting" → keyboard shortcut (accel+Shift+V) for "paste without formatting"
Target Milestone: --- → Future
*** Bug 259071 has been marked as a duplicate of this bug. ***
I think you need Paste without font/attributes more often than paste with. In
composer, if you paste anything, more often than not it does not fit to the
current text you are working on, and there is no Format Brush to quickly adapt
the pasted text to the surroundings (Bug 239054). So I even think, Paste without
font/attributes should be the default and should be Ctrl+V.
Product: Browser → Seamonkey
BTW: Bug 273008 is the Thunderbird version of this bug (Should this be a "Core"
bug?)
Well, not actually a core issue since the aviaries can be as inconsistent as
they like - they don't claim to be more then standalone programs.
In the suite, however, having consistent key bindings is a must.

I do agree that when pasting text, one almost always is just interested in the
actual text, not in its formatting. I strongly would like to see ^V (etc.) to do
"paste without formatting", thus having "paste with formatting" as a mere
menuitem. I doubt that "paste with formatting" is used often enough to justify
its own shortcut.

The "paste as quotation" shortcut (Shift-^V etc.) is an entirely different
issue, especially in mail - it's very convenient as workaround there because the
(plaintext) mail editor is still one of our greatest weknesses. :-/
(In reply to comment #6)
>I strongly would like to see ^V (etc.) to do "paste without formatting"
This just isn't possible because the command keys are global (stored in
platformHTMLBindings.xml) and would affect Composer and Midas too.
Actually, it would be great if Composer and MIDAS would use Paste Without
Formatting by default too. Going through notepad.exe all the time gets old.

Prog.
(In reply to comment #7)
> >I strongly would like to see ^V (etc.) to do "paste without formatting"
> This just isn't possible because the command keys are global (stored in
> platformHTMLBindings.xml) and would affect Composer and Midas too.

Well, the question is, then, if they'd object such a change?
We need to maintain consistency with OS-wide and mainstream-apps conventions.
There might even be guidelines on this. I believe they all have Ctrl+V = Paste
(with formatting). "Normal" users might also become confused if the "page's
layout" they were copying disappeared (they only know "Paste").

Suggestion:
1. Ctrl+V       = Paste (with formatting, unless in plaintext compose)
2. Ctrl+Shift+V = Paste Without Formatting   <--- This bug
3. Ctrl+Alt+V   = Paste As Quotation (least used function) (Can we bind "Alt"?)

This bug could then focus on only #2.
(In reply to comment #10)
>3. Ctrl+Alt+V   = Paste As Quotation (least used function) (Can we bind "Alt"?)
Ctrl+Alt+V is reserved for Windows lnk shortcut hotkeys.
(Shift+)Alt+V will break any extension adding a menu with a V shortcut.
With logging facility (Bug 273241) we'll be able check what action users
actually prefer, but since we don't currently have it, an additional pref (as
frowned upon as it is), might be a sufficient solution.

Prog.
(In reply to comment #11)
> (In reply to comment #10)
> >3. Ctrl+Alt+V   = Paste As Quotation (least used function) (Can we bind "Alt"?)
> Ctrl+Alt+V is reserved for Windows lnk shortcut hotkeys.
> (Shift+)Alt+V will break any extension adding a menu with a V shortcut.

How about Ctrl+Shift+Q for paste as quotation
In response to comment #8 and comment #9:
Yes, there would be objections if Composer were to have accel-V do a paste
without formatting.  It makes no sense at all for users of Composer (where it is
quite common to move blocks of text with cut/paste).

For my own use, I often do want the formatting from a browser window so I'm
happy that it is retained when pasting into Composer applications (or mail
compose).  Sometimes I don't want the formatting so I really like "paste without
styles" as an option in a context menu (which I have in my own code).

Also, personally, I do use Paste as Quotation occasionally but I can never
remember the shortcut key so I always use the menu.  I like Aaron's suggestion
but it is VERY close to Quit.  My preference is no shortcut for paste as
quotation but that is based on personal experience.
(In reply to comment #13)
> How about Ctrl+Shift+Q for paste as quotation

Ctrl+Q-based shortcuts are problematic. Take, for example, a user that edits a
MIDAS form in a window without multiple tabs and then accidently hits Ctrl+Q
instead of Ctrl+Shift+Q. In this case, dataloss will occur. See Bug 48333 for
more details on the problem.

Prog.
(In reply to comment #15)
>(In reply to comment #13)
>>How about Ctrl+Shift+Q for paste as quotation
>Ctrl+Q-based shortcuts are problematic. Take, for example, a user that ...
>accidently hits Ctrl+Q instead of Ctrl+Shift+Q.
Isn't there a bug requesting Quit be moved to Ctrl+Shift+Q?

(In reply to comment #14)
>My preference is no shortcut for paste as quotation
Can we switch paste without formatting to Ctrl+Shift+V and then if someone wants
a shortcut for paste as quotation they can file a new bug?
> >My preference is no shortcut for paste as quotation
> Can we switch paste without formatting to Ctrl+Shift+V and then if someone wants
> a shortcut for paste as quotation they can file a new bug?

That sounds good. Paste with quotation is not as common, and using a menu item
for it is really not much of a hindrance. Paste without formatting needs to be
done all the time.
OK, the most logical choice seems to be that "Paste Without Formatting" should
be Ctrl+Shift+V (and "Paste As Quotation" should be without a shortcut for now).

I there anyone here that can submit a patch for this?
I also feel that "Paste Without Formatting" is more commonly needed than "Paste
As Quotation", but we have no solid data on how many users actually use the
latter. Replacing an existing accelerator on nothing more than our own personal
preference seems a bit hasty. If you must, then the old behavior should at least
be accessible as a pref (or a hidden pref).

Prog.
Once this is settled (I vote for changing accel+shift+v to "Paste without
formatting"), can the patch contributor also change the help file, please?
erm, i use paste as quotation, and it's a royal pain to get long lines without it.

we could do this the office way which is tack on a widget that lets you remove
the formatting.

i unfortunately can't think of an easy way to default to paste without
formatting such that one could choose to get paste with formatting.

also when i have multiple html documents open in composer, it's quite likely
that i want to copy the markup instead of just the text (it usually means i'm
compositing a document from multiple other documents).
I don't have no real end user data either, but even though I'm using Paste As
Quotation a lot, I'm well aware that it may not be that common.
I'm used to Alt-E,R for Rewrap by now, so I guess I'll learn Alt-E,Q also. :-/
This is the feature I've wanted most in the Mail part of SeaMonkey (1.1.1 currently), so much so that I've been tempted to dive into the chrome to see if I could add it.  (I haven't dug into the code because it's a bit overwhelming to me at present, so I'm not really qualified to make this change.) 

I'm always having to use the context menu or the Edit menu to paste without formatting, and I use this operation constantly.  It's a real hassle to have to move my hands from the keyboard to the mouse to do this, and I had settled on Ctrl-Shift-V for the shortcut on my own, so it seems like the best choice.  I looked through all the shortcuts in the SeaMonkey help file for conflicts, and didn't find any use of this key combination, so the 'paste as quotation' must be hidden or very hard to find.  I also don't understand exactly what 'paste as quotation' does, so for me a menu option would be quite sufficient.  I want this feature more than anything else I can think of at the moment.
Assignee: composer → nobody
QA Contact: sujay → composer
Target Milestone: Future → ---
Posted patch proposed fixSplinter Review
This removes the keyboard shortcut for "Paste As Quotation" (which used to have Ctrl+Shift+V) and assigns that shortcut to "Paste Without Formatting".
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #340815 - Flags: superreview?(neil)
Attachment #340815 - Flags: review?(philringnalda)
Blocks: 273008
(In reply to comment #24)
> This removes the keyboard shortcut for "Paste As Quotation" (which used to have
> Ctrl+Shift+V) and assigns that shortcut to "Paste Without Formatting".

Magnus: You just made my day! :-D

PS. (In reply to comment #11)
> Ctrl+Alt+V is reserved for Windows lnk shortcut hotkeys.

What are "Windows lnk shortcut hotkeys"? Are they ever used? (i don't) Can they be overridden?
Comment on attachment 340815 [details] [diff] [review]
proposed fix

>+    <key id="key_paste_no_formatting" key="&pasteNoFormattingCmd.key;"
>+         observes="cmd_pasteNoFormatting" modifiers="accel, shift"/>
Nit: file style seems to be id="pastenoformattingkb"

> <!ENTITY pasteNoFormatting.label "Paste Without Formatting">
> <!ENTITY pasteNoFormatting.accesskey "o">
>+<!ENTITY pasteNoFormattingCmd.key "V">
Nit: localisers prefer all the prefixes to match i.e. pasteNoFormatting.key

>diff --git a/suite/locales/en-US/chrome/common/help/shortcuts-mailnews.xhtml b/suite/locales/en-US/chrome/common/help/shortcuts-mailnews.xhtml
:-)
Attachment #340815 - Flags: superreview?(neil) → superreview+
This is fantastic!  Has it been entered into the code base yet, or how can I make this change to my installation?  I looked at the attachment (340815), but I don't know what to do with this, or whether it can help me implement the change.  Any suggestions or guidance will be hugely appreciated.  Thanks, guys...
It's still being reviewed. When the bug resolution of this bug says "FIXED" it's available in the next nightly build (of the upcoming seamonkey2/thunderbird3). To apply the patch before that you need to make your own build.
Target Milestone: --- → seamonkey2.0a2
Comment on attachment 340815 [details] [diff] [review]
proposed fix

Looks good to me, whichever way you fight out the key id with Neil.
Attachment #340815 - Flags: review?(philringnalda) → review+
changeset:   510:b4f6d29f34bb
http://hg.mozilla.org/comm-central/rev/b4f6d29f34bb

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
(In reply to comment #25)
> PS. (In reply to comment #11)
> > Ctrl+Alt+V is reserved for Windows lnk shortcut hotkeys.
> 
> What are "Windows lnk shortcut hotkeys"? Are they ever used? (i don't) Can they
> be overridden?

Ctrl+Alt+foo should NEVER be used as a shortcut on Windows programs, because Ctrl+Alt is equal to AltGr in this OS.
Read this post for explanation: http://blogs.msdn.com/oldnewthing/archive/2004/03/29/101121.aspx
(In reply to comment #32)
> (In reply to comment #25)
> > PS. (In reply to comment #11)
> > > Ctrl+Alt+V is reserved for Windows lnk shortcut hotkeys.
> > 
> > What are "Windows lnk shortcut hotkeys"? Are they ever used? (i don't) Can they
> > be overridden?
> 
> Ctrl+Alt+foo should NEVER be used as a shortcut on Windows programs, because
> Ctrl+Alt is equal to AltGr in this OS.
> Read this post for explanation:
> http://blogs.msdn.com/oldnewthing/archive/2004/03/29/101121.aspx

With the possible problems with other language keyboards and/or collisions with other key combo usages, could this be user-changeable through a preference? This would require a way to code key combinations for entering into a preference, but a preference would avoid nailing someone to the wall with an unworkable key combination that is set in stone.
(In reply to comment #33)
> With the possible problems with other language keyboards and/or collisions with
> other key combo usages, could this be user-changeable through a preference?
> This would require a way to code key combinations for entering into a
> preference, but a preference would avoid nailing someone to the wall with an
> unworkable key combination that is set in stone.

This applies to all keyboard shortcuts, and I don't think anyone is going to make them configurable...

Considering Ctrl+Alt+foo shortcuts, they should simply NOT be used in default configurations, and that's it.
(In reply to comment #34)
> (In reply to comment #33)
> > With the possible problems with other language keyboards and/or collisions with
> > other key combo usages, could this be user-changeable through a preference?
> > This would require a way to code key combinations for entering into a
> > preference, but a preference would avoid nailing someone to the wall with an
> > unworkable key combination that is set in stone.
> 
> This applies to all keyboard shortcuts, and I don't think anyone is going to
> make them configurable...
> 
> Considering Ctrl+Alt+foo shortcuts, they should simply NOT be used in default
> configurations, and that's it.

Pardon me for getting off track.  With the previous comment (#32) referring to Ctrl+Alt+V, I got confused and thought this was the proposed keyboard shortcut for Paste Without Formatting.  (My bad!)  Ctrl+Shift+V seems to work well without any of the problems I mentioned in comment #33, so please ignore those remarks.
I have never been more tempted to curse in a bug report than I am about this.

Hey, here's an idea for SeaMonkey council: Before taking away features,
why not PUBLICLY ASK users if they use the features?  

Word Perfect?  
We care more about WP users than about the established base of SM users?  

Thus is a HUGE reduction is usability for email composer for me.  

Give me back this feature that I've used MANY TIME EVERY DAY for 10 years!
(In reply to comment #0)
> * The shortcut for "Paste as quotation" doesn't appear in menus or in
> http://www.mozilla.org/docs/end-user/moz_shortcuts.html, so I don't think many
> current users know about the shortcut I'm proposing we change.
I admit I didn't know about it either. Wow, it even works in 1.6! (Don't ask.)

On the offchance that it helps, apparently if you enable the middle-click paste preference then Control+middle-click pastes as quotation.
(In reply to comment #37)
> > * The shortcut for "Paste as quotation" doesn't appear in menus

This is wrong. 
When in composer, "Edit->Paste As Quotation (Ctrl+Shift+V)" is shown in SM 1.1.12 etc.

Ctrl+Shift+V are three keys.
Alt-E,Q are three keys, too. (Given you're not on Mac.)

(In reply to comment #36)
> Hey, here's an idea for SeaMonkey council: Before taking away features,
> why not PUBLICLY ASK users if they use the features?  

We can't hold public conferences for each reassigned key.
No feature was taken away, Paste As Quotation is still there.

> Thus is a HUGE reduction is usability for email composer for me.  

I, personally, use Paste As Quotation quite frequently and I probably never used Paste without formatting - but I'm using no HTML whatsoever in mail (always plaintext everywhere), so I'm a dying species, probably - see comment #22.
Karsten, the keyboard shortcut is a feature. 
The removal of that keyboard shortcut is the loss of a feature.

You don't need to hold a conference.  
A disucssion in mozilla's seamonkey would be a good start.

Besides "Paste without formatting", there is another paradigm, which is to 
paste, and then separately remove formatting.  I'd suggest using that one.

I'll go back to an earlier build of SM trunk, for a while, and stay there
until this feature is restored or I decide to switch to another mail program.
(In reply to comment #39)
> I'll go back to an earlier build of SM trunk, for a while, and stay there
> until this feature is restored or I decide to switch to another mail program.

A more constructive approach might be to suggest an alternate shortcut for paste as quotation. And to file a separate bug on that.

How about Ctrl+Shift+Q
Here's an idea.  Put the old keyboard shortcut back, and give a NEW shortcut 
(such as ctrl-shift-Q) to the NEW feature, paste without formatting.
I suggest we better take the approach suggested in Comment #0:

* "Paste as quotation" only lets you increase the quotation level, so there
should be "Increase quotation level" and "Decrease quotation level" commands
anyway.

I just filed Bug 460975 requesting this functionality.
It makes sense for "without formatting" to be Ctrl+Shift+V, to match the normal Ctrl+V. Shift for the opposite format, like many other commands.

Paste as quotation is virtually unknown outside mozilla mail apps (afaik), and therefore people wouldn't relate it as opposite to anything.
(In reply to comment #43)
> Paste as quotation is virtually unknown outside mozilla mail apps (afaik), and
> therefore people wouldn't relate it as opposite to anything.

I never thought about it this way, but indeed, there's no "Paste with one level of quotation stripped"...

I think the main problem is a clash of cultures here: on the one hand, old plaintext editor dinosaurs like me who have no real need for "paste without formatting", because all you can paste is in fact ... text. OTOH, HTML script kiddies :-P write text on top of full quotes anyway and don't care for proper quoting... ;-)

Anyway, "Paste as Quotation" was implemented only half-heartedly, because it doesn't distinguish between "real" and "third party" quotes. It's common practice to use | for external quotes when using > for normal quotes, e.g.:

>> Read the RfC!
> Which paragraph?

This one:
| The use of SHOULD, MUST and NEEDS NOT in this
OK, so keep paste-as-quotation in the plain text composer, and 
pates-without-formatting in the html composer.  Let the keyboard shortcut
do different things in the different composers.  Then I'll just have to 
never use the html composer.  :)
(In reply to comment #45)
> OK, so keep paste-as-quotation in the plain text composer, and 
> pates-without-formatting in the html composer.  Let the keyboard shortcut
> do different things in the different composers.  

This would be counter-intuitive, and make the Composer widget inconsistent with itself.
I'm voting for Ctrl+Shift+V for 'paste without formatting' to maintain consistency with Ctrl+V for 'paste.' And as Ctrl+Shift+Q was suggested for 'paste without formatting,' how about instead using this shortcut for 'paste as quote,' which the "Q" is more suggestive of anyway? That way the 'paste as quote' advocate could still have a keyboard shortcut for that operation, and not have to switch to a new mail program.
(In reply to comment #47)
> And as Ctrl+Shift+Q was suggested for 'paste without formatting,' how
> about instead using this shortcut for 'paste as quote,' which the "Q"
> is more suggestive of anyway? 

This was discussed in Comment #13 and below.
OK, I just filed bug 461117 to provide a keyboard combo for paste as quotation (CTRL+SHIFT+Q).

This is something both Thunderbird and Seamonkey would benefit from, so I made it a Thunderbird bug (don't know how to make a bug for both, and I use Thunderbird).
Thank you Magnus !
For those who have a combination of skill and desperation, look at comment 10 for bug 273008.  There is an addon to deal with keyboard shortcuts.  Nearly saved my computer from being tossed out the window, it did.
> There is an addon to deal with keyboard shortcuts. 

In Tbird.  This is a SeaMonkey bug.  That addon doesn't apply to SM.
(In reply to comment #52)
> > There is an addon to deal with keyboard shortcuts. 
> 
> In Tbird.  This is a SeaMonkey bug.  That addon doesn't apply to SM.

Keyconfig also works in SM2, just set the hidden extensions.checkCompatibility to false, install Keyconfig, add command goDoCommand('cmd_pasteQuote') and there you go. Furthermore I think there will be no problem convincing the author to officially support SM 2 once it is released.
You need to log in before you can comment on or make changes to this bug.