Closed Bug 461117 Opened 11 years ago Closed 10 years ago

Implement new keyboard shortcut for Paste as Quotation (Now that CTRL+SHIFT+V is for Paste Without Formatting)

Categories

(MailNews Core :: Composition, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: Peter, Assigned: neil)

References

(Blocks 1 open bug)

Details

(Keywords: fixed-seamonkey2.0, regression)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081021 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081021 Lightning/1.0pre Shredder/3.0b1pre

CTRL+SHIFT+Q for Paste as Quotation (Now that CTRL+SHIFT+V is for Paste Without Formatting)

In the distant past, CTRL+SHIFT+V used to paste as quotation, so several long-time users are used to having a keyboard shortcut for it. Although paste as quotation is less used than paste without formatting, it would still be useful to have a keyboard shortcut for it if a sensible is still available. I propose to use CTRL+SHIFT+Q ("Q" for quote).

This is a spinoff bug from bug 192330 Comment #13. Hopefully, this will be useful for both Thunderbird and Seamonkey.

Reproducible: Always

Steps to Reproduce:
1. Copy some formatted text (bold + larger + red) from a web page
2. compose an e-mail in Thunderbird
3. press CTRL+SHIFT+Q
Actual Results:  
Nothing happens. The key combo seems not bound to any action.

Expected Results:  
CTRL+SHIFT+Q should paste the copied text into the e-mail as a quote.

> This is quoted and *formatted* text.

PS. Microsoft Outlook and Lotus Notes don't seem to recognize Mozilla's quote format - they simply don't display that the text is quoted. Perhaps, until this is resolved (presumably by MS and Lotus), Mozilla could also *indent* quoted text?
Since people used to be able to use a keyboard combo to paste as quote, this bug can be considered a kind of regression. Marking as such...

Also marking "Wanted for Thunderbird 3" for the same reason.
Flags: wanted-thunderbird3?
Keywords: regression
This bug is related to (or might conflict with) bug 460975.
Component: Message Compose Window → Editor
Flags: wanted-thunderbird3?
Product: Thunderbird → Core
Version: unspecified → Trunk
Flags: wanted1.9.1?
So I'd have said MailNews Core: Composition would be a better place for this. Though this also seems to be a duplicate of bug 460847 which is currently in SM.
I wonder how many folks will complain that this is too close to Ctrl+Q... 9_9
QA Contact: message-compose → editor
AFAIK, paste as quotation was always purely a mailnews feature.  
Firefox never had it.  I believe that makes it a mailnews core bug, not
a core composer bug.  Note that there is already a core mailnews bug
about this.  bug 460847.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #5)
Bug 460847 is *seamonkey* only. I want this function for Thunderbird! So I thought "Core - Editor" would cover both.
Peter, you want product "Mailnews core", component "composition", I think.
Component: Editor → Composition
Product: Core → MailNews Core
Duplicate of this bug: 484668
Asking "wanted" for Tb & Sm. I hope this is a really easy fix.

BTW: I often want to paste un-formatted *and* as quotation. It would be cool to have a keyboard shortcut for that too. CTRL+SHIFT+ALT+V or CTRL+SHIFT+ALT+Q ? :-)
Flags: wanted-thunderbird3?
Flags: wanted-seamonkey2?
fixing qa contact
QA Contact: editor → composition
Duplicate of this bug: 496112
The current behavior will probably useless for a couple of people who don't use html messages. It will be always greyed out. Why the shortcut has been changed and no new one has been taken for paste as formatting? This change will break the usual way how users operated the last years.
Mac OS X uses shift-command-Q for Log Out, so another keyboard shortcut should be assigned. Why can't we use our old favourite shift-commnd-V?

I tried to assign option-shift-command-V to Paste without Formatting and shift-command-V to shift-command-V using Mac OS X Keyboard Preferences, but didn't help.
(In reply to comment #13)
> I tried to assign option-shift-command-V to Paste without Formatting and
> shift-command-V to shift-command-V using Mac OS X Keyboard Preferences, but
> didn't help.

Sadly this will not work due to bug 429824.
(In reply to comment #13)
> Mac OS X uses shift-command-Q for Log Out, so another keyboard shortcut should
> be assigned. 

Could this be done only for the Mac? (very low market share) How are other keyboard shortcut differences between OSs handled in Thunderbird? Is there a "Q" combo that is available on Mac? Cmd+Alt+Q?

> Why can't we use our old favourite shift-command-V?

This has been discussed extensively elsewhere. Briefly: more people want to paste stuff (e.g., from formatted web pages) than quote stuff. This will cause some inconvenience to some people (at least until this bug is fixed) but benefits a larger set of users.
(In reply to comment #15)
> This has been discussed extensively elsewhere. Briefly: more people want to

Can you please give a reference? Thanks.
You could start with bug 192330, and then perhaps find something in the older Thunderbird newsgroup posts (news://news.mozilla.com:119/mozilla.dev.apps.thunderbird).

Workaround (Mac too?): Alt-E,Q (see bug 192330 Comment #38)
I think a more accurate statement is that pasting formatted stuff is a feature
of a competing product, and having that feature in TB is believed to be more 
likely to attract users of that competing product to TB than the existing
paste-as-quotation feature would attract.
What competing product? Neil certainly didn't do anything for Tb marketing, since he can't stand us, so you must mean that I reviewed a patch for marketing reasons - if so, it would be nice if I knew what product I was trying to catch up to.
Oh, you were *joking*! Sorry, I didn't get that.
(In reply to comment #15)
> Could this be done only for the Mac? (very low market share) How are other
> keyboard shortcut differences between OSs handled in Thunderbird? Is there a
> "Q" combo that is available on Mac? Cmd+Alt+Q?

Well, I don't know whether shift-command-Q is assigned to Paste As Quotation in Thunderbird Mac. At least no keyboard shortcut appears next to the menu item, and typing shift-command-Q invokes logout confirmation message.
command-option-Q doesn't seem to be "reserved" for a system-wide command.

(In reply to comment #14)
Thanks for the info. I will wait for a fix for bug 429824.
I don't see any reason to give this special priority, but it's also not unwanted, so cancelling the wanted flag.
Flags: wanted-seamonkey2.0?
Attached patch Possible patch (obsolete) — Splinter Review
I don't know about Thunderbird, but on SeaMonkey this is an editor bug ;-)

I couldn't come up with a better key than Accel+Shift+Q, unless we can get away with swapping the Quit and Quote keys perhaps?
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #401827 - Flags: review?(iann_bugzilla)
Attachment #401827 - Flags: review?(bugzilla)
Comment on attachment 401827 [details] [diff] [review]
Possible patch

>+    <td>Paste As Quotation</td>
>+    <td>Ctrl+Shift+V</td>
>+    <td>Cmd+Shift+V</td>
>+    <td>Ctrl+Shift+V</td>

I think you mean Q here?

Moving "Quit" away from the standard Accel-Q key will make Unixoid users very unhappy...
(In reply to comment #25)
> Moving "Quit" away from the standard Accel-Q key will make Unixoid users very
> unhappy...

Why "will"? I guess you mean "would", as he's not doing that here - and you're right, it would make many people unhappy, probably not just Unix users...
(In reply to comment #25)
> I think you mean Q here?
Sorry, too much copypasta :-(
(In reply to comment #26)
> Why "will"? I guess you mean "would"

Yes, of course.
I really would prefer to stay away from key combinations involving Q 
because one wrong move and I've just blown away the entire process and 
all its windows.
At least if using the Q key I don't think we want this in Thunderbird.  As Nelson has experienced, we'll be requiring Mac users to walk a tight rope of key codes between pasting as quotation and quitting everything.
Flags: wanted-thunderbird3? → wanted-thunderbird3-
Make an alternate suggestion then. Let's get this problem solved.

CTRL+SHIFT+O (quOte)?
Bryan, I think you know better than to imagine that the people who requested
this feature want it to be ctrl+shift+Q or nothing.  They want the feature
that was taken out put back in some usable manner.  

Personally, I think you should give users a choice of what CTRL+SHIFT+V does.
Let the user decide between "paste as quotation" and "paste without formatting".
TB should be empowering users, not disempowering them.
Flags: wanted-thunderbird3- → wanted-thunderbird3?
Summary: CTRL+SHIFT+Q for Paste as Quotation (Now that CTRL+SHIFT+V is for Paste Without Formatting) → Implement new keyboard shortcut for Paste as Quotation (Now that CTRL+SHIFT+V is for Paste Without Formatting)
Not that I'm surprised about the opposition to Q... ;-)
Accel-Shift-O sounds reasonable, though.
(In reply to comment #32)
> Bryan, I think you know better than to imagine that the people who requested
> this feature want it to be ctrl+shift+Q or nothing.  They want the feature
> that was taken out put back in some usable manner.  

Considering both the previous title and the posted patch it seemed pretty obvious of the direction being taken.  :)

> Personally, I think you should give users a choice of what CTRL+SHIFT+V does.
> Let the user decide between "paste as quotation" and "paste without
> formatting".

That sounds good to me.  I think we'll just need to balance that choice with user work flow.  If a person is always pasting without formatting it doesn't seem like a good idea to always ask them.  We would need a design that could accommodate a balance of choice with efficiency.

This direction would be a bit more complicated that assigning an alternate key.

> TB should be empowering users, not disempowering them.

I think everyone agrees with this
Comment on attachment 401827 [details] [diff] [review]
Possible patch

>--- a/editor/ui/locales/en-US/chrome/composer/editorOverlay.dtd	Sun Sep 20 21:41:34 2009 +0100
>+++ b/editor/ui/locales/en-US/chrome/composer/editorOverlay.dtd	Mon Sep 21 13:48:14 2009 +0100
>@@ -98,6 +98,7 @@
> <!ENTITY publishSettings.accesskey "b">
> <!ENTITY pasteAsQuotationCmd.label "Paste As Quotation">
> <!ENTITY pasteAsQuotationCmd.accesskey "Q">
>+<!ENTITY pasteAsQuotationCmd.key "q">
I prefer Accel+Shift+O for the key.

>--- a/suite/locales/en-US/chrome/common/help/shortcuts-mailnews.xhtml	Sun Sep 20 21:41:34 2009 +0100
>+    <td>Paste As Quotation</td>
>+    <td>Ctrl+Shift+V</td>
>+    <td>Cmd+Shift+V</td>
>+    <td>Ctrl+Shift+V</td>
As pointed out elsewhere, this is incorrect, should be the same as the key specified above. In this case now O

r=me with those changes.

Any user configurable keyboard shortcuts are outside scope of this bug.
Attachment #401827 - Flags: review?(iann_bugzilla) → review+
(In reply to comment #30)
> At least if using the Q key I don't think we want this in Thunderbird.  As
> Nelson has experienced, we'll be requiring Mac users to walk a tight rope of
> key codes between pasting as quotation and quitting everything.

Except ctrl+shift+Q would still cause a confirmation dialog where you could just cancel the quit (if you have written anything).
(In reply to comment #36)
> Except ctrl+shift+Q would still cause a confirmation dialog where you could
> just cancel the quit (if you have written anything).

I just don't think that's a behavior we'd want to aim for.  This key code could work for Windows where AFAIK ctrl-q isn't used for quit (or anything) but for Mac + Linux I don't think it would be good behavior and we might want to use 'O' or something else there.
(In reply to comment #32)
> Personally, I think you should give users a choice of what CTRL+SHIFT+V does.
> Let the user decide between "paste as quotation" and "paste without
> formatting".

I don't think that's a good idea. Depending how that would be implemented, it would either force users to answer a dialog every time, or it would force them to choose one over the other in the options. I use both functions and want to use them without either being slowed down by a interjecting dialog or having to choose only one in the Options. Anyhow, that feature would be a separate bug.

The best solution would be the ability to quickly (i.e., without interrupting dialog) execute Paste-without-formatting or Paste-as-quotation. That's why this bug is the better solution.

CTRL+SHIFT+V = Paste-without-formatting

CTRL+SHIFT+O = Paste-as-quotation

BTW: It would be great if someone could "sneak in" (meaning: implement with this bug) an additional keyboard shortcut for the ability to Paste-without-formatting *and* Paste-as-quotation with just one keystroke. :-) CTRL+SHIFT+ALT+V and/or CTRL+SHIFT+ALT+O?
Comment on attachment 401827 [details] [diff] [review]
Possible patch

Neil, the patch looks generally reasonable, but from the comments on the bug I'm not sure if you're happy with going with 'O'. I think clarkbw would be.

Therefore cancelling review to send a flag to get that clarification.
Attachment #401827 - Flags: review?(bugzilla)
Attached patch Proposed patch (obsolete) — Splinter Review
Ctrl+Shift+O version.
Attachment #401827 - Attachment is obsolete: true
Attachment #402360 - Flags: review?(bugzilla)
Attached patch The fixSplinter Review
I've ported the relevant parts of this patch across to make sure they work on Thunderbird. r+a=Standard8
Attachment #402360 - Attachment is obsolete: true
Attachment #403605 - Flags: review+
Attachment #403605 - Flags: approval-thunderbird3+
Attachment #402360 - Flags: review?(bugzilla)
Pushed changeset f6d7c851c905 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
Flags: wanted1.9.1?
Flags: wanted-thunderbird3?
What does "fixed seamonkey" mean in a "mailNews-core" bug that is marked a FIXED? Do we now need a new bug to get this fixed in Thunderbird? I filed THIS bug for Thunderbird!
Flags: wanted-thunderbird3?
Re-removing "wanted Tb3". I didn't see the new target milestone:Tb3rc1". Sorry for the bugspam.
Flags: wanted-thunderbird3?
(In reply to comment #43)
> What does "fixed seamonkey" mean in a "mailNews-core" bug that is marked a
> FIXED? Do we now need a new bug to get this fixed in Thunderbird?
It means that I know that the patch fixes it for SeaMonkey, and I don't know how to flag the bug as being fixed for Thunderbird ;-) This is a MailNews Core bug because it affects shared editor code.
You need to log in before you can comment on or make changes to this bug.