[win32] use system beep on Windows for notification

RESOLVED FIXED in mozilla1.8.1alpha2

Status

SeaMonkey
Find In Page
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: philor)

Tracking

({fixed-seamonkey1.1a, fixed1.8.1})

1.8 Branch
mozilla1.8.1alpha2
fixed-seamonkey1.1a, fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
spun off from bug 185905.

find as you type should use the win32 OS beep for notifications. mail
notification and popup blocking does this by default. since win32 offers a
control panel where the user can change the sound, the configuration should go
there --rather than adding complexity / bloat to mozilla.

Comment 1

15 years ago
*** Bug 207402 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
You can just set

user_pref("accessibility.typeaheadfind.soundURL", "beep");

to get this behaviour.
(Assignee)

Comment 3

12 years ago
Created attachment 216613 [details] [diff] [review]
fix

Rationale: on Mac or Linux, if you are deaf, the checkbox in your system prefs that you checked when you first got your computer causes the window/titlebar to flash for typeaheadfind, on Windows you have to either keep looking down to the statusbar, or discover that changing a hidden pref will make it work; on Mac or Linux, if you are working at the library or somewhere else quiet, telling your OS to shut up will shut up typeaheadfind, on Windows you have to either know about and remember an unobvious pref for SeaMonkey, or a hidden pref for Firefox.
Assignee: aaronleventhal → philringnalda
Status: NEW → ASSIGNED
Attachment #216613 - Flags: superreview?(jag)
Attachment #216613 - Flags: review?(aaronleventhal)
(Assignee)

Comment 4

12 years ago
*** Bug 331990 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

12 years ago
*** Bug 315354 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Attachment #216613 - Flags: superreview?(jag) → superreview+

Updated

12 years ago
Attachment #216613 - Flags: review?(aaronleventhal) → review?(mconnor)
Comment on attachment 216613 [details] [diff] [review]
fix

Ok, worth a shot, especially in alpha.
Attachment #216613 - Flags: review?(mconnor) → review+
(Assignee)

Updated

12 years ago
Keywords: helpwanted
Whiteboard: [checkin needed]
(Assignee)

Comment 7

12 years ago
Comment on attachment 216613 [details] [diff] [review]
fix

Maybe I can make it aaronlev's fault this way instead ;)
Attachment #216613 - Flags: approval-branch-1.8.1?(aaronleventhal)

Comment 8

12 years ago
Comment on attachment 216613 [details] [diff] [review]
fix

Sorry Phil, I don't own this code anymore. Don't want anything to do with it.
Attachment #216613 - Flags: approval-branch-1.8.1?(aaronleventhal)
Comment on attachment 216613 [details] [diff] [review]
fix

Let's get this on branch too, get the real feedback!
Attachment #216613 - Flags: approval-branch-1.8.1+
mozilla/modules/libpref/src/init/all.js 	3.585.2.28
mozilla/modules/libpref/src/init/all.js 	3.628
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.8.1alpha2
Version: Trunk → 1.8 Branch
Status: RESOLVED → REOPENED
Keywords: fixed-seamonkey1.1a
Hardware: All → PC
Resolution: FIXED → ---
Target Milestone: mozilla1.8.1alpha2 → ---
Version: 1.8 Branch → Trunk
oops
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8.1alpha2
Version: Trunk → 1.8 Branch
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.