Status

SeaMonkey
Help Documentation
--
enhancement
18 years ago
7 years ago

People

(Reporter: Caspy7, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
We've added (and are adding) a lot of new features to 5.0.
I think a Netscape QuickTips system should be implemented because of
these new features and even the existing cool but unknown features from
4.x.

The first time you run the browser it would pop up telling about how to
best utilize one of these features.  This could tell about how to change
the skin and deal with the sidebar, etc.  The Mail component would of
course have a separate QuickTips system (even I would benefit from this)
and there would be a check box for "Don't show this on startup."

One would be able to skip to the next tip, and then the next, in order
to learn a lot in a short period of time.  The QuickTips would also be
accessible from the help menu, and perhaps searchable from the help
system.

Please tell me what you think, what you like, don't like, or would make
better.

Mark
(Reporter)

Updated

18 years ago
Whiteboard: HELP WANTED

Comment 1

18 years ago
Neat idea. Are you volunteering to implement this? ;)

(I don't believe our understaffed Help folks have the ability to add any more
work to their already over-stuffed plates.)

Comment 2

18 years ago
Hmm. "All successful application suites expand until a startup tips
screen is implemented" ? It is definitely time with Mozilla.

The best way I can see to get a rough list started for this would be to post
a message much like this RFE to the n.p.m.general and n.p.m.documentation
newsgroups (followups to the latter) and hope for some responses -
but to supplement the hope, get MozillaZine to talk it up.
Go for it, mobius!

This does look like serious work to finish, but aside from the startup tips
dialog, these same tips would be perfect fodder for media that want a sidebar
for their Navigator 5 launch stories.

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Keywords: helpwanted
Whiteboard: HELP WANTED

Comment 3

17 years ago
I agree that Mozilla could gain a lot from this feature.

We can easily employ Mozilla resources for writing the content (tips). We would
need a responsible person who overlooks it and decides the order.

But first, we need the infrastructure, speak "code". Who is going to implement
this? verah, do you have time for this?

Removing "Netscape" from SUMMARY.
Summary: Netscape QuickTips → QuickTips

Comment 4

17 years ago
hm, aren't QuickTips these yellow boxes, which appear some time after a
mouseover? Setting SUMMARY to "Tip of the day".
Summary: QuickTips → Tip of the day

Comment 5

17 years ago
Sorry, I don't have time currently, though I could supply a rough list of new 
features, tips, etc. Someone else would have to implement it.

I do wish I had time!
Target Milestone: --- → Future

Comment 6

17 years ago
Updating QA Contact to elig...welcome back!

Comment 7

17 years ago
I'd suggest that when this does get done, the first priority should be 
tips on how to do things that can no longer be done the 4xp way. 
An example:

A single click in the location (URL) bar no longer selects the entire URL 
(see bug 37587). That was 4xp, but won't be replicated. 

For those who primarily use the mouse and wouldn't think of tabbing to
the location bar to select its contents, it would be useful to mention
in a tip that double-clicking will select the entire URL.

Comment 8

17 years ago
cc'ing rosilene and rleggins to see if they are interested in making this happen.

Comment 9

17 years ago
qa assigning open/resolved help bugs to paw
QA Contact: elig → paw
spam: mass-moving currently open help bugs to Terri, who now does qa on 'em. :)
QA Contact: paw → tpreston

Comment 11

17 years ago
Does anyone have any evidence that Tips of the Day have ever caused a net speed 
increase in users' use of any product, rather than causing a net slowdown where 
the time required to read and dismiss the dialog on startup is greater than the 
time saved by the knowledge it imparts?

If our interface has behaviors which can only be explained by a Tip of the Day 
feature (rather than implied by the interface itself), for something as basic as 
a Web browser or mail program, I think we should attack the root UI problems 
rather than try to explain them away with Tips of the Day.

Comment 12

17 years ago
Matthew, the user has the chance to easily disable this feature, and I often do
so. But *if* I took the chance to read a few tips (in pther apps), they often
turned out to be very useful and helpful.

I agree that there are other methods to achive the same (better UI,
context-sensitive help, manual), but this is an additional help for the user.

BTW: Don't assume we are in a perfect world. Even if it might be possible to
avoid a tip by improving the UI, it might be to costy at this time, and giving a
tip is better than not doing so.

Comment 13

17 years ago
If you are completely convince, that this feature is unecessary in all cases,
please proof it (listing all possible cases where it might help, and showing
that all of them are better achieved via other methods; don't forget to consider
time).

Comment 14

17 years ago
Ben, I believe that is known as `putting the shoe on the other foot'. For an RFE, 
surely the onus is on its supporters to present a convincing argument that it 
would be a *net* usability win, not on its detractors to prove that in `all 
possible cases' (your words) it would be a usability loss.

I could give you a list of all the bits of stupid UI in Mozilla which would 
require Tips of the Day to explain; but such a list would take several weeks to 
compile, and I'd rather report them as separate bugs instead.

Comment 15

17 years ago
> putting the shoe on the other foot
Matthew, as I said, I know from my own experience that this feature was very
helpful. It is a nice way to
- welcome new users and introduce them to the app
- constantly improve the productivity of the user, even for advanced users.
(Late tips could even point to hidden prefs.)
Also, most large apps employ this feature, and Mozilla surely is a large app.
So, IMO, it is your job to argue, if you disagree with the common practice.

> bits of stupid UI in Mozilla

Surely compiling such a list is faster than fixing all those "bugs". Given that
we don't have the time to fix all UI problems, not even for Moz1.0, we should
give the user hints instead of leaving him alone with the problems.

Comment 16

17 years ago
> *net* usability win

Also, users are not that dumb. They will disable the feature, when they don't
think, it is still rewarding.

Comment 17

16 years ago
Regarding Sean's 6/21 comment, the information about double-clicking to select a 
URL in N6 (vs. single-clicking as was done in Communicator 4.x) was added to the 
Upgrading to Netscape 6 document posted at http://home.netscape.com/browsers/
upgrade.html.

Comment 18

16 years ago
*** Bug 103608 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
Whatever Peter says that bug was a dup of this one. Anyway I'll resolve them the
other way round if it makes people happy. How can his be a tracking bug if
there's no dependencies, more of a case of someone at Netscape filing a bug for
a feature they want in and not checking for duplicates (although most of us are
guilty of that sometimes)

*** This bug has been marked as a duplicate of 103608 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 20

16 years ago
I absolutely hate old bugs being duped against new ones. Reopening and making
the new one block this one.
Status: RESOLVED → REOPENED
Depends on: 103608
Resolution: DUPLICATE → ---

Updated

15 years ago
Blocks: 103608
No longer depends on: 103608

Comment 21

15 years ago
Once I finish up my current work with Help, I might think about doing this.  It
might be a nice way to learn some simple XUL.

Comment 22

14 years ago
I think these should be duplicates, not dependencies.

Comment 23

14 years ago
*** Bug 96844 has been marked as a duplicate of this bug. ***

Comment 24

14 years ago
I've created an extension for Mozilla Firebird that adds a "Tip of the Day" bar
to the bottom of the content area.  CTRL+F1 shows/hides it, and preferences
control what tip to show on startup.  You can install it <a
href="http://thekleins.freeservers.com/ext/tipbar.xpi">here</a>

Updated

14 years ago
QA Contact: tpreston → stolenclover
Product: Browser → Seamonkey

Comment 25

12 years ago
See Bugzilla Bug 298026

Comment 26

12 years ago
Since it is also in Firefox, shouldn't this be moved to core?

Comment 27

12 years ago
worcester12345@yahoo.com: no, because the individual apps may choose to do it
differently, or not at all.
Assignee: verah → neil.parkwaycc.co.uk
Status: REOPENED → NEW

Comment 28

12 years ago
There is a bugzilla for these Mozilla "projects", but I am not seeing the
tipzilla one. Anyone know how to report this?

Comment 29

12 years ago
Created Bugzilla Bug 308226 Add Tip of the Day for Firefox before 1.5 for Firefox.

Comment 30

11 years ago
(In reply to comment #29)
> Created Bugzilla Bug 308226 Add Tip of the Day for Firefox before 1.5 for
> Firefox.
> 

The Firefox version of this bug was WONTFIX 'd. I imagine this one will be also then.
Priority: P3 → --
Target Milestone: Future → ---
KompoZer has a Tip of the day feature, FWIW. It could be easily ported to SeaMonkey if there is interest in fixing this.

Comment 32

7 years ago
(In reply to comment #31)
> KompoZer has a Tip of the day feature, FWIW. It could be easily ported to
> SeaMonkey if there is interest in fixing this.

Please do!
(In reply to comment #32)
> (In reply to comment #31)
> > KompoZer has a Tip of the day feature, FWIW. It could be easily ported to
> > SeaMonkey if there is interest in fixing this.
> 
> Please do!


:-) Not that I'm able to do it myself, it was just a pointer in case someone with enough XUL knowledge can do it.

FWIW, it seems the TOTD code in KompoZer is fairly simple:

http://kompozer.svn.sourceforge.net/viewvc/kompozer/trunk/mozilla/composer/extensions/tipoftheday/

I guess an extension could be written with that code to test it in SeaMonkey trunk.
You need to log in before you can comment on or make changes to this bug.