Find as you Type does not honour current frame

VERIFIED DUPLICATE of bug 185824

Status

SeaMonkey
Find In Page
P4
minor
VERIFIED DUPLICATE of bug 185824
15 years ago
10 years ago

People

(Reporter: Luiz-Otavio Zorzella, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Contrary to finding with a CTRL-F, the find as you type does not start at the
currently selected frame, but rather always starts at the "firt" frame. I.e.
from the url given (javadocs for jdk 1.4), typing "/drag" will always match
first the left bottom frame, even if the right frame is the current frame.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
I see it also. Linux 2003031308

Comment 2

15 years ago
-> All/All (OS X 1.3)
OS: Linux → All
Hardware: PC → All

Comment 3

15 years ago
Once upon a time, regular find didn't work with frames either.  Thankfully that
has been fixed.  However I confirm this with search as you type find.

To reproduce:
Go to http://java.sun.com/j2se/1.4.1/docs/api/ and click in the large frame. 
Start typing 'java' which is found multiple times as the link text in every frame.

Expected results:  
The first occurance of Java is found in the large (current) frame.

Actual results:
The first occurance of Java is found in the top left (first) frame.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
*** Bug 225466 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
*** Bug 209668 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Priority: -- → P4

Comment 6

14 years ago
*** Bug 246671 has been marked as a duplicate of this bug. ***
updated test URL.

also, this doesn't seem to be a problem in Firefox aviary1.0 (branch) builds.
although it is problemative in Firefox trunk bits.

Comment 8

13 years ago
I should note that the same behavior occurs with iframes (the currently selected
iframe is not used for Find As You Type, only the parent frame)
I suggest adding to the summary 'Searching text in webs with frames not working
correctly' or something like that, it would avoid duplicates.
Fixed back in September in bug 185824

*** This bug has been marked as a duplicate of 185824 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 11

13 years ago
*** Bug 263878 has been marked as a duplicate of this bug. ***
I think this should be more severe than "minor".
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.